You are not logged in.

#1 2018-05-27 21:03:41

nannerpussy
Member
Registered: 2017-02-15
Posts: 87

World of Tanks issue, need gcc ver. used to compile wine-staging-nine

Hey, been playing World of Tanks via wine for a long time now. I stopped for a month or two and installed wine-gaming-nine (AUR package) over wine-staging-nine because of performance. However, the game no longer starts and I get the infamous:

err:seh:raise_exception Unhandled exception code

error message following an immediate client crash. The launcher works fine, game does not even launch.

Looking around with Google it sounds like this is related to the version of gcc used to compile wine. Wine is pretty sensitive to gcc apparently, but before I move back to the official repo wine-staging-nine I want to know which version of gcc was used to compile it. If it's identical to what wine-gaming-nine used, there's no point. I know there has to be an easy way to find this out, but I'm not seeing it. I looked through the package details on the Arch site, but no dice.

Secondary question: anyone else run into this with World of Tanks? They made it to 1.0 recently and I was also wondering if the big changes made could be a problem here. I've tried all kinds of different library setups, from what always worked to new ideas to making sure DX11 was disabled, but nothing helped.

Edit: By the way I have gcc version 8.1.0 installed, so that's what the AUR package wine-gaming-nine was built with. I'm wondering if wine-staging-nine in our official repo was built with this latest, or hopefully an earlier version.

Edit 2: OK, downgrading wine-staging-nine to 2.11 works. Something did go wrong with the latest wine builds, presumably the version of gcc used to compile. If anyone can give me more information about this, I'd appreciate it.

Last edited by nannerpussy (2018-05-27 21:14:38)

Offline

#2 2018-05-27 21:36:15

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 8,201
Website

Re: World of Tanks issue, need gcc ver. used to compile wine-staging-nine

Since you've got the wine-staging-nine package in your cache, you can extract the .BUILDINFO file from the package which will tell you exactly which packages were installed on the build system at the time of making the package.

e.g.

bsdtar xOf /var/cache/pacman/pkg/wine-staging-nine-2.11-1-x86_64.pkg.tar.xz .BUILDINFO | less

Note that this won't tell you which compiler was used during the build process, so you will need to cross-check with the ABS.


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#3 2018-05-27 23:13:50

nannerpussy
Member
Registered: 2017-02-15
Posts: 87

Re: World of Tanks issue, need gcc ver. used to compile wine-staging-nine

WorMzy wrote:

Since you've got the wine-staging-nine package in your cache, you can extract the .BUILDINFO file from the package which will tell you exactly which packages were installed on the build system at the time of making the package.

e.g.

bsdtar xOf /var/cache/pacman/pkg/wine-staging-nine-2.11-1-x86_64.pkg.tar.xz .BUILDINFO | less

Note that this won't tell you which compiler was used during the build process, so you will need to cross-check with the ABS.

Cool, good to know in the future. However, I'm starting to think the issue here is the new graphics engine (named Core) that they went to in 1.0. Even with earlier wine builds I am getting constant screen flickering even if I set Windows version to XP (which used to work before because it would only use DX9). If I completely disable the d3d11 library the game gives me a black screen only. I'm thinking their new engine requires DX11+ support even on lowered Standard settings and wine just doesn't handle DX11 right now.

Offline

#4 2018-05-28 00:51:43

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 5,244

Re: World of Tanks issue, need gcc ver. used to compile wine-staging-nine

Have you tried a normal non-nine version of wine? wine does support quite a bit of dx11 by now, however it's likely that that leads to interaction issues specifically with the nine patchset.

Offline

#5 2018-05-28 01:56:34

nannerpussy
Member
Registered: 2017-02-15
Posts: 87

Re: World of Tanks issue, need gcc ver. used to compile wine-staging-nine

V1del wrote:

Have you tried a normal non-nine version of wine? wine does support quite a bit of dx11 by now, however it's likely that that leads to interaction issues specifically with the nine patchset.

You know, I haven't. I've been using the gallium patches for over a year now, probably closer to two years. I don't use any prefix manager (except pywinery) + installer like POL, but I guess I'll try plain wine from the repo and if it still doesn't work I'll see if POL works with much older version of wine.

Offline

#6 2018-06-08 15:59:12

Kortaffel
Member
Registered: 2018-06-08
Posts: 1

Re: World of Tanks issue, need gcc ver. used to compile wine-staging-nine

I have exactly the same problem as you do. Wine 3.81 and following bow out with a SEH exception.
Solution: downgrade to Wine 3.7.1. Works perfect. Also remember to install dxvk for pretty graphics.
Happy tanking.

ps: check your /var/cache/pacman/pkg if you still have the old wine-staging.3.7.1 package and install it with "pacman -U wine-sta ...."

Last edited by Kortaffel (2018-06-08 16:06:09)

Offline

Board footer

Powered by FluxBB