You are not logged in.

#1 2018-06-08 20:17:37

buffalopete
Member
Registered: 2018-06-08
Posts: 5

[SOLVED] Steam hangs on 'installing breakpad exception handler'

EDIT: Solved by downgrading to lib32-nvidia-340xx-utils-340.106-2. Thanks WorMzy!

---

I've seen several other threads with the same symptoms, but nothing I've seen has pointed me in the right direction.

For the last few days, when I start Steam through the console, I get this:

/home/pete/.local/share/Steam/steam.sh: line 154: VERSION_ID: unbound variable
/home/pete/.local/share/Steam/steam.sh: line 154: VERSION_ID: unbound variable
Running Steam on arch  64-bit
/home/pete/.local/share/Steam/steam.sh: line 154: VERSION_ID: unbound variable
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(0)

Steam runs in the background but the window does not appear.

I've tried steam-runtime and steam-native, with the same result. I have steam-native-runtime installed.

ldd ~/.steam/bin/steam

tells me all my libraries are present. I have tried removing the steam package, deleting ~/.steam and ~/.local/share/Steam, and reinstalling Steam.

My uneducated guess is that it may be related to my nvidia driver. I'm using nvidia-340xx, and have been unable to upgrade to xorg-server 1.20 because of incompatibility problems similar to those described in this thread. Relevant package versions are:

xorg-server 1.19.6-2
nvidia-340xx 340.106-39
nvidia-340xx-utils 340.106-2
lib32-nvidia-340xx-utils 340.107-1

Except xorg-server as described above, these are all up to date and correct for my video card.

That's about all I know after three days of screwing around with it. If there are any other log files or information that would be helpful, please let me know, and thanks in advance for any help.

Last edited by buffalopete (2018-06-11 22:30:36)

Offline

#2 2018-06-08 20:33:14

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 8,209
Website

Re: [SOLVED] Steam hangs on 'installing breakpad exception handler'

It seems like lib32-nvidia-340xx-utils 340.107-1 got moved to [multilib] before the corresponding nvidia-340xx-utils got moved to [extra]. This discrepancy in versions may be the cause of steam not starting. Try downgrading lib32-nvidia-340xx-utils to 340.106-2.


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#3 2018-06-09 07:20:09

iruneachteam
Member
Registered: 2018-01-20
Posts: 16

Re: [SOLVED] Steam hangs on 'installing breakpad exception handler'

I have the same problem but with the 390xx drivers. Should I also downgrade lib32-nvidia-390xx-utils?
Edit: The latest lib32-nvidia-390xx-utils package on the ALA is 390.48-2, which did not solve my problem.
Edit: Downgraded nvidia-390xx and nvidia-390xx-utils to 390.59 to match with lib32-nvidia-390xx-utils. This solved my problem. Thanks WorMzy!

Last edited by iruneachteam (2018-06-09 07:43:05)

Offline

#4 2018-06-09 09:47:09

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 8,209
Website

Re: [SOLVED] Steam hangs on 'installing breakpad exception handler'

For 340xx: https://bugs.archlinux.org/task/58942

@iruneachteam: the [extra] and [multilib] 390xx packages are both at 390.59. If you had to downgrade to that level, then that suggests you're using [testing] or unsupported packages. If the former, then the explanation is that there isn't a corresponding 390.67 version of lib32-nvidia-390xx-utils in [multilib-testing] (yet?) to match the version in [testing].


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#5 2018-06-11 17:09:08

iruneachteam
Member
Registered: 2018-01-20
Posts: 16

Re: [SOLVED] Steam hangs on 'installing breakpad exception handler'

WorMzy wrote:

For 340xx: https://bugs.archlinux.org/task/58942

@iruneachteam: the [extra] and [multilib] 390xx packages are both at 390.59. If you had to downgrade to that level, then that suggests you're using [testing] or unsupported packages. If the former, then the explanation is that there isn't a corresponding 390.67 version of lib32-nvidia-390xx-utils in [multilib-testing] (yet?) to match the version in [testing].

Yes @WorMzy, I think enabling [testing] was exactly my problem. The lib32-nvidia-390xx-utils package (in [testing], I suppose) has now been updated to 390.67-2 . I updated my packages, and had no problem so far.

I have a question, but keep in mind that I have been using GNU/Linux (and Arch Linux) since December last year so forgive me if I am asking something that's too obvious, but should I disable the [testing] repository? Is there any benefit in keeping in enabled?

Last edited by iruneachteam (2018-06-11 17:09:25)

Offline

#6 2018-06-11 18:10:50

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 5,258

Re: [SOLVED] Steam hangs on 'installing breakpad exception handler'

Enabling testing means you want to help out and potentially report useful bug reports, before they hit stable users. If you don't want to do that you will have far less breakage remaining on the stable repositories. However this particular case is somewhat of a special case because those nvidia packages do fix compatibility with xorg 1.20. If you remain on 1.19 for the time being anyway, it's likely more recommended to stay on stable if you're unfamiliar with what usage of the [testing] repo entails.

Offline

#7 2018-06-11 22:29:09

buffalopete
Member
Registered: 2018-06-08
Posts: 5

Re: [SOLVED] Steam hangs on 'installing breakpad exception handler'

This worked! Thanks WorMzy, I forgot to subscribe to this thread when I posted it so didn't see any replies til just now. Thanks again!

Offline

Board footer

Powered by FluxBB