You are not logged in.

#1 2018-06-13 17:37:59

kgizdov
Member
Registered: 2015-12-08
Posts: 109

Cannot get GDM GUI

Hi,

For a while, maybe a month now, I've been getting weird behaviour at login - GDM will not show me the login screen and I would have to reboot to get it to work - I assumed it was harmless as no scary errors were reported anywhere. This happened intermittently so far, however, since yesterday I could no longer make any GUI appear. The curious part is that I still could not spot any errors or failed units that will do this. I tried disabling Wayland as well, but it had no effect.Then suddenly, after I don't know how many reboots, I finally managed to see logind and enter a GUI. I'm completely baffled.

In all instances, systemctl did not show any failures.

$ systemctl --failed
0 loaded units listed. Pass --all to see loaded but inactive units, too.
To show all installed unit files use 'systemctl list-unit-files'.

Also, these are the logs from the most recent boot attempts that did not succeed to get GUI:

journalctl --boot - https://pastebin.com/T1jEn9rx
journalctl --boot + enabled Gnome debug mode - https://pastebin.com/q2QgHbGe

and this is the success one:
journalctl --boot - https://pastebin.com/2206JiDp

I am also including the last (successful) dmesg log here - https://pastebin.com/21nLEAuv

The only real difference I can see is that in the successful boot GDM actually crashed with a segfault and was restarted, plus gnome-tracker shows a bunch of non-fatal errors (which I believe are caused by the GDM restart). But maybe I am blind to the problem... Could anyone have a look as to what is causing this?

Another curious thing is that this problem is only apparent on my laptop (Dell XPS 9350 with Intel Haswell CPU + i915 GPU) and not on my desk machine (Intel Haswell CPU + NVIDIA GPU), but both have basically the same packages and configuration apart from the GPU drivers of course.

Any ideas on what to check?

Thanks in advance!


Dell XPS 13 (9350): Core i7, 16GB, 512GB NVMe

Offline

Board footer

Powered by FluxBB