You are not logged in.

#1 2018-06-14 14:13:05

Registered: 2014-05-16
Posts: 20

can't boot : 'xhci_hcd : Abort failed to stop command ring' & other

Good afternoon,

I ran into a problem with my arch installation after modifying my grub settings. I can no longer boot, and I can't find anything relevant on google using the error messages.
This problem is very much unlike any I never had in that i could not find people with similar issues (not booting) by searching the error messages. Any help is really apreciated, because I really don't know what to do at this point except reinstalling...

Problem :
Arch doesn't boot anymore, I get error messages and get dropped in a rescue shell I can't type anything in. Arch booted fine just yesterday. I didn't update anything on arch's side.
Here is the transcript of the errors - refer to the (image) for the original error - as I couldn't find an easy way to get is as text.

starting version 238
[    16.31xxxx] xhci_hcd 0000:03:00.0: Abort failed to stop command ring : -110
[    16.31xxxx] xhci_hcd 0000:03:00.0: xHCI host controller not responding, assume dead
[    16.31xxxx] xhci_hcd 0000:03:00.0: HC died, cleaning up
[    16.31xxxx] xhci_hcd 0000:03:00.0: Error while assigning device slot ID
[    16.31xxxx] xhci_hcd 0000:03:00.0: Max number of devices with this xHCI host support is 127
[    16.31xxxx] usb usb1-port2 : couldn't allocate usb_device
ERROR: device 'UUID=72f1a793-2383-479b-b6d8-5ae31c9ca2d3' not found. Skipping fsck
mount: /new_root : can't find UUID=72f1a793-2383-479b-b6d8-5ae31c9ca2d3.
You are being dropped into an emergency shell
sh: can't acces tty: job control turned off
[rootfs ]# _

Other possible related symptom :
I booted using the arch install iso to verify the UUIDs of my disks. While in the "live session", I can list them using '$ lsblk -fs'. When chrooted in my installation, '$ lsblk -fs' only shows the drives name along with empty columns for FSTYPE, LABEL, UUID  (like so). This makes me think there may be something preventing my arch install to access correctly the disks, and perhaps that could be related to something going wrong with grub. To be honest, it's pure speculation, I'm lost here...

Setup :
Dual boot manjaro / arch, with grub installed with manjaro, EFI system.
ESP on /dev/sda1,
manjaro on /dev/sda2
arch on /dev/sda3
Other drives disconnected

Possible cause of the problem :
I updated my grub settings with grub customizer on manjaro so that arch is the OS that gets booted by default. The process took abnormally long to complete (~10 minutes), but I didn't close grub-customizer until it completed.
Now, arch does boot by default, but the grub selection menu doesn't appear, so I can't boot the other OS.

I tried :
- checking the disk UUID - they are correct
- restarting several time, physically switching off the power supply.
- googling the error messages, but I didn't find an equivalent problem, as in most cases it didn't prevent people from booting correctly, so I didn't find any suitable solution here.
- I disconnected all drives but the OS drive (and commented out their entries in /etc/fstab)
- Installing grub on the arch partition using the instructions on the wiki. Arch's grub installed successfully, generated the configuration file without errors, and loads correctly, but arch still doesn't boot and shows the same errors.

Do you have any idea where I could start to get it to boot again ? Any help is hugely apreciated, as I can't really afford to reinstall my system now...

Best regards,

Last edited by SgPepper (2018-06-14 16:42:08)


Board footer

Powered by FluxBB