You are not logged in.

#1 2018-06-15 00:55:57

Skunky
Member
Registered: 2018-01-25
Posts: 18

Can't enable autologin

Hello everyone, im trying to figure out how to enable virtual console autologin by following this guide, https://wiki.archlinux.org/index.php/Ge … al_console
It keep asking me to type the password everytime, but the user get loaded correctly what can be wrong with my system?I tried like 10 times sad i also saw some video and it should login without problem
(Sorry for my bad english)

Offline

#2 2018-06-15 01:01:51

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 25,042
Website

Re: Can't enable autologin

Share your configs: see How To Ask Questions The Smart Way.


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#3 2018-06-16 08:04:09

Skunky
Member
Registered: 2018-01-25
Posts: 18

Re: Can't enable autologin

Thanks for the reply, here is my /etc/systemd/system/getty@tty1.service.d/override.conf if it can help, anyway i solved on my notebook removing the user password
(im the only one using the computer so..i could do the same on my desktop?)

[Service]
ExecStart=
ExecStart=-/usr/bin/mingetty --autologin io --noclear %I $TERM

Last edited by Skunky (2018-06-16 08:04:38)

Offline

#4 2018-06-16 08:43:03

Haller
Member
Registered: 2018-04-08
Posts: 23

Re: Can't enable autologin

Why do you use mingetty? The wiki uses agetty.

Offline

#5 2018-06-17 09:23:45

Skunky
Member
Registered: 2018-01-25
Posts: 18

Re: Can't enable autologin

Haller wrote:

Why do you use mingetty? The wiki uses agetty.

Sorry i forgot to say i tried both in the attempt to make it work with no success sad i think i will just remove the user password at this point

Offline

#6 Yesterday 12:42:34

Seventh
Member
Registered: 2016-08-05
Posts: 47

Re: Can't enable autologin

Maybe your user needs to be in the tty group.

Offline

#7 Yesterday 18:48:52

Skunky
Member
Registered: 2018-01-25
Posts: 18

Re: Can't enable autologin

I removed the password for the user and everything works fine does it count as solved?

Offline

#8 Today 11:05:50

Seventh
Member
Registered: 2016-08-05
Posts: 47

Re: Can't enable autologin

@ loqs, im unaware of the below step covered by the wiki?

# nano /etc/conf.d/agetty.tty1
# make agetty quiet
#quiet="yes"

# Set the baud rate of the terminal line
baud="38400"

# set the terminal type
term_type="linux"

# extra options to pass to agetty for this port
agetty_options="--autologin user"

Offline

#9 Today 11:09:36

Seventh
Member
Registered: 2016-08-05
Posts: 47

Re: Can't enable autologin

It would be better of if the OP kept their password for the user.

Offline

#10 Today 11:14:33

loqs
Member
Registered: 2014-03-06
Posts: 4,883

Re: Can't enable autologin

Unneeded because Systemd#Editing_provided_units of getty@tty1.service  does not need /etc/conf.d/agetty.tty1
Even though Skunky sucessfully editted the service file it failed as you can not login to a password protected account with only a username.
Seventh and you have tried the service file you are advocating and you can log in to a password protected users account with only a username?

Offline

#11 Today 11:36:59

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 19,321
Website

Re: Can't enable autologin

Skunky wrote:

I removed the password for the user and everything works fine does it count as solved?

Whether or not it counts as solved is up to you - are you satisfied with that workaround?  I wouldn't be.  The methods linked in your first post will work just fine with a user password.  I'm not (yet) sure what the next step in troubleshooting your setup would be to figure out why it was not working for you.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Online

#12 Today 12:00:57

Skunky
Member
Registered: 2018-01-25
Posts: 18

Re: Can't enable autologin

If it works it's fine for me xD anyway im a bit worried about security now, could this be exploited by a virus for example?Or it's the same thing as having a password?

Offline

#13 Today 12:44:48

Seventh
Member
Registered: 2016-08-05
Posts: 47

Re: Can't enable autologin

loqs wrote:

Unneeded because Systemd#Editing_provided_units of getty@tty1.service  does not need /etc/conf.d/agetty.tty1
Even though Skunky sucessfully editted the service file it failed as you can not login to a password protected account with only a username.
Seventh and you have tried the service file you are advocating and you can log in to a password protected users account with only a username?

No sorry i was in an openrc session as i dislike systemd. My apologies for the confusion. Ill have to stick to strict archsystemd linux when answering vague posts in the future.

The OP has probably not created the below directory file as outlined on the wiki, https://wiki.archlinux.org/index.php/Ge … al_console

#/etc/systemd/system/serial-getty@ttyS0.service.d/autologin.conf

[Service]
ExecStart=
ExecStart=-/usr/bin/agetty --autologin username -s %I 115200,38400,9600 vt102

Offline

#14 Today 12:50:24

Seventh
Member
Registered: 2016-08-05
Posts: 47

Re: Can't enable autologin

Skunky wrote:

If it works it's fine for me xD anyway im a bit worried about security now, could this be exploited by a virus for example?Or it's the same thing as having a password?

Having no password for your user is not wise, its leaving a door open.

Offline

#15 Today 14:26:43

Skunky
Member
Registered: 2018-01-25
Posts: 18

Re: Can't enable autologin

So even if im the only one who uses the computer removing the password can be a problem?

Offline

#16 Today 14:37:40

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 19,321
Website

Re: Can't enable autologin

It'd definitely be a problem if that user is in the sudoers file and/or the wheel group, as having no password then is effectively the same as letting any process run any command as root.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Online

#17 Today 15:11:46

Skunky
Member
Registered: 2018-01-25
Posts: 18

Re: Can't enable autologin

Well it is hmm i suppose i need to set a password now sad

EDIT: WTF i just did it and no password asked at login....i will try on my other pc later

Last edited by Skunky (Today 15:14:45)

Offline

Board footer

Powered by FluxBB