You are not logged in.

#1 2018-06-15 02:55:58

Salkay
Member
Registered: 2014-05-22
Posts: 357

tlmgr not installed; can't change TeX paper size

I'd like to change my default page size from letter to A4. The wiki says the following.

Paper size
If you would like to set the default page size to something other than A4 (such as "Letter"), run the texconfig command. This command is also capable of changing other useful settings.

However, after running the texconfig command, and following the menus to change the default, I get the following error

/usr/bin/texconfig: line 799: tlmgr: command not found
/usr/bin/texconfig: line 649: tlmgr: command not found
/usr/bin/texconfig: line 1406: tlmgr: command not found
/usr/bin/texconfig: line 1266: tlmgr: command not found

Similarly, tlmgr paper doesn't work, because the tlmgr executable is missing. Should this have been installed? I have texlive-core and texlive-latexextra installed. How can I change default paper size?

Offline

#2 2018-06-17 20:17:25

Stefan Husmann
Member
From: Germany
Registered: 2007-08-07
Posts: 1,050

Re: tlmgr not installed; can't change TeX paper size

tlmgr is not included in Arch Linux' texlive-bin-package, so you cannot set the papersize globally.

Offline

#3 2018-06-17 21:47:45

Salkay
Member
Registered: 2014-05-22
Posts: 357

Re: tlmgr not installed; can't change TeX paper size

Thank you for the reply. Just to clarify, when you say "globally", do you mean "for all users", or is it impossible to set a default paper size for even a single user with Arch Linux?

Offline

#4 2018-06-18 14:36:15

Stefan Husmann
Member
From: Germany
Registered: 2007-08-07
Posts: 1,050

Re: tlmgr not installed; can't change TeX paper size

Sorry for being unclear. With "globally" i mean "for all documents" in this case. This is not related to an unix user: If tlmgr is missing, it is missing for all users.

This seems like a bug to me. I think Arch took the policy from Debian: Distros should not ship tlmgr, because it can mess up the package manger. (I do not agree to that Point, but it is the point they make).

But then tlmgr should not be needed for configuration purposes, and obviously it is.

Offline

#5 2018-06-18 23:29:37

Salkay
Member
Registered: 2014-05-22
Posts: 357

Re: tlmgr not installed; can't change TeX paper size

Stefan Husmann wrote:

Sorry for being unclear.

No worries. Thank you again for your reply.

Stefan Husmann wrote:

I think Arch took the policy from Debian

I had a bit of a search, and in Debian, you can use paperconfig. I tested the following command

paperconfig -p a4

which wrote a4 to /etc/papersize. However, this did not affect paper size when rendering to PDF.

Are there no other options at all? No text files to manually write to? I guess that installing tlmgr manually is not recommended either. Perhaps I should file a bug report for Arch?

Offline

#6 2018-06-19 07:32:47

Stefan Husmann
Member
From: Germany
Registered: 2007-08-07
Posts: 1,050

Re: tlmgr not installed; can't change TeX paper size

The PKGBUILD for texlive-bin explicitely removes, among other, also a symlink to /usr/bin/tlmgr. The actual perl script tlmgr.pl is provided by texlive-core. I removed the removal of the symlink and rebuilt texlive-bin, but then some perl modules were not found. So there seem to be some more doings.

Anyway, a feature request in th bug tracker would be the appropiate place to discuss this.

Offline

#7 Today 02:48:55

Salkay
Member
Registered: 2014-05-22
Posts: 357

Re: tlmgr not installed; can't change TeX paper size

Stefan Husmann wrote:

I removed the removal of the symlink and rebuilt texlive-bin, but then some perl modules were not found.

Thank you for testing.

Stefan Husmann wrote:

Anyway, a feature request in th bug tracker would be the appropiate place to discuss this.

I opened a task, and edited the wiki. Thank you again for your help.

Offline

Board footer

Powered by FluxBB