You are not logged in.

#1 2018-06-13 16:48:52

USRapt0r
Member
Registered: 2018-06-10
Posts: 8

qemu/kvm with -vga std not offering native resolution of my laptop

Guest system is Windows 7, and has options that bound my native resolution of 1600 x 900, such as 1440 x 900, and other ones greater.  Would like to figure out how to get 1600 x 900.  Using vncviewer, if that matters at all.

Offline

#2 2018-06-16 22:09:16

bashM0nk3y
Member
From: the big she-bang
Registered: 2018-05-26
Posts: 41

Re: qemu/kvm with -vga std not offering native resolution of my laptop

Not quite sure what you mean.. Changing the guest OS's resolution doesn't work?

Offline

#3 2018-06-20 22:20:35

USRapt0r
Member
Registered: 2018-06-10
Posts: 8

Re: qemu/kvm with -vga std not offering native resolution of my laptop

Nah, because my host res (1600x900) isn't an option, the closest being 1440x900.

Offline

#4 2018-06-22 03:06:41

bashM0nk3y
Member
From: the big she-bang
Registered: 2018-05-26
Posts: 41

Re: qemu/kvm with -vga std not offering native resolution of my laptop

USRapt0r wrote:

Nah, because my host res (1600x900) isn't an option, the closest being 1440x900.

Oh I gotcha.. I have the same problem in my recent kali VM, but I tend to prefer parrot-sec over kali anyway so its a non-issue for me.

Offline

#5 2018-06-22 13:19:59

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 6,213

Re: qemu/kvm with -vga std not offering native resolution of my laptop

Maybe try https://wiki.archlinux.org/index.php/QEMU#vnc ?

please post the full comand line you use to start the VM.


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#6 2018-06-26 03:04:42

gaofei
Member
Registered: 2017-08-11
Posts: 26

Re: qemu/kvm with -vga std not offering native resolution of my laptop

bashM0nk3y wrote:

Not quite sure what you mean.. Changing the guest OS's resolution doesn't work?

Why not send the problem to QEMU mailing lists? (If you sure it’s not an ArchLinux bug.)

Offline

#7 2018-06-28 22:27:53

USRapt0r
Member
Registered: 2018-06-10
Posts: 8

Re: qemu/kvm with -vga std not offering native resolution of my laptop

Command to run VM:

qemu-system-x86_64 -enable-kvm -drive file=/home/username/Qemu\ VMs/Win7.cow,format=qcow2 -m 2G -vga std -usb -device usb-tablet -net nic -net user,smb=/home/username/Downloads -monitor telnet:127.0.0.1:5678,server,nowait &

gaofei, if messing the vncviewer/display doesn't help I'll definitely do as you suggest.

Offline

Board footer

Powered by FluxBB