You are not logged in.

#1 2018-07-11 06:33:25

snlia
Member
Registered: 2015-12-16
Posts: 8

Can not log in gnome using Xorg

Hi all,
I encounter an issue with my Xorg. When I  tried to log in the system using gdm, the system looks like trying to load gnome but it fails after a second or less and the login interface shows again.

I looked Xorg.0.log, but no EE in there. The full Xorg.0.log is here:
http://paste.ubuntu.com/p/pfJhDWJV2k/

I notice a line in log file says:
(WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)

I don't know if it's related to my kernel configuration, because my computer cannot reboot properly without these setting(see here: https://bbs.archlinux.org/viewtopic.php?pid=1762570 )

GRUB_CMDLINE_LINUX="quiet rcutree.rcu_idle_gp_delay=1 acpi=force reboot=acpi acpi_osi=! acpi_osi=\"Windows 2009\" acpi_backlight=native"

Also my laptop has two GPU, I use bumblebeed to block NVIDIA. I don't know if it is caused by bumblebeed, so I tried to disable bumblebeed, but it still cannot log into the system:

$ lspci | grep -e VGA -e 3D
00:02.0 VGA compatible controller: Intel Corporation Device 591b (rev 04)
01:00.0 3D controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Ti Mobile] (rev ff)

The video driver I have installed:

extra/mesa 18.1.3-1
extra/xf86-video-nouveau 1.0.15-3 (xorg-drivers)
extra/xf86-video-intel 1:2.99.917+831+ge7bfc906-1 (xorg-drivers)
extra/nvidia 396.24-14
extra/nvidia-utils 396.24-2

I searched the Internet, some people say it may be caused by .Xauthority. I tried to rm .Xauthority, the system freeze a while and jump back to login interface, without creating a new .xauthority file.

A list of software I install related to Xorg:

$pacman -Qs xorg
local/xf86-input-libinput 0.27.1-1 (xorg-drivers)
    Generic input driver for the X.Org server based on libinput
local/xf86-video-fbdev 0.5.0-1 (xorg-drivers)
    X.org framebuffer video driver
local/xf86-video-intel 1:2.99.917+831+ge7bfc906-1 (xorg-drivers)
    X.org Intel i810/i830/i915/945G/G965+ video drivers
local/xf86-video-nouveau 1.0.15-3 (xorg-drivers)
    Open Source 2D acceleration driver for nVidia cards
local/xf86-video-vesa 2.4.0-2 (xorg-drivers xorg)
    X.org vesa video driver
local/xorg-bdftopcf 1.1-1 (xorg xorg-apps)
    Convert X font from Bitmap Distribution Format to Portable Compiled Format
local/xorg-font-util 1.3.1-2 (xorg-fonts xorg)
    X.Org font utilities
local/xorg-font-utils 7.6-5
    Transitional package depending on xorg font utilities
local/xorg-fonts-encodings 1.0.4-5 (xorg-fonts xorg)
    X.org font encoding files
local/xorg-mkfontdir 1.0.7-8 (xorg xorg-apps)
    Create an index of X font files in a directory
local/xorg-mkfontscale 1.1.3-1 (xorg-apps xorg)
    Create an index of scalable font files for X
local/xorg-server 1.20.0-9 (xorg)
    Xorg X server
local/xorg-server-common 1.20.0-9 (xorg)
    Xorg server common files
local/xorg-server-devel 1.20.0-9 (xorg)
    Development files for the X.Org X server
local/xorg-server-xwayland 1.20.0-9 (xorg)
    run X clients under wayland
local/xorg-setxkbmap 1.3.1-2 (xorg-apps xorg)
    Set the keyboard using the X Keyboard Extension
local/xorg-util-macros 1.19.2-1
    X.Org Autotools macros
local/xorg-xauth 1.0.10-1 (xorg-apps xorg)
    X.Org authorization settings program
local/xorg-xhost 1.0.7-2 (xorg-apps xorg)
    Server access control program for X
local/xorg-xkbcomp 1.4.2-1 (xorg-apps xorg)
    X Keyboard description compiler
local/xorg-xmessage 1.0.5-1
    Display a message or query in a window
local/xorg-xprop 1.2.3-1 (xorg-apps xorg)
    Property displayer for X
local/xorg-xrdb 1.1.1-1 (xorg-apps xorg)
    X server resource database utility
local/xorg-xset 1.2.4-1 (xorg-apps xorg)
    User preference utility for X
local/xorgproto 2018.4-1
    combined X.Org X11 Protocol headers

I syu yesterday, so software version may not be the problem. And it's not caused by update because the problem existed before I updated software.

I don't know why but, waylay works for me, however, it sometimes crashes and fills my journal with dump message(https://bugzilla.redhat.com/show_bug.cgi?id=1539258).

Any help will be welcomed!

Last edited by snlia (2018-07-11 06:56:50)

Offline

#2 2018-07-11 07:26:57

seth
Member
Registered: 2012-09-03
Posts: 8,946

Re: Can not log in gnome using Xorg

Offline

#3 2018-07-11 08:41:17

snlia
Member
Registered: 2015-12-16
Posts: 8

Re: Can not log in gnome using Xorg

seth wrote:

My xorg has this problem before this upgrade(the last time I updgraded libsystemd is [2018-04-18 21:59] [ALPM] upgraded libsystemd (238.51-1 -> 238.76-1)). I downgrade systemd and libsystemd and uncommenting that line, but that do not help... The system still tried to log in and jump back to login interface after a few seconds.

However, this time after I tried to login system, the left top of my screen blurred(I attached a picture)
https://imgur.com/vVsIy0J

Offline

#4 2018-07-11 09:02:14

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 5,705

Re: Can not log in gnome using Xorg

Can you post a journal of the failing boot?

sudo journalctl -b
systemctl status bumblebeed

Offline

#5 2018-07-11 09:14:33

snlia
Member
Registered: 2015-12-16
Posts: 8

Re: Can not log in gnome using Xorg

V1del wrote:

Can you post a journal of the failing boot?

sudo journalctl -b
systemctl status bumblebeed

I put journalctl here http://paste.ubuntu.com/p/Z8CRchnhw2/

bumblebeed is disable, and the status is:

● bumblebeed.service - Bumblebee C Daemon
   Loaded: loaded (/usr/lib/systemd/system/bumblebeed.service; disabled; vendor preset: disabled)
   Active: inactive (dead)

Offline

#6 2018-07-11 14:12:31

seth
Member
Registered: 2012-09-03
Posts: 8,946

Re: Can not log in gnome using Xorg

Offline

#7 2018-07-11 14:42:57

snlia
Member
Registered: 2015-12-16
Posts: 8

Re: Can not log in gnome using Xorg

Not works for me... I reboot 5 times, just behaved the same as before. And I found Xorg did not regenerate gnome-shell, but wayland regenerate gnome-shell.

Offline

#8 2018-07-11 14:47:04

seth
Member
Registered: 2012-09-03
Posts: 8,946

Re: Can not log in gnome using Xorg

get GDM out of the equation, boot into the multi-user.target, run "startx xterm" and from there "gnome-shell", see what happens.

Offline

#9 2018-07-11 16:34:52

snlia
Member
Registered: 2015-12-16
Posts: 8

Re: Can not log in gnome using Xorg

seth wrote:

get GDM out of the equation, boot into the multi-user.target, run "startx xterm" and from there "gnome-shell", see what happens.

This works! I logged into the system successfully(after installing many missed packages). But I still cannot log in using gdm(I tried to uncomment that line, rm .Xauthority and gnome-shell, none of them works).

Offline

Board footer

Powered by FluxBB