You are not logged in.

#1 2018-07-12 02:08:01

thisisausername222
Member
Registered: 2018-07-12
Posts: 5

[SOLVED] cannot use xinit or a display as non root

[SOLVED] I have a fresh install of arch and I have no idea what I did wrong. I have searched for days and cannot find a solution.

    No user besides root can use startx. No user besides root can execute any commands or applications that use a display.

    For example with two simple programs I am getting these errors:

    scrot -

 giblib error: Can't open x display. it *is* running, yeah? 

    thunar - failed to initialize xfconf: failed to connect to socket /run/usr/0/bus: permission denied

    No protocol specified
    unable to init server: could not connect: connection refused
    (thunar: 879): GTK-WARNING **: 20:17:02.333: cannot open display :0 

    I have none of these issues if I am running as root

I have two other installs of arch in VMs and have installed arch before on this machine and have never had this issue before

Last edited by thisisausername222 (2018-07-12 22:32:50)

Offline

#2 2018-07-12 02:12:53

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 15,927

Re: [SOLVED] cannot use xinit or a display as non root

Welcome to Arch Linux.

Have you ever run tried running with root permissions using sudo while logged in as a normal user?  If so, you may have files around that are owned by root in your user's $HOME
Please post your ~/.xinitrc file and your Xorg log file.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#3 2018-07-12 02:32:27

thisisausername222
Member
Registered: 2018-07-12
Posts: 5

Re: [SOLVED] cannot use xinit or a display as non root

the ~/.xinitrc just has 

exec i3 

the /var/log/Xorg.0.log has quite a bit of text. sorry if this is now what you were asking for, first day on the forums

 [   776.760] (WW) Failed to open protocol names file lib/xorg/protocol.txt
[   776.760] 
X.Org X Server 1.20.0
X Protocol Version 11, Revision 0
[   776.761] Build Operating System: Linux Arch Linux
[   776.761] Current Operating System: Linux neetpad 4.17.5-1-ARCH #1 SMP PREEMPT Sun Jul 8 17:27:31 UTC 2018 x86_64
[   776.761] Kernel command line: BOOT_IMAGE=/vmlinuz-linux root=UUID=cff399b5-a81e-4884-bb75-ce70d940a3f7 rw quiet
[   776.761] Build Date: 18 June 2018  03:12:37PM
[   776.761]  
[   776.761] Current version of pixman: 0.34.0
[   776.761] 	Before reporting problems, check [url]http://wiki.x.org[/url]
	to make sure that you have the latest version.
[   776.761] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   776.762] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Jul 11 20:48:52 2018
[   776.762] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   776.762] (==) No Layout section.  Using the first Screen section.
[   776.762] (==) No screen section available. Using defaults.
[   776.762] (**) |-->Screen "Default Screen Section" (0)
[   776.762] (**) |   |-->Monitor "<default monitor>"
[   776.762] (==) No monitor specified for screen "Default Screen Section".
	Using a default monitor configuration.
[   776.762] (==) Automatically adding devices
[   776.762] (==) Automatically enabling devices
[   776.762] (==) Automatically adding GPU devices
[   776.762] (==) Automatically binding GPU devices
[   776.762] (==) Max clients allowed: 256, resource mask: 0x1fffff
[   776.762] (WW) The directory "/usr/share/fonts/misc" does not exist.
[   776.762] 	Entry deleted from font path.
[   776.762] (WW) The directory "/usr/share/fonts/OTF" does not exist.
[   776.762] 	Entry deleted from font path.
[   776.762] (WW) The directory "/usr/share/fonts/Type1" does not exist.
[   776.762] 	Entry deleted from font path.
[   776.762] (WW) The directory "/usr/share/fonts/100dpi" does not exist.
[   776.762] 	Entry deleted from font path.
[   776.762] (WW) The directory "/usr/share/fonts/75dpi" does not exist.
[   776.762] 	Entry deleted from font path.
[   776.762] (==) FontPath set to:
	/usr/share/fonts/TTF
[   776.762] (==) ModulePath set to "/usr/lib/xorg/modules"
[   776.762] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[   776.762] (II) Module ABI versions:
[   776.762] 	X.Org ANSI C Emulation: 0.4
[   776.762] 	X.Org Video Driver: 24.0
[   776.762] 	X.Org XInput driver : 24.1
[   776.762] 	X.Org Server Extension : 10.0
[   776.763] (++) using VT number 1

[   776.765] (II) systemd-logind: took control of session /org/freedesktop/login1/session/c1
[   776.766] (II) xfree86: Adding drm device (/dev/dri/card0)
[   776.766] (II) systemd-logind: got fd for /dev/dri/card0 226:0 fd 10 paused 0
[   776.769] (--) PCI:*(0@0:2:0) 8086:1616:17aa:2226 rev 9, Mem @ 0xf0000000/16777216, 0xe0000000/268435456, I/O @ 0x00003000/64, BIOS @ 0x????????/131072
[   776.769] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[   776.769] (II) LoadModule: "glx"
[   776.769] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[   776.770] (II) Module glx: vendor="X.Org Foundation"
[   776.770] 	compiled for 1.20.0, module version = 1.0.0
[   776.770] 	ABI class: X.Org Server Extension, version 10.0
[   776.770] (==) Matched intel as autoconfigured driver 0
[   776.770] (==) Matched modesetting as autoconfigured driver 1
[   776.770] (==) Matched fbdev as autoconfigured driver 2
[   776.770] (==) Matched vesa as autoconfigured driver 3
[   776.770] (==) Assigned the driver to the xf86ConfigLayout
[   776.770] (II) LoadModule: "intel"
[   776.770] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[   776.770] (II) Module intel: vendor="X.Org Foundation"
[   776.770] 	compiled for 1.20.0, module version = 2.99.917
[   776.770] 	Module class: X.Org Video Driver
[   776.770] 	ABI class: X.Org Video Driver, version 24.0
[   776.770] (II) LoadModule: "modesetting"
[   776.770] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[   776.771] (II) Module modesetting: vendor="X.Org Foundation"
[   776.771] 	compiled for 1.20.0, module version = 1.20.0
[   776.771] 	Module class: X.Org Video Driver
[   776.771] 	ABI class: X.Org Video Driver, version 24.0
[   776.771] (II) LoadModule: "fbdev"
[   776.771] (WW) Warning, couldn't open module fbdev
[   776.771] (EE) Failed to load module "fbdev" (module does not exist, 0)
[   776.771] (II) LoadModule: "vesa"
[   776.771] (WW) Warning, couldn't open module vesa
[   776.771] (EE) Failed to load module "vesa" (module does not exist, 0)
[   776.771] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
	i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
	915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
	Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
	GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[   776.771] (II) intel: Driver for Intel(R) HD Graphics
[   776.771] (II) intel: Driver for Intel(R) Iris(TM) Graphics
[   776.771] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics
[   776.771] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[   776.771] (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20180308
[   776.771] (II) intel(0): SNA compiled from 2.99.917-831-ge7bfc906
[   776.787] (WW) Falling back to old probe method for modesetting
[   776.787] (--) intel(0): Integrated Graphics Chipset: Intel(R) HD Graphics 5500
[   776.787] (--) intel(0): CPU: x86-64, sse2, sse3, ssse3, sse4.1, sse4.2, avx, avx2; using a maximum of 2 threads
[   776.787] (II) intel(0): Creating default Display subsection in Screen section
	"Default Screen Section" for depth/fbbpp 24/32
[   776.787] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[   776.787] (==) intel(0): RGB weight 888
[   776.787] (==) intel(0): Default visual is TrueColor
[   776.788] (II) intel(0): Output eDP1 has no monitor section
[   776.788] (**) intel(0): Found backlight control interface intel_backlight (type 'raw') for output eDP1
[   776.788] (II) intel(0): Enabled output eDP1
[   776.788] (II) intel(0): Output DP1 has no monitor section
[   776.788] (II) intel(0): Enabled output DP1
[   776.788] (II) intel(0): Output HDMI1 has no monitor section
[   776.788] (II) intel(0): Enabled output HDMI1
[   776.788] (II) intel(0): Output DP2 has no monitor section
[   776.788] (II) intel(0): Enabled output DP2
[   776.788] (II) intel(0): Output HDMI2 has no monitor section
[   776.789] (II) intel(0): Enabled output HDMI2
[   776.789] (--) intel(0): Using a maximum size of 256x256 for hardware cursors
[   776.789] (II) intel(0): Output VIRTUAL1 has no monitor section
[   776.789] (II) intel(0): Enabled output VIRTUAL1
[   776.789] (--) intel(0): Output eDP1 using initial mode 1920x1080 on pipe 0
[   776.789] (==) intel(0): TearFree enabled
[   776.789] (==) intel(0): Using gamma correction (1.0, 1.0, 1.0)
[   776.789] (==) intel(0): DPI set to (96, 96)
[   776.789] (II) Loading sub module "dri3"
[   776.789] (II) LoadModule: "dri3"
[   776.789] (II) Module "dri3" already built-in
[   776.789] (II) Loading sub module "dri2"
[   776.789] (II) LoadModule: "dri2"
[   776.789] (II) Module "dri2" already built-in
[   776.789] (II) Loading sub module "present"
[   776.789] (II) LoadModule: "present"
[   776.789] (II) Module "present" already built-in
[   776.789] (II) UnloadModule: "modesetting"
[   776.789] (II) Unloading modesetting
[   776.789] (II) intel(0): SNA initialized with Broadwell (gen8) backend
[   776.789] (==) intel(0): Backing store enabled
[   776.789] (==) intel(0): Silken mouse disabled
[   776.789] (II) intel(0): HW Cursor enabled
[   776.790] (==) intel(0): DPMS enabled
[   776.790] (==) intel(0): Display hotplug detection enabled
[   776.790] (II) intel(0): [DRI2] Setup complete
[   776.790] (II) intel(0): [DRI2]   DRI driver: i965
[   776.790] (II) intel(0): [DRI2]   VDPAU driver: va_gl
[   776.790] (II) intel(0): direct rendering: DRI2 DRI3 enabled
[   776.790] (II) intel(0): hardware support for Present enabled
[   776.790] (II) Initializing extension Generic Event Extension
[   776.790] (II) Initializing extension SHAPE
[   776.790] (II) Initializing extension MIT-SHM
[   776.790] (II) Initializing extension XInputExtension
[   776.790] (II) Initializing extension XTEST
[   776.790] (II) Initializing extension BIG-REQUESTS
[   776.790] (II) Initializing extension SYNC
[   776.790] (II) Initializing extension XKEYBOARD
[   776.790] (II) Initializing extension XC-MISC
[   776.790] (II) Initializing extension SECURITY
[   776.790] (II) Initializing extension XFIXES
[   776.790] (II) Initializing extension RENDER
[   776.790] (II) Initializing extension RANDR
[   776.790] (II) Initializing extension COMPOSITE
[   776.790] (II) Initializing extension DAMAGE
[   776.790] (II) Initializing extension MIT-SCREEN-SAVER
[   776.790] (II) Initializing extension DOUBLE-BUFFER
[   776.790] (II) Initializing extension RECORD
[   776.790] (II) Initializing extension DPMS
[   776.790] (II) Initializing extension Present
[   776.790] (II) Initializing extension DRI3
[   776.790] (II) Initializing extension X-Resource
[   776.790] (II) Initializing extension XVideo
[   776.790] (II) Initializing extension XVideo-MotionCompensation
[   776.790] (II) Initializing extension GLX
[   776.801] (II) AIGLX: Loaded and initialized i965
[   776.801] (II) GLX: Initialized DRI2 GL provider for screen 0
[   776.801] (II) Initializing extension XFree86-VidModeExtension
[   776.801] (II) Initializing extension XFree86-DGA
[   776.801] (II) Initializing extension XFree86-DRI
[   776.801] (II) Initializing extension DRI2
[   776.804] (II) intel(0): switch to mode 1920x1080@60.0 on eDP1 using pipe 0, position (0, 0), rotation normal, reflection none
[   776.807] (II) intel(0): Setting screen physical size to 508 x 285
[   776.833] (II) config/udev: Adding input device Power Button (/dev/input/event2)
[   776.833] (**) Power Button: Applying InputClass "libinput keyboard catchall"
[   776.833] (II) LoadModule: "libinput"
[   776.833] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[   776.834] (II) Module libinput: vendor="X.Org Foundation"
[   776.834] 	compiled for 1.19.6, module version = 0.27.1
[   776.834] 	Module class: X.Org XInput Driver
[   776.834] 	ABI class: X.Org XInput driver, version 24.1
[   776.834] (II) Using input driver 'libinput' for 'Power Button'
[   776.835] (II) systemd-logind: got fd for /dev/input/event2 13:66 fd 18 paused 0
[   776.835] (**) Power Button: always reports core events
[   776.835] (**) Option "Device" "/dev/input/event2"
[   776.835] (**) Option "_source" "server/udev"
[   776.835] (II) event2  - Power Button: is tagged by udev as: Keyboard
[   776.835] (II) event2  - Power Button: device is a keyboard
[   776.835] (II) event2  - Power Button: device removed
[   776.835] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input2/event2"
[   776.835] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[   776.836] (II) event2  - Power Button: is tagged by udev as: Keyboard
[   776.836] (II) event2  - Power Button: device is a keyboard
[   776.836] (II) config/udev: Adding input device Video Bus (/dev/input/event12)
[   776.836] (**) Video Bus: Applying InputClass "libinput keyboard catchall"
[   776.836] (II) Using input driver 'libinput' for 'Video Bus'
[   776.836] (II) systemd-logind: got fd for /dev/input/event12 13:76 fd 21 paused 0
[   776.837] (**) Video Bus: always reports core events
[   776.837] (**) Option "Device" "/dev/input/event12"
[   776.837] (**) Option "_source" "server/udev"
[   776.837] (II) event12 - Video Bus: is tagged by udev as: Keyboard
[   776.837] (II) event12 - Video Bus: device is a keyboard
[   776.837] (II) event12 - Video Bus: device removed
[   776.837] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input14/event12"
[   776.837] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 7)
[   776.837] (II) event12 - Video Bus: is tagged by udev as: Keyboard
[   776.837] (II) event12 - Video Bus: device is a keyboard
[   776.838] (II) config/udev: Adding input device Lid Switch (/dev/input/event0)
[   776.838] (II) No input driver specified, ignoring this device.
[   776.838] (II) This device may have been added with another device file.
[   776.838] (II) config/udev: Adding input device Sleep Button (/dev/input/event1)
[   776.838] (**) Sleep Button: Applying InputClass "libinput keyboard catchall"
[   776.838] (II) Using input driver 'libinput' for 'Sleep Button'
[   776.838] (II) systemd-logind: got fd for /dev/input/event1 13:65 fd 22 paused 0
[   776.838] (**) Sleep Button: always reports core events
[   776.838] (**) Option "Device" "/dev/input/event1"
[   776.838] (**) Option "_source" "server/udev"
[   776.839] (II) event1  - Sleep Button: is tagged by udev as: Keyboard
[   776.839] (II) event1  - Sleep Button: device is a keyboard
[   776.839] (II) event1  - Sleep Button: device removed
[   776.839] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0E:00/input/input1/event1"
[   776.839] (II) XINPUT: Adding extended input device "Sleep Button" (type: KEYBOARD, id 8)
[   776.839] (II) event1  - Sleep Button: is tagged by udev as: Keyboard
[   776.839] (II) event1  - Sleep Button: device is a keyboard
[   776.840] (II) config/udev: Adding input device HDA Intel HDMI HDMI/DP,pcm=3 (/dev/input/event13)
[   776.840] (II) No input driver specified, ignoring this device.
[   776.840] (II) This device may have been added with another device file.
[   776.840] (II) config/udev: Adding input device HDA Intel HDMI HDMI/DP,pcm=7 (/dev/input/event14)
[   776.840] (II) No input driver specified, ignoring this device.
[   776.840] (II) This device may have been added with another device file.
[   776.840] (II) config/udev: Adding input device HDA Intel HDMI HDMI/DP,pcm=8 (/dev/input/event15)
[   776.840] (II) No input driver specified, ignoring this device.
[   776.840] (II) This device may have been added with another device file.
[   776.840] (II) config/udev: Adding input device HDA Intel HDMI HDMI/DP,pcm=9 (/dev/input/event16)
[   776.840] (II) No input driver specified, ignoring this device.
[   776.840] (II) This device may have been added with another device file.
[   776.840] (II) config/udev: Adding input device HDA Intel HDMI HDMI/DP,pcm=10 (/dev/input/event17)
[   776.840] (II) No input driver specified, ignoring this device.
[   776.840] (II) This device may have been added with another device file.
[   776.841] (II) config/udev: Adding input device Integrated Camera: Integrated C (/dev/input/event11)
[   776.841] (**) Integrated Camera: Integrated C: Applying InputClass "libinput keyboard catchall"
[   776.841] (II) Using input driver 'libinput' for 'Integrated Camera: Integrated C'
[   776.841] (II) systemd-logind: got fd for /dev/input/event11 13:75 fd 23 paused 0
[   776.841] (**) Integrated Camera: Integrated C: always reports core events
[   776.841] (**) Option "Device" "/dev/input/event11"
[   776.841] (**) Option "_source" "server/udev"
[   776.842] (II) event11 - Integrated Camera: Integrated C: is tagged by udev as: Keyboard
[   776.842] (II) event11 - Integrated Camera: Integrated C: device is a keyboard
[   776.842] (II) event11 - Integrated Camera: Integrated C: device removed
[   776.842] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb2/2-8/2-8:1.0/input/input13/event11"
[   776.842] (II) XINPUT: Adding extended input device "Integrated Camera: Integrated C" (type: KEYBOARD, id 9)
[   776.842] (II) event11 - Integrated Camera: Integrated C: is tagged by udev as: Keyboard
[   776.842] (II) event11 - Integrated Camera: Integrated C: device is a keyboard
[   776.842] (II) config/udev: Adding input device HDA Intel PCH Mic (/dev/input/event8)
[   776.842] (II) No input driver specified, ignoring this device.
[   776.842] (II) This device may have been added with another device file.
[   776.843] (II) config/udev: Adding input device HDA Intel PCH Dock Headphone (/dev/input/event9)
[   776.843] (II) No input driver specified, ignoring this device.
[   776.843] (II) This device may have been added with another device file.
[   776.843] (II) config/udev: Adding input device HDA Intel PCH Headphone (/dev/input/event10)
[   776.843] (II) No input driver specified, ignoring this device.
[   776.843] (II) This device may have been added with another device file.
[   776.843] (II) config/udev: Adding input device HDA Digital PCBeep (/dev/input/event6)
[   776.843] (II) No input driver specified, ignoring this device.
[   776.843] (II) This device may have been added with another device file.
[   776.843] (II) config/udev: Adding input device HDA Intel PCH Dock Mic (/dev/input/event7)
[   776.843] (II) No input driver specified, ignoring this device.
[   776.843] (II) This device may have been added with another device file.
[   776.844] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event3)
[   776.844] (**) AT Translated Set 2 keyboard: Applying InputClass "libinput keyboard catchall"
[   776.844] (II) Using input driver 'libinput' for 'AT Translated Set 2 keyboard'
[   776.844] (II) systemd-logind: got fd for /dev/input/event3 13:67 fd 24 paused 0
[   776.844] (**) AT Translated Set 2 keyboard: always reports core events
[   776.844] (**) Option "Device" "/dev/input/event3"
[   776.844] (**) Option "_source" "server/udev"
[   776.844] (II) event3  - AT Translated Set 2 keyboard: is tagged by udev as: Keyboard
[   776.844] (II) event3  - AT Translated Set 2 keyboard: device is a keyboard
[   776.844] (II) event3  - AT Translated Set 2 keyboard: device removed
[   776.844] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input3/event3"
[   776.844] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 10)
[   776.845] (II) event3  - AT Translated Set 2 keyboard: is tagged by udev as: Keyboard
[   776.845] (II) event3  - AT Translated Set 2 keyboard: device is a keyboard
[   776.845] (II) config/udev: Adding input device PC Speaker (/dev/input/event5)
[   776.845] (II) No input driver specified, ignoring this device.
[   776.845] (II) This device may have been added with another device file.
[   776.845] (II) config/udev: Adding input device ThinkPad Extra Buttons (/dev/input/event4)
[   776.845] (**) ThinkPad Extra Buttons: Applying InputClass "libinput keyboard catchall"
[   776.845] (II) Using input driver 'libinput' for 'ThinkPad Extra Buttons'
[   776.846] (II) systemd-logind: got fd for /dev/input/event4 13:68 fd 25 paused 0
[   776.846] (**) ThinkPad Extra Buttons: always reports core events
[   776.846] (**) Option "Device" "/dev/input/event4"
[   776.846] (**) Option "_source" "server/udev"
[   776.846] (II) event4  - ThinkPad Extra Buttons: is tagged by udev as: Keyboard Switch
[   776.846] (II) event4  - ThinkPad Extra Buttons: device is a keyboard
[   776.846] (II) event4  - ThinkPad Extra Buttons: device removed
[   776.846] (**) Option "config_info" "udev:/sys/devices/platform/thinkpad_acpi/input/input5/event4"
[   776.846] (II) XINPUT: Adding extended input device "ThinkPad Extra Buttons" (type: KEYBOARD, id 11)
[   776.847] (II) event4  - ThinkPad Extra Buttons: is tagged by udev as: Keyboard Switch
[   776.847] (II) event4  - ThinkPad Extra Buttons: device is a keyboard
[   776.847] (II) config/udev: Adding input device Synaptics TM3075-002 (/dev/input/event18)
[   776.847] (**) Synaptics TM3075-002: Applying InputClass "libinput touchpad catchall"
[   776.847] (II) Using input driver 'libinput' for 'Synaptics TM3075-002'
[   776.847] (II) systemd-logind: got fd for /dev/input/event18 13:82 fd 26 paused 0
[   776.847] (**) Synaptics TM3075-002: always reports core events
[   776.847] (**) Option "Device" "/dev/input/event18"
[   776.847] (**) Option "_source" "server/udev"
[   776.848] (II) event18 - Synaptics TM3075-002: is tagged by udev as: Touchpad
[   776.848] (II) event18 - Synaptics TM3075-002: device is a touchpad
[   776.848] (II) event18 - Synaptics TM3075-002: device removed
[   776.848] (**) Option "config_info" "udev:/sys/devices/rmi4-00/input/input20/event18"
[   776.848] (II) XINPUT: Adding extended input device "Synaptics TM3075-002" (type: TOUCHPAD, id 12)
[   776.848] (**) Option "AccelerationScheme" "none"
[   776.848] (**) Synaptics TM3075-002: (accel) selected scheme none/0
[   776.848] (**) Synaptics TM3075-002: (accel) acceleration factor: 2.000
[   776.848] (**) Synaptics TM3075-002: (accel) acceleration threshold: 4
[   776.848] (II) event18 - Synaptics TM3075-002: is tagged by udev as: Touchpad
[   776.848] (II) event18 - Synaptics TM3075-002: device is a touchpad
[   776.848] (II) config/udev: Adding input device Synaptics TM3075-002 (/dev/input/mouse0)
[   776.848] (II) No input driver specified, ignoring this device.
[   776.848] (II) This device may have been added with another device file.
[   776.849] (II) config/udev: Adding input device TPPS/2 IBM TrackPoint (/dev/input/event19)
[   776.849] (**) TPPS/2 IBM TrackPoint: Applying InputClass "libinput pointer catchall"
[   776.849] (II) Using input driver 'libinput' for 'TPPS/2 IBM TrackPoint'
[   776.849] (II) systemd-logind: got fd for /dev/input/event19 13:83 fd 27 paused 0
[   776.849] (**) TPPS/2 IBM TrackPoint: always reports core events
[   776.849] (**) Option "Device" "/dev/input/event19"
[   776.849] (**) Option "_source" "server/udev"
[   776.849] (II) event19 - TPPS/2 IBM TrackPoint: is tagged by udev as: Mouse Pointingstick
[   776.849] (II) event19 - TPPS/2 IBM TrackPoint: trackpoint does not have a specified range, guessing... see [url]https://wayland.freedesktop.org/libinput/doc/1.11.2/trackpoints.html[/url]
[   776.849] (II) event19 - TPPS/2 IBM TrackPoint: trackpoint device set to range 31
[   776.849] (II) event19 - TPPS/2 IBM TrackPoint: device is a pointer
[   776.850] (II) event19 - TPPS/2 IBM TrackPoint: device removed
[   776.850] (**) Option "config_info" "udev:/sys/devices/rmi4-00/rmi4-00.fn03/serio2/input/input21/event19"
[   776.850] (II) XINPUT: Adding extended input device "TPPS/2 IBM TrackPoint" (type: MOUSE, id 13)
[   776.850] (**) Option "AccelerationScheme" "none"
[   776.850] (**) TPPS/2 IBM TrackPoint: (accel) selected scheme none/0
[   776.850] (**) TPPS/2 IBM TrackPoint: (accel) acceleration factor: 2.000
[   776.850] (**) TPPS/2 IBM TrackPoint: (accel) acceleration threshold: 4
[   776.850] (II) event19 - TPPS/2 IBM TrackPoint: is tagged by udev as: Mouse Pointingstick
[   776.850] (II) event19 - TPPS/2 IBM TrackPoint: trackpoint does not have a specified range, guessing... see [url]https://wayland.freedesktop.org/libinput/doc/1.11.2/trackpoints.html[/url]
[   776.850] (II) event19 - TPPS/2 IBM TrackPoint: trackpoint device set to range 31
[   776.850] (II) event19 - TPPS/2 IBM TrackPoint: device is a pointer
[   776.850] (II) config/udev: Adding input device TPPS/2 IBM TrackPoint (/dev/input/mouse1)
[   776.850] (II) No input driver specified, ignoring this device.
[   776.850] (II) This device may have been added with another device file.
[   776.930] (II) intel(0): EDID vendor "LGD", prod id 1079
[   776.931] (II) intel(0): Printing DDC gathered Modelines:
[   776.931] (II) intel(0): Modeline "1920x1080"x0.0  138.46  1920 1968 2000 2106  1080 1083 1088 1095 +hsync -vsync (65.7 kHz eP) 

Last edited by thisisausername222 (2018-07-12 02:44:11)

Offline

#4 2018-07-12 02:34:59

thisisausername222
Member
Registered: 2018-07-12
Posts: 5

Re: [SOLVED] cannot use xinit or a display as non root

Have you ever run tried running with root permissions using sudo while logged in as a normal user?

the thing is i cannot even log in as another user. if, while in a terminal, i switch user to another user and try to execute any commands i get these display errors, however if i preface it with sudo or run it as root it will work fine, except for the fact that it is now root doing these actions. if i su user in tty and sudo root i log in as root

Offline

#5 2018-07-12 02:36:04

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 25,294
Website

Re: [SOLVED] cannot use xinit or a display as non root

Please use code, not quote, tags when pasting to the boards: https://wiki.archlinux.org/index.php/Co … s_and_code

Your ~/.xinitrc is incomplete: follow the instructions on the wiki and use the skeleton file that sources the necessary files for an active session.

And, as ewaller suggested, make sure that your $HOME does not have incorrect permissions.


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#6 2018-07-12 04:09:40

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 15,927

Re: [SOLVED] cannot use xinit or a display as non root

As jasonwryan points out, your xinitrc file needs a bit of the boilerplate from the template in /etc.  That xorg does not show that Xorg is exiting -- either normally or with an error.  That tells me it is either still running, or somehow became truncated.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#7 2018-07-12 13:42:06

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 19,532
Website

Re: [SOLVED] cannot use xinit or a display as non root

Does that xorg log come from a failed attempt to start X as a regular user?  Why is the log under /var/log rather than ~/.local/share?


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Online

#8 2018-07-12 14:17:45

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 15,927

Re: [SOLVED] cannot use xinit or a display as non root

Trilby wrote:

Why is the log under /var/log rather than ~/.local/share?

Nice catch!


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#9 2018-07-12 21:40:00

thisisausername222
Member
Registered: 2018-07-12
Posts: 5

Re: [SOLVED] cannot use xinit or a display as non root

Hey, thanks for the help guys and sorry for the late reply. I got it working last night by just re installing xorg server. However by doing so i now cant get wifi-menu, or anything wifi to work

when i start it i get

 Scanning for networks... nl8021: could not set interface 'p2p-dev-wlp3s0' UP
p2p-dev-wlp3s0: failed to initialize driver interface 

and when it ends (i can see the wifi menu pop and and select an SSID and go though the process, but it always says cannot connect)

 Job for netctl@wlp3s0\x2d(my wifi SSID).service failed because the control process exited with error code.
See "systemcctl status "netctl@wlp3s0\\x2d(my wifi SSID).service" and "journalctl -xe" for details 

wired internet works fine no problem, no configuring, or anything. just plug it up and im in, but i cannot use wifi. Thanks again for the help already.

Offline

#10 2018-07-12 21:45:08

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 25,294
Website

Re: [SOLVED] cannot use xinit or a display as non root

This is an entirely separate issue: https://wiki.archlinux.org/index.php/Co … ow_to_post

Before opening another thread, follow the advice in the error message and read the status to determine why it is failing.


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#11 2018-07-12 22:04:26

thisisausername222
Member
Registered: 2018-07-12
Posts: 5

Re: [SOLVED] cannot use xinit or a display as non root

Oh sorry man. I fixed it btw. I have no idea how but all i did was delete some of the info and all the wifi profiles i had saved, set the link down then back up, exited i3, switched to the root, used wifi-menu as root, and then signed back in as my user and i am now able to use the wifi-menu and wifi networking no problems and with no errors even after reboot. So thanks for the help guys, really appreciate it.

Offline

#12 2018-07-12 22:24:23

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 25,294
Website

Re: [SOLVED] cannot use xinit or a display as non root

Please remember to mark your thread as [Solved] by editing your first post and prepending it to the title.


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

Board footer

Powered by FluxBB