You are not logged in.

#1 2018-07-13 14:21:15

SanTDR
Member
Registered: 2015-09-09
Posts: 9

[Solved] MPD: No mixer

Hi everyone.

I'm trying to run mpd+ncmpcpp, but I'm getting no sound output from ncmpcpp nor from

mpc play

. My mpd.conf at the moment is:

pid_file "/run/mpd/mpd.pid"
db_file "/var/lib/mpd/mpd.db"
state_file "/var/lib/mpd/mpdstate"
playlist_directory "/var/lib/mpd/playlists"
music_directory "/path/to/music"
bind_to_address "127.0.0.1"  
log_file "/var/lib/mpd/mpd.log"

audio_output {
        type            "pulse"
        name            "pulse audio"
        mixer_type      "hardware"      # optional
        mixer_device    "default"       # optional
        mixer_control   "PCM"           # optional
        mixer_index     "0"             # optional
}

audio_output {
    type                    "fifo"
    name                    "my_fifo"
    path                    "/tmp/mpd.fifo"
    format                  "44100:16:2"
}

With this configuration trying to change the volume, which is displayed as n/a, returns the error MPD: No Mixer, having tried both hardware and software mixer types.

mpd.log:

Jul 13 15:59 : client: [0] opened from 127.0.0.1:46440
ALSA lib pulse.c:243:(pulse_connect) PulseAudio: Unable to connect: Connection refused

Jul 13 15:59 : exception: Failed to read mixer for 'ALSA': failed to attach to default: Connection refused
ALSA lib pulse.c:243:(pulse_connect) PulseAudio: Unable to connect: Connection refused

Jul 13 15:59 : exception: Failed to open "ALSA" [alsa]
Jul 13 15:59 : exception: nested: Failed to open ALSA device "default": Connection refused
Jul 13 15:59 : client: [0] closed

arecord -l

card 0: PCH [HDA Intel PCH], device 0: ALC668 Analog [ALC668 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

/etc/asound.conf

# Use PulseAudio by default
pcm.!default {
  type pulse
  fallback "sysdefault"
  hint {
    show on
    description "Default ALSA Output (currently PulseAudio Sound Server)"
  }
}

ctl.!default {
  type pulse
  fallback "sysdefault"
}

# vim:set ft=alsaconf:

pcm.dsp {
    type plug
    slave.pcm "dmix"
}

pcm.pulse {
    type pulse
}
ctl.pulse {
    type pulse
}
pcm.!default {
    type pulse
}
ctl.!default {
    type pulse
}

Last edited by SanTDR (2018-07-13 17:57:21)

Offline

#2 2018-07-13 14:38:51

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 6,275

Re: [Solved] MPD: No mixer

post /etc/pulse/client.conf .

Alos post both /etc/mpd.conf and ~/config/mpd.conf


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#3 2018-07-13 14:48:41

SanTDR
Member
Registered: 2015-09-09
Posts: 9

Re: [Solved] MPD: No mixer

Lone_Wolf wrote:

post /etc/pulse/client.conf .

Alos post both /etc/mpd.conf and ~/config/mpd.conf

/etc/pulse/client.conf

# This file is part of PulseAudio.
#
# PulseAudio is free software; you can redistribute it and/or modify
# it under the terms of the GNU Lesser General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version.
#
# PulseAudio is distributed in the hope that it will be useful, but
# WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
# General Public License for more details.
#
# You should have received a copy of the GNU Lesser General Public License
# along with PulseAudio; if not, see <http://www.gnu.org/licenses/>.

## Configuration file for PulseAudio clients. See pulse-client.conf(5) for
## more information. Default values are commented out.  Use either ; or # for
## commenting.

; default-sink =
; default-source =
; default-server =
; default-dbus-server =

;autospawn=yes
; daemon-binary = /usr/bin/pulseaudio
extra-arguments = --log-target=syslog -vvvv

; cookie-file =

; enable-shm = yes
; shm-size-bytes = 0 # setting this 0 will use the system-default, usually 64 MiB

; auto-connect-localhost = no
; auto-connect-display = no
autospawn = no

as for mpd.conf, the one in my home directory is posted in my OP.

/etc/mpd.conf

# See: /usr/share/doc/mpd/mpdconf.example

pid_file "/run/mpd/mpd.pid"
db_file "/var/lib/mpd/mpd.db"
state_file "/var/lib/mpd/mpdstate"
playlist_directory "/var/lib/mpd/playlists"
music_directory "/path/to/music"
bind_to_address "127.0.0.1"  
log_file "/var/lib/mpd/mpd.log"

audio_output {
        type            "pulse"
        name            "pluse audio"
}

audio_output {
    type                    "fifo"
    name                    "my_fifo"
    path                    "/tmp/mpd.fifo"
    format                  "44100:16:2"
}

Offline

#4 2018-07-13 15:10:49

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 6,275

Re: [Solved] MPD: No mixer

That indicates you're using "Per-user configuration" .
To make that work with pulseaudio you need to allow autospawn in /etc/pulse/client.conf .

re-read https://wiki.archlinux.org/index.php/Mu … figuration .


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#5 2018-07-13 15:16:29

SanTDR
Member
Registered: 2015-09-09
Posts: 9

Re: [Solved] MPD: No mixer

Lone_Wolf wrote:

That indicates you're using "Per-user configuration" .
To make that work with pulseaudio you need to allow autospawn in /etc/pulse/client.conf .

re-read https://wiki.archlinux.org/index.php/Mu … figuration .

Thank you! I had checked autospawn being on but I had uncommented/commented back the commented autospawn line, not noticing I had previously added another at the bottom. Problem solved, mpd+ncmpcpp works now.

Offline

#6 2018-07-13 15:24:17

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 6,275

Re: [Solved] MPD: No mixer

Great, please prepend "[Solved]" to the thread title (edit the first post)


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

Board footer

Powered by FluxBB