You are not logged in.

#1 2018-07-12 19:20:59

MayhemWithMercy
Member
From: Ontario, Canada
Registered: 2018-06-03
Posts: 5

[solved]Bluetooth headset won't set to correct profile

Hey everyone,

On a fresh install I'm trying to get bluetooth working with my wireless headset (a Sony MDR-1000X). On my first try I managed to pair and connect no problem with KDE's bluedevil wizard; just went to audio output config and change the default device to my headset.

However upon waking from suspend, or reboot, the headset will connect (or remain connected), but I won't see an output option for it displayed in the output device list. Disconnecting/reconnecting does nothing, rebooting does nothing to fix it as well.

I've tried disconnecting, unpairing, shutting down, booting up, and repairing, but upon checking the advanced tab in audio volume config, the profile is set to "off". When I try and switch to A2DP sink, the headset quickly disconnects, reconnects, disappears from the output device list, and then reappears with the profile set again to off. I've tried restarting the bluetooth service to no avail. Playing any sort of audio obviously does not work.

I have also attempted to pair via CLI with bluetoothctl as outlined here https://wiki.archlinux.org/index.php/Bl … on_via_CLI with similar results.

pulseaudio-alsa, pulseaudio-bluetooth, bluez, bluez-libs, bluez-utils are all installed and up to date.

Any ideas?



This is my first topic post, so if I'm doing something incorrectly or breaking any forum rules please let me know.

Last edited by MayhemWithMercy (2018-07-15 02:22:02)

Offline

#2 2018-07-13 16:04:16

MayhemWithMercy
Member
From: Ontario, Canada
Registered: 2018-06-03
Posts: 5

Re: [solved]Bluetooth headset won't set to correct profile

My

lspci -v

output if the above is not enough information. Can't quite tell which is the bluetooth controller

https://pastebin.com/PF6FnypJ

edit: Broadcom Limited BCM43228 802.11a/b/g/n is my controller I believe.

Last edited by MayhemWithMercy (2018-07-13 20:06:14)

Offline

#3 2018-07-13 20:07:05

MayhemWithMercy
Member
From: Ontario, Canada
Registered: 2018-06-03
Posts: 5

Re: [solved]Bluetooth headset won't set to correct profile

What I think is relevant log output (complete noob @ reading logs so bear with me):

https://pastebin.com/Z8qb8uVG

Offline

#4 2018-07-15 02:19:41

MayhemWithMercy
Member
From: Ontario, Canada
Registered: 2018-06-03
Posts: 5

Re: [solved]Bluetooth headset won't set to correct profile

The latest pulseaudio updates have fixed the issue. I suppose the previous updates were faulty and caused the issue in the first place.

Offline

Board footer

Powered by FluxBB