You are not logged in.

#1 2018-08-05 13:51:54

spomeg
Member
Registered: 2017-07-28
Posts: 5

[SOLVED] Kernel Panic on Install with Encrypted Root

When I attempt to boot into my new arch install with the LVM on LUKS configuration, I get a kernel panic error which states:

not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

I’m using systemd-boot, but I don’t think that’s causing this error. Here are my arch.conf, mkinitcpio hooks, fstab, and crypttab:

/boot/loader/entries/arch.conf
title    Arch Linux
linux  /vmlinuz-linux
options rd.luks.name=cde8598b-9065-4177-acb3-75791bbd3287=cryptlvm root=/dev/cryptgroup/root resume=/dev/cryptgroup/swap
/etc/mkinitcpio.conf
HOOKS=(base systemd autodetect keyboard sd-vconsole modconf block sd-encrypt sd-lvm2 filesystems resume fsck)
/etc/fstab
/dev/mapper/cryptgroup-root   UUID=05ac290b-8d0c-4daf-b35a-accd10d6a9e8   /   ext4   rw.relatime   0 1
/dev/mapper/cryptgroup-home   UUID=0dff827f-274b-4d79-bbe0-f5c86ba5d2e5   /home   ext4   rw,relatime   0 2
/dev/nvme0n1p1   UUID=F2D6-0FA4   /boot   vfat   rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-to   0 2
/dev/mapper/cryptgroup-swap   UUID=f22d4384-a6f9-478b-8947-1fc53824b88f   none   swap   defaults,pri=-2 0 0
/etc/crypttab
/dev/nvme0n1p2   UUID=cde8598b-9065-4177-acb3-75791bbd3287   none   luks,timeout=90

Last edited by spomeg (2018-08-06 01:46:41)

Offline

#2 2018-08-06 01:46:21

spomeg
Member
Registered: 2017-07-28
Posts: 5

Re: [SOLVED] Kernel Panic on Install with Encrypted Root

Alright, I was able to get it working, and boy do I feel silly. Turns out I didn't need crypttab at all, and I don't need the resume hook in my mkinitcpio.conf because the systemd hook takes care of that for me. I was able to fix the issue by installing intel-ucode, and adding the following lines to my arch.conf:

initrd  /intel-ucode.img
initrd  /initramfs-linux.img

I'm marking this "solved" now.

Offline

Board footer

Powered by FluxBB