You are not logged in.

#1 2018-08-07 05:49:40

andmars
Member
Registered: 2012-03-13
Posts: 339

hplip/hplip-plugin 3.18.7 - "Filter failed" after update

Hi, I'm maintaining the hplip-plugin in AUR and until the update to 3.18.7. everything worked fine for my HP_LaserJet_Professional_P1102. After the update the printer refuses to print saying: Stopped "Filter failed".

Here's my /var/log/cups/error_log

Others report it in the AUR for hplip-plugin

Maybe you guys can figure out what the issue is here :-)

Last edited by andmars (2018-08-07 05:51:44)

Offline

#2 2018-08-07 06:23:29

zaxdan69
Member
Registered: 2016-06-04
Posts: 98

Re: hplip/hplip-plugin 3.18.7 - "Filter failed" after update

I don't use the aur version, but I have this problem too after hplip update. Thanks for mentioned. 
I have a Deskjet Ink Advandage 3635 printer, and I could print a test page but I get this error when I tried to print anything else. After I downgraded hplip printer start worked again.

Last edited by zaxdan69 (2018-08-07 06:23:54)

Offline

#3 2018-08-07 07:15:39

amish
Member
Registered: 2014-05-10
Posts: 365

Re: hplip/hplip-plugin 3.18.7 - "Filter failed" after update

May be related / may be not - but you can give it a try.

Some time back I was not able to print anything using my Canon printer. CUPS logs showed some error which I could not figure out.

But then I deleted the printer from CUPS and let it re-detect it.

And then printer started working again.

May be you can try the same?


Forum signature: I discuss. I put my thoughts strongly. But I definitely respect all developers and time they put in.

Offline

#4 2018-08-07 08:55:35

andmars
Member
Registered: 2012-03-13
Posts: 339

Re: hplip/hplip-plugin 3.18.7 - "Filter failed" after update

I have removed the printer already and installed it fresh via "# hp-setup -i" but still it doesn't print.

Offline

#5 2018-08-07 10:13:04

kekules_dream
Member
Registered: 2009-05-19
Posts: 100

Re: hplip/hplip-plugin 3.18.7 - "Filter failed" after update

I had the same problem with my HP laserjet. Downgrading back to hplip 3.18.6 got printing going again.

Offline

#6 2018-08-07 10:44:41

andmars
Member
Registered: 2012-03-13
Posts: 339

Re: hplip/hplip-plugin 3.18.7 - "Filter failed" after update

Ah, I see there is already a bug-report

Offline

#7 2018-08-08 18:43:21

mbrennr
Member
Registered: 2012-09-17
Posts: 4

Re: hplip/hplip-plugin 3.18.7 - "Filter failed" after update

I get

D [08/Aug/2018:20:13:53 +0200] [Job 1] LenasLaser: error while loading shared libraries: libImageProcessor.so: cannot open shared object file: No such file or directory

and

[michaelb@lillharven ~]$ /usr/lib/cups/filter/hpcups
/usr/lib/cups/filter/hpcups: error while loading shared libraries: libImageProcessor.so: cannot open shared object file: No such file or directory

Indicates clearly it's the https://bugs.archlinux.org/task/59548 bugwhich discusses the missing library.

I think many will also need hplip-plugin 3.18.6-2 from the AUR, since each hplip-plugin version also depends on the hplip with the same version.

To get the  old PKGBUILD for that (with the right checksum value)?

cd /tmp
git clone https://aur.archlinux.org/hplip-plugin
cd hplip-plugin/
git checkout b648610c5486604dc64c5df96669c18bbad8106b
makepkg
sudo pacman -U hplip-plugin-3.18.6-1-x86_64.pkg.tar.xz

the checkout magic number comes from

git log
commit 2b30f26009e5a96f081dabac070b22672ed8da58 (HEAD -> master, origin/master, origin/HEAD)
Author: andmars <andreas.marschall@unitybox.de>
Date:   Tue Aug 7 01:59:05 2018 +0200

    update to 3.18.7

commit b648610c5486604dc64c5df96669c18bbad8106b
Author: andmars <andreas.marschall@unitybox.de>
Date:   Mon Jun 25 18:15:08 2018 +0200

    Update to 3.18.6

[...]

You also have to add

IgnorePkg=hplip 

to /etc/pacman.conf

And (!)

IgnorePkg=hplip-plugin

to ~/.config/cower/config
(if you use cower and/or pacaur)

Last edited by mbrennr (2018-08-08 19:51:32)

Offline

#8 2018-08-08 20:10:36

loqs
Member
Registered: 2014-03-06
Posts: 6,364

Re: hplip/hplip-plugin 3.18.7 - "Filter failed" after update

Please try hplip 3.18.7-3 from testing which should have resolved the issue.

Offline

#9 2018-08-08 22:30:40

vlas
Member
From: Russia, Lipetsk
Registered: 2016-04-29
Posts: 23

Re: hplip/hplip-plugin 3.18.7 - "Filter failed" after update

Thank you, mbrennr and all of you, guys! Otherwise I almost despaired. After downgrading printer revived!


Beware! © Kozma Prutkov

Offline

#10 2018-08-08 22:45:37

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 26,195
Website

Re: hplip/hplip-plugin 3.18.7 - "Filter failed" after update

loqs wrote:

Please try hplip 3.18.7-3 from testing which should have resolved the issue.

It has.


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#11 2018-08-09 12:57:12

andmars
Member
Registered: 2012-03-13
Posts: 339

Re: hplip/hplip-plugin 3.18.7 - "Filter failed" after update

jasonwryan wrote:

It has.

Not!
I just installed hplip 3.18.7-3, rebuild hplip-plugin and installed the printer fresh with "sudo hp-setup -i" but it refuses to print a test page with "Filter failed" for my HP_LaserJet_Professional_P1102.

Offline

#12 2018-08-09 13:06:15

loqs
Member
Registered: 2014-03-06
Posts: 6,364

Re: hplip/hplip-plugin 3.18.7 - "Filter failed" after update

@andmars please post an updated /var/log/cups/error_log

Offline

#13 2018-08-09 21:47:19

KirkyD
Member
Registered: 2015-02-21
Posts: 4

Re: hplip/hplip-plugin 3.18.7 - "Filter failed" after update

after installing hplip 3.18.7-3 my officejet_pro_6830 works except it seems to think I'm out of paper. If I hit the 'continue' button on a dialog window it will go ahead and print.

here's my error_log file:
https://pastebin.com/mG0SfNKb

Offline

#14 2018-08-10 07:08:06

KirkyD
Member
Registered: 2015-02-21
Posts: 4

Re: hplip/hplip-plugin 3.18.7 - "Filter failed" after update

seems to be trouble with printer. does the same w/ hplip 3.18.6-1 on my other test machine running antergos.

Offline

#15 2018-08-10 19:53:20

andmars
Member
Registered: 2012-03-13
Posts: 339

Re: hplip/hplip-plugin 3.18.7 - "Filter failed" after update

loqs wrote:

@andmars please post an updated /var/log/cups/error_log

Here you go: https://pastebin.com/3dwLGffr

Offline

#16 2018-08-10 20:10:35

loqs
Member
Registered: 2014-03-06
Posts: 6,364

Re: hplip/hplip-plugin 3.18.7 - "Filter failed" after update

prnt/hpcups/HPCupsFilter.cpp 644: DEBUG: SHIVA inside the while loopprnt/hpcups/HPCupsFilter.cpp 648: DEBUG: imageProcessorStartPage failed result = 2
STATE: +connecting-to-device
STATE: +hplip.plugin-error
prnt/hpcups/HPCupsFilter.cpp 490: m_Job initialization failed with error = 48

With the updated package imageProcessor is now being used but is failing.  Unfortunately ImageProcessor is a binary blob and the hplip.plugin is another binary blob.
Some interaction between these two black boxes results in the issue.  Raise it upstream?
Edit:

          dbglog("DEBUG: SHIVA inside the while loop");
  
          IMAGE_PROCESSOR_ERROR result = imageProcessorStartPage(imageProcessor, &cups_header);
          if (result != IPE_SUCCESS){
              dbglog("DEBUG: imageProcessorStartPage failed result = %d\n", result);
          }
  
          current_page_number++;
  
          if (current_page_number == 1) {
  
              if (startPage(&cups_header) != NO_ERROR) {
                  return JOB_CANCELED;
              }
  
              if (m_JA.pre_process_raster) {
                  // CC ToDo: Why pSwapedPagesFileName should be sent as a parameter? 
                      // Remove if not required to send it as parameter
                  err = m_Job.preProcessRasterData(&cups_raster, &cups_header, hpPreProcessedRasterFile);
                  if (err != NO_ERROR) {
                      if (m_iLogLevel & BASIC_LOG) {
                          dbglog ("DEBUG: Job::StartPage failed with err = %d\n", err);
                      }
                      ret_status = JOB_CANCELED;
                      break;
                  }
              }

Last edited by loqs (2018-08-10 20:15:44)

Offline

#17 2018-08-15 20:43:01

colinkeenan
Member
From: Kansas City, MO USA
Registered: 2013-06-13
Posts: 209
Website

Re: hplip/hplip-plugin 3.18.7 - "Filter failed" after update

andmars wrote:
jasonwryan wrote:

It has.

Not!
I just installed hplip 3.18.7-3, rebuild hplip-plugin and installed the printer fresh with "sudo hp-setup -i" but it refuses to print a test page with "Filter failed" for my HP_LaserJet_Professional_P1102.

hplip 3.18.7-3 didn't solve the problem for me either. Just downgraded hplip and hplip plugin:

sudo pacman -U /var/cache/pacman/pkg/hplip-3.18.6-1-x86_64.pkg.tar.xz /var/cache/pacman/pkg/hplip-plugin-3.18.6-1-x86_64.pkg.tar.xz

Now working again. This bug is definitely not solved.

Offline

#18 2018-08-15 20:52:19

loqs
Member
Registered: 2014-03-06
Posts: 6,364

Re: hplip/hplip-plugin 3.18.7 - "Filter failed" after update

Does the patch in https://bugs.archlinux.org/task/59548#comment172098 resolve the issue for you?
If so it needs someone with the issue to report it upstream.

Offline

#19 2018-08-15 21:25:51

colinkeenan
Member
From: Kansas City, MO USA
Registered: 2013-06-13
Posts: 209
Website

Re: hplip/hplip-plugin 3.18.7 - "Filter failed" after update

It worked! The patch linked in "Comment by loqs (loqs) - Monday, 13 August 2018, 19:19 GMT" on the page that comes up from link https://bugs.archlinux.org/task/59548#comment172098 did the trick. Here is the direct link to the patch: https://bugs.archlinux.org/task/59548?getfile=16673

I had to follow the Patching packages wiki:
https://wiki.archlinux.org/index.php/Patching_packages

After getting the package by following the ABS wiki:
https://wiki.archlinux.org/index.php/Arch_Build_System

Basically:

asp checkout hplip

cd hplip/trunk

(copy the hplip.patch here)

edit PKGBUILD and updpkgsums according to the wiki on applying patches

Build & install as usual. Got the current hplip-plugin installed again and now the printer works.

I guess I have to report this upstream, but may have to do that tomorrow.

Offline

#20 2018-08-15 22:17:13

colinkeenan
Member
From: Kansas City, MO USA
Registered: 2013-06-13
Posts: 209
Website

Re: hplip/hplip-plugin 3.18.7 - "Filter failed" after update

OK. I filed an upstream bug report: https://bugs.launchpad.net/hplip/+bug/1787289

Would it be possible to include this patch in the Arch Linux package before upstream fixes it though?

Offline

#21 2018-08-16 04:49:29

colinkeenan
Member
From: Kansas City, MO USA
Registered: 2013-06-13
Posts: 209
Website

Re: hplip/hplip-plugin 3.18.7 - "Filter failed" after update

Since Arch Linux is not supported, doesn't look like upstream will fix this. They replied to my bug report by not even acknowledging the patch and simply saying it works on supported distributions. They then went on to explain how to install it on a supported distribution.

Since it won't be fixed upstream, can this patch be applied by Arch Linux maintainer of the hplip package?

Offline

#22 2018-08-16 06:07:22

amanouss
Member
Registered: 2014-12-08
Posts: 14

Re: hplip/hplip-plugin 3.18.7 - "Filter failed" after update

hplip 3.18.7-3 didn't solve the problem for me either for HP Laserjet P1005
I have also   downgrade  hplip but  again the printer even the test pages does not print




I'm quoting the results from hp-doctor


P1005
-----
Type: Printer
Device URI: hp:/usb/HP_LaserJet_P1005?serial=BC12E4T
PPD: /etc/cups/ppd/P1005.ppd
warning: Failed to read /etc/cups/ppd/P1005.ppd ppd file
PPD Description:
Printer ready to printr P1005 is idle.  enabled since Πεμ 16 Αυγ 2018 09:00:15 πμ EEST
Required plug-in status: Installed
Communication status: Good


--------------
| PERMISSION |
--------------

USB             P1005                          Required        -        -        OK       Node:'/dev/bus/usb/003/008' Perm:'  root  lp rw- rw- rw- rw- r--'


Checking for Configured Queues....
warning: Fail to read ppd=/etc/cups/ppd/P1005.ppd file
warning: Insufficient permission to access file /etc/cups/ppd/P1005.ppd
warning: Could not complete Queue(s) configuration check


Checking for HP Properitery Plugin's....
Plugin's already installed

Offline

#23 2018-08-16 09:14:27

loqs
Member
Registered: 2014-03-06
Posts: 6,364

Re: hplip/hplip-plugin 3.18.7 - "Filter failed" after update

@colinkeenan you could try asking on the arch bug report for the patch I generated to be applied.
HP's response is unfortunate,  the patch just reverts the use of libImageProcessor so I can understand that being ignored as  libImageProcessor is a new feature HP would want to fix.
The generic form response is unfortunate.

Offline

#24 2018-08-16 09:22:45

progandy
Member
Registered: 2012-05-17
Posts: 3,194

Re: hplip/hplip-plugin 3.18.7 - "Filter failed" after update

You might have more luck if you can reproduce the error with Manjaro (17.1.4) and the binary installer provided by hp.
https://developers.hp.com/hp-linux-imag … /downloads

Last edited by progandy (2018-08-16 09:26:19)


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Offline

#25 2018-08-16 17:40:09

colinkeenan
Member
From: Kansas City, MO USA
Registered: 2013-06-13
Posts: 209
Website

Re: hplip/hplip-plugin 3.18.7 - "Filter failed" after update

I'm not going to try anymore with upstream since I don't use a supported distribution and don't care enough to install one. I have opened a package bug to have the patch applied: https://bugs.archlinux.org/task/59681

Offline

Board footer

Powered by FluxBB