You are not logged in.

#1 2018-06-05 02:43:22

zizheng
Member
Registered: 2016-12-11
Posts: 18

GDM provides no option for Wayland

I just decided to try Wayland today and read that GDM should choose Wayland by default, unless I choose "GNOME on Xorg" explicitly. However, I see only two options, "GNOME" and "GNOME Classic", and the "GNOME" option uses x11 (as confirmed by loginctl and XDG_SESSION_TYPE).

I'm using the NVIDIA driver. My package versions (let me know if I should provide others):

  • 4.16.13-1-ARCH

  • nvidia: 396.24-7

  • gdm: 3.28.1-1

  • gnome-shell: 3.28.2-1

  • gnome-session: 3.28.1-1

  • wayland: 1.15.0-1

  • xorg-server-xwayland: 1.20.0-5

Although I have an NVIDIA GPU and an integrated Intel GPU, the Intel one is disabled in BIOS so I don't know if it matters. Output of "lspci | grep VGA":

01:00.0 VGA compatible controller: NVIDIA Corporation GP104 [GeForce GTX 1080] (rev a1)

I tried starting a Wayland session manually by executing "XDG_SESSION_TYPE=wayland dbus-run-session gnome-session", but got

dbus-daemon[4713]: [session uid=1000 pid=4713] Activating service name='org.gtk.vfs.Daemon' requested by ':1.0' (uid=1000 pid=4733 comm="/usr/lib/gnome-session-check-accelerated ")
dbus-daemon[4713]: [session uid=1000 pid=4713] Successfully activated service 'org.gtk.vfs.Daemon'
fusermount: failed to access mountpoint /run/user/1000/gvfs: Permission denied
dbus-daemon[4713]: [session uid=1000 pid=4713] Activating service name='org.freedesktop.systemd1' requested by ':1.3' (uid=1000 pid=4714 comm="/usr/lib/gnome-session-binary ")
dbus-daemon[4713]: [session uid=1000 pid=4713] Activated service 'org.freedesktop.systemd1' failed: Process org.freedesktop.systemd1 exited with status 1
dbus-daemon[4713]: [session uid=1000 pid=4713] Activating service name='org.freedesktop.systemd1' requested by ':1.5' (uid=1000 pid=4714 comm="/usr/lib/gnome-session-binary ")
dbus-daemon[4713]: [session uid=1000 pid=4713] Activated service 'org.freedesktop.systemd1' failed: Process org.freedesktop.systemd1 exited with status 1
dbus-daemon[4713]: [session uid=1000 pid=4713] Activating service name='org.freedesktop.systemd1' requested by ':1.7' (uid=1000 pid=4714 comm="/usr/lib/gnome-session-binary ")
dbus-daemon[4713]: [session uid=1000 pid=4713] Activated service 'org.freedesktop.systemd1' failed: Process org.freedesktop.systemd1 exited with status 1
dbus-daemon[4713]: [session uid=1000 pid=4713] Activating service name='org.freedesktop.systemd1' requested by ':1.8' (uid=1000 pid=4714 comm="/usr/lib/gnome-session-binary ")
dbus-daemon[4713]: [session uid=1000 pid=4713] Activated service 'org.freedesktop.systemd1' failed: Process org.freedesktop.systemd1 exited with status 1
A connection to the bus can't be made

I also tried this https://wiki.archlinux.org/index.php/NV … de_setting but it had no effect I could see.

I'm not sure where to start as I'm completely new to this stuff. I can provide logs if told how to get them. Thanks for any help!

Last edited by zizheng (2018-06-05 02:45:42)

Offline

#2 2018-06-05 03:24:49

bulletmark
Member
From: Brisbane, Australia
Registered: 2013-10-22
Posts: 398

Re: GDM provides no option for Wayland

What you describe will occur if you have set an explicit WaylandEnable=false in /etc/gdm/custom.conf. That is not the default so you possibly set this long ago in the early days of Wayland issues and have forgotten about it.

Offline

#3 2018-06-05 03:40:05

zizheng
Member
Registered: 2016-12-11
Posts: 18

Re: GDM provides no option for Wayland

bulletmark wrote:

What you describe will occur if you have set an explicit WaylandEnable=false in /etc/gdm/custom.conf. That is not the default so you possibly set this long ago in the early days of Wayland issues and have forgotten about it.

So I removed GDM completely, enabled DRM for NVIDIA following the wiki, and then tried to start Wayland from the tty after login with "XDG_SESSION_TYPE=wayland dbus-run-session gnome-session". And I got the error:

dbus-daemon[829]: [session uid=1000 pid=829] Activating service name='org.freedesktop.systemd1' requested by ':1.1' (uid=1000 pid=830 comm="/usr/lib/gnome-session-binary ")
dbus-daemon[829]: [session uid=1000 pid=829] Activated service 'org.freedesktop.systemd1' failed: Process org.freedesktop.systemd1 exited with status 1
dbus-daemon[829]: [session uid=1000 pid=829] Activating service name='org.freedesktop.systemd1' requested by ':1.3' (uid=1000 pid=830 comm="/usr/lib/gnome-session-binary ")
dbus-daemon[829]: [session uid=1000 pid=829] Activated service 'org.freedesktop.systemd1' failed: Process org.freedesktop.systemd1 exited with status 1
dbus-daemon[829]: [session uid=1000 pid=829] Activating service name='org.freedesktop.systemd1' requested by ':1.5' (uid=1000 pid=830 comm="/usr/lib/gnome-session-binary ")
dbus-daemon[829]: [session uid=1000 pid=829] Activated service 'org.freedesktop.systemd1' failed: Process org.freedesktop.systemd1 exited with status 1
dbus-daemon[829]: [session uid=1000 pid=829] Activating service name='org.freedesktop.systemd1' requested by ':1.7' (uid=1000 pid=830 comm="/usr/lib/gnome-session-binary ")
dbus-daemon[829]: [session uid=1000 pid=829] Activated service 'org.freedesktop.systemd1' failed: Process org.freedesktop.systemd1 exited with status 1
dbus-daemon[829]: [session uid=1000 pid=829] Activating service name='org.freedesktop.systemd1' requested by ':1.8' (uid=1000 pid=830 comm="/usr/lib/gnome-session-binary ")
dbus-daemon[829]: [session uid=1000 pid=829] Activated service 'org.freedesktop.systemd1' failed: Process org.freedesktop.systemd1 exited with status 1
dbus-daemon[829]: [session uid=1000 pid=829] Activating service name='org.freedesktop.systemd1' requested by ':1.8' (uid=1000 pid=830 comm="/usr/lib/gnome-session-binary ")
dbus-daemon[829]: [session uid=1000 pid=829] Activated service 'org.freedesktop.systemd1' failed: Process org.freedesktop.systemd1 exited with status 1

Offline

#4 2018-06-05 04:37:40

zizheng
Member
Registered: 2016-12-11
Posts: 18

Re: GDM provides no option for Wayland

Also, running "weston" directly in an X session works fine. Running "weston-launch" from tty results in a black screen, however.

Offline

#5 2018-06-09 01:52:33

zizheng
Member
Registered: 2016-12-11
Posts: 18

Re: GDM provides no option for Wayland

Any idea what could be wrong?

Offline

#6 2018-06-09 17:55:03

Bols Blue
Member
Registered: 2018-06-09
Posts: 1

Re: GDM provides no option for Wayland

I got the EXACT same problem.

Also I get the following error on every boot:

gnome-shell[566]: Unable to initialize Clutter: Unable to initialize the Clutter backend: no available drivers found.
gnome-shell[566]: Unable to initialize Clutter.
gnome-session[559]: gnome-session-binary[559]: WARNING: App 'org.gnome.Shell.desktop' exited with code 1
gnome-session-binary[559]: WARNING: App 'org.gnome.Shell.desktop' exited with code 1
gnome-session-binary[559]: Unrecoverable failure in required component org.gnome.Shell.desktop

This error doesn't occur when I'm uncommenting the #WaylandEnable=false line in /etc/gdm/custom.conf.
It's definitely the Nvidia driver, because nouveau is working fine with Wayland.

Also using a GTX1080, btw. I really would like to try Wayland, but it still isn't working with the proprietary Nvidia drivers I guess.

Offline

#7 2018-06-16 12:03:34

Smoerrebroed
Member
From: Germany
Registered: 2011-07-24
Posts: 70

Re: GDM provides no option for Wayland

Any more insights into this issue? I do not have a hybrid gfx setup - nVidia GPU only - but still see the exact same behavior as described here. Putting WaylandEnable=true in /etc/gdm/custom.conf does not change anything either, btw.

Cheers,

Smoerrebroed

Offline

#8 2018-08-13 02:41:36

Smoerrebroed
Member
From: Germany
Registered: 2011-07-24
Posts: 70

Re: GDM provides no option for Wayland

Still not working even with the very latest nvidia (396.51). Guess we'll have to wait for Gnome 3.30. :-/

Offline

Board footer

Powered by FluxBB