You are not logged in.

#1 2018-07-26 08:44:08

quellen
Member
Registered: 2014-05-24
Posts: 206

[SOLVED] acroread doesn't run anymore

hi,
after last system update, acroread doesn't run:

$ acroread

(process:2297): Gtk-WARNING **: 10:44:35.609: Locale not supported by C library.
	Using the fallback 'C' locale.

(acroread:2297): Gtk-WARNING **: 10:44:35.625: Unable to locate theme engine in module_path: "clearlooks",

(acroread:2297): Gtk-WARNING **: 10:44:35.626: Unable to locate theme engine in module_path: "clearlooks",

(acroread:2297): Gtk-WARNING **: 10:44:35.626: Unable to locate theme engine in module_path: "clearlooks",

(acroread:2297): Gtk-WARNING **: 10:44:35.626: Unable to locate theme engine in module_path: "clearlooks",

(acroread:2297): Gtk-WARNING **: 10:44:35.626: Unable to locate theme engine in module_path: "clearlooks",

(acroread:2297): Gtk-WARNING **: 10:44:35.626: Unable to locate theme engine in module_path: "clearlooks",

(acroread:2297): Gtk-WARNING **: 10:44:35.626: Unable to locate theme engine in module_path: "clearlooks",

(acroread:2297): Gtk-WARNING **: 10:44:35.627: Unable to locate theme engine in module_path: "clearlooks",

(acroread:2297): Gtk-WARNING **: 10:44:35.627: Unable to locate theme engine in module_path: "clearlooks",

(acroread:2297): Gtk-WARNING **: 10:44:35.627: Unable to locate theme engine in module_path: "clearlooks",

(acroread:2297): Gtk-WARNING **: 10:44:35.627: Unable to locate theme engine in module_path: "clearlooks",

(acroread:2297): Gtk-WARNING **: 10:44:35.627: Unable to locate theme engine in module_path: "clearlooks",

(acroread:2297): Gtk-WARNING **: 10:44:35.628: Unable to locate theme engine in module_path: "clearlooks",

(acroread:2297): Gtk-WARNING **: 10:44:35.628: Unable to locate theme engine in module_path: "clearlooks",

(acroread:2297): Gtk-WARNING **: 10:44:35.628: Unable to locate theme engine in module_path: "clearlooks",

(acroread:2297): Gtk-WARNING **: 10:44:35.628: Unable to locate theme engine in module_path: "clearlooks",

(acroread:2297): Gtk-WARNING **: 10:44:35.629: Unable to locate theme engine in module_path: "clearlooks",

i have tried to reinstall it from AUR and change gtk2 theme but i haven't solved.

Last edited by quellen (2018-08-13 19:18:27)

Offline

#2 2018-07-26 11:26:49

ooo
Member
Registered: 2013-04-10
Posts: 1,637

Re: [SOLVED] acroread doesn't run anymore

quellen wrote:
(process:2297): Gtk-WARNING **: 10:44:35.609: Locale not supported by C library.
	Using the fallback 'C' locale.

Broken locale?

Offline

#3 2018-07-26 17:59:41

quellen
Member
Registered: 2014-05-24
Posts: 206

Re: [SOLVED] acroread doesn't run anymore

no, it says that error because before i have ran "LANG=EN" command.

Last edited by quellen (2018-07-26 18:00:07)

Offline

#4 2018-07-26 19:15:42

loqs
Member
Registered: 2014-03-06
Posts: 15,094

Re: [SOLVED] acroread doesn't run anymore

quellen wrote:

hi,
after last system update, acroread doesn't run:

What was in the last update for that system?
What does an strace run of acroread produce?
Why did you set "LANG=EN"?

Offline

#5 2018-07-29 19:32:41

quellen
Member
Registered: 2014-05-24
Posts: 206

Re: [SOLVED] acroread doesn't run anymore

loqs wrote:

What does an strace run of acroread produce?

it crashes my system (mouse and keyboard dead) and i can't copy output.

EDIT:
now i can get it:
https://pastebin.com/EVX1Gph6

loqs wrote:

Why did you set "LANG=EN"?

because i'm italian and this forum is english.

On AUR page someone says that it's a lib32-harfbuzz problem:
https://aur.archlinux.org/packages/acroread/

Last edited by quellen (2018-07-29 19:41:06)

Offline

#6 2018-07-29 20:51:58

loqs
Member
Registered: 2014-03-06
Posts: 15,094

Re: [SOLVED] acroread doesn't run anymore

The strace appears to have been truncated it does not include output that matches with that reported on the AUR page.

Offline

#7 2018-07-30 10:21:51

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 10,250

Re: [SOLVED] acroread doesn't run anymore

quellen wrote:

because i'm italian and this forum is english.

Check https://wiki.archlinux.org/index.php/Co … s_and_code for a better way

Last edited by Lone_Wolf (2018-07-30 10:22:13)


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.
Did you use the guided installer ? If yes, I can't help you.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#8 2018-08-07 08:27:19

quellen
Member
Registered: 2014-05-24
Posts: 206

Re: [SOLVED] acroread doesn't run anymore

SOLVED?
i have downgraded "lib32-glib2" and "lib32-harfbuzz":

pacman -U https://archive.archlinux.org/packages/l/lib32-glib2/lib32-glib2-2.56.0%2B7%2Bg66948ae23-1-x86_64.pkg.tar.xz
pacman -U https://archive.archlinux.org/packages/l/lib32-harfbuzz/lib32-harfbuzz-1.7.6-2-x86_64.pkg.tar.xz

and now acroread works, but i don't know if is a good idea downgrade those packages...

Last edited by quellen (2018-08-07 08:28:32)

Offline

#9 2018-08-07 15:37:41

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 10,250

Re: [SOLVED] acroread doesn't run anymore

i don't know if is a good idea downgrade those packages...

It's a bad idea as you're doing partial upgrades now and those are not supported.
(sooner or later they'll cause problems).

Keep in mind acrobat reader for linux is stuck at version 9 and adobe stopped support for it years ago.

Try using an alternative, https://wiki.archlinux.org/index.php/Li … F_and_DjVu .
If none of those fulfill your needs, consider running latest adobe reader windows version in wine.

Last edited by Lone_Wolf (2018-08-07 15:38:03)


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.
Did you use the guided installer ? If yes, I can't help you.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#10 2018-08-07 15:55:06

loqs
Member
Registered: 2014-03-06
Posts: 15,094

Re: [SOLVED] acroread doesn't run anymore

Perhaps the package should be removed from AUR if it is unable to function with the current dependencies.

Offline

#11 2018-08-07 18:41:29

quellen
Member
Registered: 2014-05-24
Posts: 206

Re: [SOLVED] acroread doesn't run anymore

i think I'll exclude "lib32-glib2" and "lib32-harfbuzz" from pacman update until no problems arise, then i will use wine.
i need acroread because alternative (okular, evince...) are very bad on text finder, practically useless.

Last edited by quellen (2018-08-07 18:43:57)

Offline

#12 2018-08-13 15:33:58

kifuna
Member
Registered: 2015-01-29
Posts: 39

Re: [SOLVED] acroread doesn't run anymore

What I did was to copy the respective libraries from the last working versions of lib32-glib2 and lib32-harfbuzz to /opt/Adobe/Reader9/Reader/intellinux/lib/. Since only the (anyway outdated) acroread uses these outdated libraries in this path this seems reasonable to me. Maybe one could even modify the PKGBUILD to do this?

Offline

#13 2018-08-13 19:18:16

quellen
Member
Registered: 2014-05-24
Posts: 206

Re: [SOLVED] acroread doesn't run anymore

kifuna wrote:

What I did was to copy the respective libraries from the last working versions of lib32-glib2 and lib32-harfbuzz to /opt/Adobe/Reader9/Reader/intellinux/lib/. Since only the (anyway outdated) acroread uses these outdated libraries in this path this seems reasonable to me.

Great, It works! Thank you.

Last edited by quellen (2018-08-13 19:19:12)

Offline

#14 2018-08-14 19:57:10

dimich
Member
From: Kharkiv, Ukraine
Registered: 2009-11-03
Posts: 131

Re: [SOLVED] acroread doesn't run anymore

Can older versions of "lib32-glib2" and "lib32-harfbuzz" be included into acroread package with LD_LIBRARY_PATH in the same way as glibc for skypeforlinux few days ago?

Offline

#15 2018-08-26 08:00:45

olive
Member
From: Belgium
Registered: 2008-06-22
Posts: 1,490

Re: [SOLVED] acroread doesn't run anymore

What versions of "lib32-glib2" and "lib32-harfbuzz" did you use?

Offline

#16 2018-08-26 09:31:52

knedlyk
Member
From: L'viv, Ukraine
Registered: 2009-04-14
Posts: 161
Website

Re: [SOLVED] acroread doesn't run anymore

olive wrote:

What versions of "lib32-glib2" and "lib32-harfbuzz" did you use?

Use downgrader and downgrade lib32-glib2 to version 2.56.0+7+g66948ae23-1 and lib32-harfbuzz to version 1.7.6-2.

Offline

#17 2018-08-26 09:38:22

loqs
Member
Registered: 2014-03-06
Posts: 15,094

Re: [SOLVED] acroread doesn't run anymore

@knedlyk you are suggesting a partial upgrade

Offline

#18 2018-08-26 09:42:23

kifuna
Member
Registered: 2015-01-29
Posts: 39

Re: [SOLVED] acroread doesn't run anymore

No need to downgrade, just copy the respective libraries to /opt/Adobe/Reader9/Reader/intellinux/lib/.

Offline

#19 2018-08-26 10:23:29

olive
Member
From: Belgium
Registered: 2008-06-22
Posts: 1,490

Re: [SOLVED] acroread doesn't run anymore

@knedlyk That does works! Thanks a lot!

Offline

#20 2018-08-26 11:34:20

knedlyk
Member
From: L'viv, Ukraine
Registered: 2009-04-14
Posts: 161
Website

Re: [SOLVED] acroread doesn't run anymore

kifuna wrote:

What I did was to copy the respective libraries from the last working versions of lib32-glib2 and lib32-harfbuzz to /opt/Adobe/Reader9/Reader/intellinux/lib/. Since only the (anyway outdated) acroread uses these outdated libraries in this path this seems reasonable to me. Maybe one could even modify the PKGBUILD to do this?

Yes, it works, there is no need to use downgrader!

Offline

#21 2018-08-26 12:11:16

kifuna
Member
Registered: 2015-01-29
Posts: 39

Re: [SOLVED] acroread doesn't run anymore

Does anyone know how this could be included in the PKGBUILD?

Offline

#22 2018-08-26 15:35:10

piona
Member
Registered: 2018-08-26
Posts: 1

Re: [SOLVED] acroread doesn't run anymore

knedlyk wrote:
kifuna wrote:

What I did was to copy the respective libraries from the last working versions of lib32-glib2 and lib32-harfbuzz to /opt/Adobe/Reader9/Reader/intellinux/lib/. Since only the (anyway outdated) acroread uses these outdated libraries in this path this seems reasonable to me. Maybe one could even modify the PKGBUILD to do this?

Yes, it works, there is no need to use downgrader!

That solution works for acroread but it breaks packages adobe-air and e-deklaracje. These packages use acroread in embedded form with updated libraries lib32-glib2 and lib32-harfbuzz, so they will not start anymore.

Offline

#23 2018-08-26 16:15:07

olive
Member
From: Belgium
Registered: 2008-06-22
Posts: 1,490

Re: [SOLVED] acroread doesn't run anymore

@kifuna. Here is the patch against the PKGBUILD to include the old libraries. I have also removed the mozilla plugin (that do not work anymore).

https://bpaste.net/show/85b4faf6ed06

Offline

#24 2018-08-26 19:49:21

kifuna
Member
Registered: 2015-01-29
Posts: 39

Re: [SOLVED] acroread doesn't run anymore

Great, thanks!

Offline

#25 2018-09-03 10:28:11

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 10,250

Re: [SOLVED] acroread doesn't run anymore

+     mkdir oldlib
+     tar -C oldlib -axf lib32-glib2-2.56.0%2B7%2Bg66948ae23-1-x86_64.pkg.tar.xz
+     tar -C oldlib -axf lib32-harfbuzz-1.7.6-2-x86_64.pkg.tar.xz

Have you tried letting makepkg do the extraction through sources array ?

something like this :

_old-glib2-ver="2.56.0+7+g66948ae23-1"
_old-harfbuzz-ver="1.7.6-2"

source=($pkgname.desktop
         http://ardownload.adobe.com/pub/adobe/reader/unix/9.x/$pkgver/enu/AdbeRdr$pkgver-1_i486linux_enu.bin
         lib32-glib-$_oldglib2-ver::https://archive.archlinux.org/packages/l/lib32-glib2/lib32-glib2-$_oldglib2-ver-x86_64.pkg.tar.xz
         lib32-harfbuzz-$_old-harfbuzz-ver::https://archive.archlinux.org/packages/l/lib32-harfbuzz/lib32-harfbuzz-$_old-harfbuzz-ver-x86_64.pkg.tar.xz)

The prepare function would become simpler that way, and the $srcdir lay-out feels cleaner.
(If you do this don't forget to adapt the build function also).


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.
Did you use the guided installer ? If yes, I can't help you.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

Board footer

Powered by FluxBB