You are not logged in.

#1 2018-08-10 17:20:38

jbenge1
Member
From: Lordran
Registered: 2018-04-09
Posts: 107

SSH: message authentication code incorrect

When trying to access media (such as videos/movies) through my sshfs mount, after a random period of time I am presented with the following error

ssh_dispatch_run_fatal: Connection to 192.168.1.23 port 22: message authentication code incorrect
remote host has disconnected

sent:               6557 messages, 205281 bytes
received:           6554 messages, 196680118 bytes
rtt min/max/avg:    0ms/81ms/4ms
num connect:        1

And after googling aroudn, I am unsure how to proceed. Most of the answers I found tell me it is either a a bug in my ssh https://unix.stackexchange.com/question … ect#288055

Or a problem with the hardware.

Here is the output of dmesg on the client side: https://ptpb.pw/7BWJ

And the output of dmesg on the server sided: https://ptpb.pw/VCL0

It may be worth noting that I am able to access/stream the media through an sshfs mount on my windows machine without any disconnects

Thank you in advance!


"Dr. Madden, why don't the natural numbers include 0?" -me
"....... Take a philosophy course" -Dr. Madden

Offline

#2 2018-08-10 19:02:17

seth
Member
Registered: 2012-09-03
Posts: 8,695

Re: SSH: message authentication code incorrect

Did you see the impressive amount of link status changes on the server?
How's the network there configured? Any power saving mechanisms that might stop the link?
Check your server journal, eg. whether NM or so "detects" a carrier loss and sets the link down or what else might cause this.

Offline

#3 2018-08-10 20:10:49

jbenge1
Member
From: Lordran
Registered: 2018-04-09
Posts: 107

Re: SSH: message authentication code incorrect

seth wrote:

Did you see the impressive amount of link status changes on the server?

I was attempting a new personal record cool

As far as the network settings, it's sitting behind my home network with the routers default settings. Here is the config file for the profile enp2s0

Description='A basic static ethernet connection'
Interface=enp2s0
Connection=ethernet
IP=static
Address=('192.168.1.23/24' '192.168.1.87/24')
#Routes=('192.168.0.0/24 via 192.168.1.2')
Gateway='192.168.1.1'
DNS=('192.168.1.1')

## For IPv6 autoconfiguration
#IP6=stateless

## For IPv6 static address configuration
#IP6=static
#Address6=('1234:5678:9abc:def::1/64' '1234:3456::123/96')
#Routes6=('abcd::1234')
#Gateway6='1234:0:123::abcd'

The journal just tells me that it's accepted my public key and that it recived a disconnect from the user (though looking at the times, I think this is me actually disconnecting)

Aug 10 12:40:53 LenovoNFS sshd[14697]: Accepted publickey for justin from 192.168.1.120 port 59762 ssh2: RSA SHA256:tnw/DPlyjgCUMkJ99brfl6ghGXDYOQwdhN1sjl6WdlI

and the full contents of the journal: https://ptpb.pw/cHla

I had powerdevil installed (with kde) for awhile but it should be gone (as I got rid of kde and powerdevil) and I haven't installed any other so I hope there isn't any power saving settings to stop the link..

Last edited by jbenge1 (2018-08-10 20:14:21)


"Dr. Madden, why don't the natural numbers include 0?" -me
"....... Take a philosophy course" -Dr. Madden

Offline

#4 2018-08-10 20:26:36

seth
Member
Registered: 2012-09-03
Posts: 8,695

Re: SSH: message authentication code incorrect

Aug 09 23:29:46 LenovoNFS dhcpcd[378]: enp2s0: carrier lost
Aug 09 23:29:46 LenovoNFS kernel: r8169 0000:02:00.0 enp2s0: link down
...
Aug 09 23:29:48 LenovoNFS dhcpcd[378]: enp2s0: carrier acquired
Aug 09 23:29:48 LenovoNFS kernel: r8169 0000:02:00.0 enp2s0: link up
...
Aug 09 23:29:50 LenovoNFS dhcpcd[378]: enp2s0: carrier lost
Aug 09 23:29:50 LenovoNFS kernel: r8169 0000:02:00.0 enp2s0: link down
Aug 09 23:29:53 LenovoNFS dhcpcd[378]: enp2s0: carrier acquired
Aug 09 23:29:53 LenovoNFS kernel: r8169 0000:02:00.0 enp2s0: link up

All link status changes in the journal are caused by carrier changes - cable? (broken, badly seated - check both ends)
Probably unrelated, but see https://wiki.archlinux.org/index.php/IPv6#dhcpcd_2

Offline

#5 2018-08-10 20:42:46

jbenge1
Member
From: Lordran
Registered: 2018-04-09
Posts: 107

Re: SSH: message authentication code incorrect

The cable is well seated, though I don't currently have acces to a separate cable atm but I will certainly have to look into that route as it is a fairly old cable!

Altering the dhcpcd.conf didn't resolve the error.


"Dr. Madden, why don't the natural numbers include 0?" -me
"....... Take a philosophy course" -Dr. Madden

Offline

#6 2018-08-10 22:16:16

jbenge1
Member
From: Lordran
Registered: 2018-04-09
Posts: 107

Re: SSH: message authentication code incorrect

Ok I found a different cable (likely just as old) same problems arise, so I went out to the store and bough a new one, and I am still getting the same problem. Most recent journal output: https://ptpb.pw/gxWJ

I'm wondering if it could be a problem with the laptop connection point?


"Dr. Madden, why don't the natural numbers include 0?" -me
"....... Take a philosophy course" -Dr. Madden

Offline

#7 2018-08-11 06:07:53

seth
Member
Registered: 2012-09-03
Posts: 8,695

Re: SSH: message authentication code incorrect

The switch might be resetting wildly.
You should check whether the client also looses the carrier at about the same times the server does.

Offline

#8 2018-08-11 23:05:50

jbenge1
Member
From: Lordran
Registered: 2018-04-09
Posts: 107

Re: SSH: message authentication code incorrect

Here are the two most recent journals

Client: https://ptpb.pw/REdv
Server: https://ptpb.pw/ZDxQ

I am not seeing a loss of the carrier at around the same time the server does


"Dr. Madden, why don't the natural numbers include 0?" -me
"....... Take a philosophy course" -Dr. Madden

Offline

#9 2018-08-12 06:13:02

seth
Member
Registered: 2012-09-03
Posts: 8,695

Re: SSH: message authentication code incorrect

Why are there error messages from a netctl service (falsely) covering wlan0 while dhcpcd still covers wlp1s0?

systemctl list-units | grep -iE '(net|dhcp)'
systemctl list-unit-files --state=enabled

(on the server)

Offline

#10 2018-08-12 17:19:09

jbenge1
Member
From: Lordran
Registered: 2018-04-09
Posts: 107

Re: SSH: message authentication code incorrect

$ systemctl list-units | grep -iE '(net|dhcp)'
  sys-devices-pci0000:00-0000:00:02.3-0000:01:00.0-net-wlp1s0.device                          loaded active plugged   RTL8821AE 802.11ac PCIe Wireless Network Adapter                             
  sys-devices-pci0000:00-0000:00:02.4-0000:02:00.0-net-enp2s0.device                          loaded active plugged   RTL810xE PCI Express Fast Ethernet controller                                
  sys-subsystem-net-devices-enp2s0.device                                                     loaded active plugged   RTL810xE PCI Express Fast Ethernet controller                                
  sys-subsystem-net-devices-wlp1s0.device                                                     loaded active plugged   RTL8821AE 802.11ac PCIe Wireless Network Adapter                             
  dhcpcd.service                                                                              loaded active running   dhcpcd on all interfaces                                                     
* netctl@GiantsFan.service                                                                    loaded failed failed    A simple WPA encrypted wireless connection using a static IP                 
  netctl@LinksysStaticEthernet.service                                                        loaded active exited    A basic static ethernet connection                                           
  systemd-timesyncd.service                                                                   loaded active running   Network Time Synchronization                                                 
  system-netctl.slice                                                                         loaded active active    system-netctl.slice                                                          
  network-online.target                                                                       loaded active active    Network is Online                                                            
  network.target                                                                              loaded active active    Network                                                                      
  nss-lookup.target                                                                           loaded active active    Host and Network Name Lookups                                          

systemctl list-unit-files --state=enabled
UNIT FILE                            STATE  
autovt@.service                      enabled
dhcpcd.service                       enabled
getty@.service                       enabled
netctl@GiantsFan.service             enabled
netctl@LinksysStaticEthernet.service enabled
nfs-server.service                   enabled
sshd.service                         enabled
systemd-timesyncd.service            enabled
remote-fs.target                     enabled

9 unit files listed.

The netctl @GiantsFan was some old wireless profile from its previous home.


"Dr. Madden, why don't the natural numbers include 0?" -me
"....... Take a philosophy course" -Dr. Madden

Offline

#11 2018-08-12 17:31:58

Slithery
Forum Moderator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 2,960

Re: SSH: message authentication code incorrect

Network wiki page wrote:

There are many solutions to choose from, but remember that all of them are mutually exclusive; you should not run two daemons simultaneously.

You have both netctl and dhcpcd fighting over control of your hardware. Why is dhcpcd enabled?


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

#12 2018-08-12 18:09:08

jbenge1
Member
From: Lordran
Registered: 2018-04-09
Posts: 107

Re: SSH: message authentication code incorrect

Slithery wrote:

You have both netctl and dhcpcd fighting over control of your hardware. Why is dhcpcd enabled?

I for some reason thought netctl wouldn't handle wired connections (and I have no idea why) and when I realized it could I forgot to disable dhcpcd. However upon disabling and stopping dhcpcd, and rebooting the computer I am still experiencing the drop in connection from the server


"Dr. Madden, why don't the natural numbers include 0?" -me
"....... Take a philosophy course" -Dr. Madden

Offline

#13 2018-08-12 19:33:18

seth
Member
Registered: 2012-09-03
Posts: 8,695

Re: SSH: message authentication code incorrect

Updated journal (and please in general w/ the "-x" switch, the "explanations" are all really silly and just clutter the output)

Offline

#14 2018-08-13 03:22:48

jbenge1
Member
From: Lordran
Registered: 2018-04-09
Posts: 107

Re: SSH: message authentication code incorrect

My mistake!
Here is the server's journal: https://ptpb.pw/IpxA

and the client side journal: https://ptpb.pw/XQ_j


"Dr. Madden, why don't the natural numbers include 0?" -me
"....... Take a philosophy course" -Dr. Madden

Offline

#15 2018-08-13 06:43:21

seth
Member
Registered: 2012-09-03
Posts: 8,695

Re: SSH: message authentication code incorrect

Notice that you posted journals dating bacl to may. The client one is a 43MB text file…

The only thing that remotely indicates a problem is the re-connect cycle after the client apparently woke up from S3,

Aug 12 20:17:10 LenovoNFS sshd[789]: Accepted publickey for justin from 192.168.1.120 port 59882 ssh2: RSA SHA256:tnw/DPlyjgCUMkJ99brfl6ghGXDYOQwdhN1sjl6WdlI
Aug 12 20:18:39 LenovoNFS sshd[791]: Received disconnect from 192.168.1.120 port 59882:11: disconnected by user
Aug 12 20:18:39 LenovoNFS sshd[791]: Disconnected from user justin 192.168.1.120 port 59882
Aug 12 20:20:12 LenovoNFS sshd[800]: Accepted publickey for justin from 192.168.1.120 port 60240 ssh2: RSA SHA256:tnw/DPlyjgCUMkJ99brfl6ghGXDYOQwdhN1sjl6WdlI

but the client log ends before at Aug 12 20:15:56 …

Since there's dhcpcd and netctl entries in the client, does https://bbs.archlinux.org/viewtopic.php … 6#p1802086 maybe apply there as well?

Offline

#16 2018-08-13 07:26:16

jbenge1
Member
From: Lordran
Registered: 2018-04-09
Posts: 107

Re: SSH: message authentication code incorrect

The client doesn't have dhcpcd enabled so this shouldn't be the case sad

$ systemctl list-unit-files --state=enabled
UNIT FILE                   STATE  
autovt@.service             enabled
display-manager.service     enabled
getty@.service              enabled
intel-undervolt.service     enabled
lm_sensors.service          enabled
netctl@HomeWifi5GHz.service enabled
sddm.service                enabled
remote-fs.target            enabled
backupTimer.timer           enabled
updatePackageCount.timer    enabled

10 unit files listed.

I don't know if it's worth noting or not, but when I mount using

$ mount -t nfs 192.168.1.23:/home/justin LenovoMount

I do not recieve any disconnects (unless I leave the home network...)

Also a separate server running on a different network mounted with sshfs I have the exact same errors (That server is running ubuntu, though I am not asking to debug that one I just wanted to see if a different machine would yield similar errors attempting to narrow down if it the server or the client)

Last edited by jbenge1 (2018-08-13 07:30:15)


"Dr. Madden, why don't the natural numbers include 0?" -me
"....... Take a philosophy course" -Dr. Madden

Offline

#17 2018-08-14 00:06:19

jbenge1
Member
From: Lordran
Registered: 2018-04-09
Posts: 107

Re: SSH: message authentication code incorrect

I am also able to connect to the ubuntu server from the Lenovo server without any interruptions


"Dr. Madden, why don't the natural numbers include 0?" -me
"....... Take a philosophy course" -Dr. Madden

Offline

#18 2018-08-14 06:51:03

seth
Member
Registered: 2012-09-03
Posts: 8,695

Re: SSH: message authentication code incorrect

Pass "-o debug,sshfs_debug" to sshfs for more details.
Just to be sure: this happens randomly after the mount worked for some time. It's not that at some point you fail to connect at all?

Offline

#19 2018-08-14 07:47:49

jbenge1
Member
From: Lordran
Registered: 2018-04-09
Posts: 107

Re: SSH: message authentication code incorrect

Yes it happens randomly (sometimes it lasts longer than other times and I get my hopes up)

sshfs -o sshfs_debug justin@192.168.1.23:/home/justin LenovoMount/ -C

...
[01065] READ
[01066] READ
[01067] READ
[01068] READ
  [01065]           DATA    32781bytes (15ms)
  [01066]           DATA    32781bytes (21ms)
  [01067]           DATA    32781bytes (28ms)
  [01068]           DATA    32781bytes (31ms)
[01069] READ
[01070] READ
[01071] READ
[01072] READ
ssh_dispatch_run_fatal: Connection to 192.168.1.23 port 22: message authentication code incorrect
remote host has disconnected

sent:               1072 messages, 35617 bytes
received:           1068 messages, 29314246 bytes
rtt min/max/avg:    0ms/57ms/19ms
num connect:        1

This is the abriged version, but previous to the ellipses is all just all read logs


"Dr. Madden, why don't the natural numbers include 0?" -me
"....... Take a philosophy course" -Dr. Madden

Offline

Board footer

Powered by FluxBB