You are not logged in.

#1 2018-08-27 07:35:07

is0lated
Member
Registered: 2013-02-06
Posts: 10

[Solved] Can't get Vulkan working

I've got got both vulkan-icd-loader and vulkan-radeon (as well as the lib32 versions) installed but whenever I run vulkaninfo I get the output


$ vulkaninfo 
==========
VULKANINFO
==========

Vulkan Instance Version: 1.1.82

ERROR: [Loader Message] Code 0 : /usr/lib32/libvulkan_radeon.so: wrong ELF class: ELFCLASS32
/build/vulkan-tools/src/Vulkan-Tools/vulkaninfo/vulkaninfo.c:3339: failed with VK_ERROR_INITIALIZATION_FAILED

If I run remove the lib32 versions of the vulkan packages and run vulkaninfo I get the same message, but without the wrong ELF class message. The card is an AMD r7 360 which is GCN 2.0 unless my information is wrong. I'm running the latest Mesa and vulkan-icd-loader and vulkan-radeon. The only thing I can think of is that I made attempts at getting openCL to work on my Intel CPU and had xf86-video-intel installed when I tried getting Vulkan to work, but I don't think that should have interfered with anything. I'm at a bit of a loss here, I'm not sure if it's something I've managed to do or if there's some incompatibility with my card. I've put in the output of glxinfo and my 20-radeon.conf at the end here in case anything from that throws up a red flag.

$ glxinfo |grep -i gles
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.1
$ glxinfo |grep -i opengl
OpenGL vendor string: X.Org
OpenGL renderer string: AMD BONAIRE (DRM 2.50.0, 4.18.5-arch1-1-ARCH, LLVM 6.0.1)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 18.1.7
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.1 Mesa 18.1.7
OpenGL shading language version string: 1.40
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.1 Mesa 18.1.7
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10
OpenGL ES profile extensions:
$ cat /etc/X11/xorg.conf.d/20-radeon.conf 
Section "Device"
	Identifier  "Radeon"
	Driver "radeon"
	Option "ColorTiling" "on"
	Option "ColorTiling2D" "on"
	Option "DRI" "3"
EndSection

Last edited by is0lated (2018-09-08 13:45:09)

Offline

#2 2018-09-04 14:33:03

Gosi
Member
From: Vienna, Austria
Registered: 2010-02-25
Posts: 46

Re: [Solved] Can't get Vulkan working

I had the same problem and got it working by switching to amdgpu with these additional steps:

https://wiki.archlinux.org/index.php/AM … 29_support

I also replaced 20-radeon.conf with 20-amdgpu.conf

It looks as if vulkan is currently not working with older cards and radeon (there is another thread here https://bbs.archlinux.org/viewtopic.php?id=238799)

So far i haven't encountered any problems with amdgpu, even if though it is marked as experimental for GCN 2 and 1 cards.

Offline

#3 2018-09-08 10:59:02

is0lated
Member
Registered: 2013-02-06
Posts: 10

Re: [Solved] Can't get Vulkan working

Thanks, I'll give that a another go. I had some trouble getting amdgpu to work properly, but I didn't replace 20-radeon.conf so that may have played a part.

Offline

#4 2018-09-08 13:44:46

is0lated
Member
Registered: 2013-02-06
Posts: 10

Re: [Solved] Can't get Vulkan working

I've managed to get everything working using AMDGPU now. I'll mark this as solved and collect everything into this post in case anyone else has this problem.

Removing 20-radeon.conf from "/etc/X11/xorg.conf.d/" seems to have fixed my issue getting AMDGPU to work. Other than removing that file, I just followed the instructions for disabling radeon support for my card and enabling AMDGPU support for my card. Now that I've AMDGPU working vulkaninfo successfully recognises my card.

Offline

Board footer

Powered by FluxBB