You are not logged in.

#1 2014-03-31 15:42:44

eugen.b
Member
Registered: 2014-02-27
Posts: 7

Kmix annoying problem - always maximum volume

I don't know whether this is a laptop specific problem or not but I only noticed it on my new laptop which I got a week ago (Asus X550LB).
Every time I want to lower the sound volume it goes back to its maximum level. It happens at login/logout or when a notification sound is played or even when I start a new application, no matter which.
I tried checking/unchecking the "restore volumes on login" option in kmix settings to no change.
I didn't have this problem on my previous laptop but I have it now and it's really annoying.

Can someone help me fix this?

Thanks

Offline

#2 2014-12-05 06:40:26

YCH
Member
Registered: 2014-01-28
Posts: 27

Re: Kmix annoying problem - always maximum volume

I have exactly same problem.

Could not figure out what event(program) occur this volume reset.

My previous DE was gnome(-S gnome) and xmonad. Then kde know. I didn't uninstall anything. Pulseaudio on.

$ yaourt -Q kde-meta -g
extra/kde-meta-kdeaccessibility 4.13-3 (kde-meta)
extra/kde-meta-kdeadmin 4.13-3 (kde-meta)
extra/kde-meta-kdeartwork 4.13-3 (kde-meta)
extra/kde-meta-kdebase 4.13-3 (kde-meta)
extra/kde-meta-kdeedu 4.13-3 (kde-meta)
extra/kde-meta-kdegames 4.13-3 (kde-meta)
extra/kde-meta-kdegraphics 4.13-3 (kde-meta)
extra/kde-meta-kdemultimedia 4.13-3 (kde-meta)
extra/kde-meta-kdenetwork 4.13-3 (kde-meta)
extra/kde-meta-kdepim 4.13-3 (kde-meta)
extra/kde-meta-kdeplasma-addons 4.13-3 (kde-meta)
extra/kde-meta-kdesdk 4.13-3 (kde-meta)
extra/kde-meta-kdetoys 4.13-3 (kde-meta)
extra/kde-meta-kdeutils 4.13-3 (kde-meta)
extra/kde-meta-kdewebdev 4.13-3 (kde-meta)
extra/kde-wallpapers 4.14.3-1 (kde kde-meta kdebase)

$ y -Qo $(which kmix)
/usr/bin/kmix is owned by kdemultimedia-kmix 4.14.3-1

YCH

Offline

#3 2014-12-07 10:57:39

erkexzcx
Banned
From: Kaunas
Registered: 2014-09-28
Posts: 77

Re: Kmix annoying problem - always maximum volume

eugen.b wrote:

I don't know whether this is a laptop specific problem or not but I only noticed it on my new laptop which I got a week ago (Asus X550LB).
Every time I want to lower the sound volume it goes back to its maximum level. It happens at login/logout or when a notification sound is played or even when I start a new application, no matter which.
I tried checking/unchecking the "restore volumes on login" option in kmix settings to no change.
I didn't have this problem on my previous laptop but I have it now and it's really annoying.

Can someone help me fix this?

Thanks

sounds like I had this problem. Everything is fine, but system notification sounds are always at 100% even if the sound is at 1%? But some apps respect kmix volume and plays normally, right?

well, I suggest to download "pavucontrol", and check system sounds level. play a bit with pulseaudio settings etc. I believe you are using KDE, also check there settings of sound. Also check out this arch wiki page: https://wiki.archlinux.org/index.php/Pu … leshooting

I have never succeed to get KDE to work properly with pulseaudio... hmm


Allergic to admins&moderators. They scare me.

Offline

#4 2015-03-26 21:24:44

star_storm
Member
Registered: 2015-03-24
Posts: 4

Re: Kmix annoying problem - always maximum volume

Having this issue also. I'm using an Asus X550ln with KDE Plasma 5. Installing pavucontrol didn't work for me. Has anyone found a fix?

Offline

#5 2015-03-26 21:47:57

star_storm
Member
Registered: 2015-03-24
Posts: 4

Re: Kmix annoying problem - always maximum volume

Found solution for anyone else with this issue: edit /etc/pulse/daemon.conf and set "flat-volumes = no"
Heres where I got the solution
EDIT: Never mind this didn't work for some reason the first notification I got didnt change the volume

Last edited by star_storm (2015-03-26 21:52:18)

Offline

#6 2018-09-13 16:45:28

Sybelius
Member
From: Gaborone - Botswana
Registered: 2014-09-05
Posts: 1

Re: Kmix annoying problem - always maximum volume

Needing to change Phonon Backend, I experienced it on Debian 9 KDE (Plasma 5) maybe the same solution is good for Arch too, steps:
- Assuming the default one is Phonon Backend VLC change with Phonon GStreamer Backend downloading/installing Phonon Qt5 GStreamer 1.0 backend and suggested plugins gstreamer1.0-plugins-good
gstreamer1.0-plugins-ugly.
- Open System Settings>Multimedia>Backend
- Select GStreamer Backend>pull it on top>Apply. Done smile

Offline

#7 2018-09-13 17:03:08

Slithery
Forum Moderator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 2,995

Re: Kmix annoying problem - always maximum volume

Please read the forum code of conduct, especially the section regarding necrobumping.

I'm going to close this old thread now.


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

Board footer

Powered by FluxBB