You are not logged in.

#1 2018-09-14 06:03:41

darklord69
Member
Registered: 2018-09-14
Posts: 4

Get stuck on installing AMD Radeon Driver

I tried installing xf86-video-amdgpu / xf86-video-ati and put the corresponding config file from arch wiki https://wiki.archlinux.org/index.php/AM … figuration / https://wiki.archlinux.org/index.php/AT … figuration in /etc/X11/xorg.conf.d/  but none of them seems to work.

My graphic card: AMD ATI Radeon R5 M315

My x log file: https://pastebin.com/sHfgtTGy

Offline

#2 2018-09-14 08:35:28

Mr.Elendig
#archlinux@freenode channel op
From: The intertubes
Registered: 2004-11-07
Posts: 3,951

Re: Get stuck on installing AMD Radeon Driver

You have to disable amdgpu at boot time. (But why not use amdgpu?)


Evil #archlinux@freenode channel op and general support dude.
. files on github, Screenshots, Random pics and the rest

Offline

#3 2018-09-14 08:37:08

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 5,564

Re: Get stuck on installing AMD Radeon Driver

You have a dual GPU system, you can't directly access the amd card, however you can set DRI_PRIME=1 to offload rendering of any given application to the AMD card, read through https://wiki.archlinux.org/index.php/PR … offloading

Offline

#4 2018-09-14 09:50:50

darklord69
Member
Registered: 2018-09-14
Posts: 4

Re: Get stuck on installing AMD Radeon Driver

Mr.Elendig wrote:

But why not use amdgpu?

I tried to use it, but it crashed my x server.

V1del wrote:

You have a dual GPU system, you can't directly access the amd card, however you can set DRI_PRIME=1 to offload rendering of any given application to the AMD card, read through https://wiki.archlinux.org/index.php/PR … offloading

Can I make my discrete amd gpu as default so I don't need to set DRI_PRIME=1 everytime launching an application?
I read the wiki but don't know how to get the values needed for the xorg configuration.

Offline

#5 2018-09-14 10:53:47

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 6,346

Re: Get stuck on installing AMD Radeon Driver

[  2472.029] (--) PCI:*(0@0:2:0) 8086:1916:1028:06c2 rev 7, Mem @ 0xd1000000/16777216, 0xb0000000/268435456, I/O @ 0x0000f000/64, BIOS @ 0x????????/131072
[  2472.030] (--) PCI: (1@0:0:0) 1002:6907:1028:06c2 rev 135, Mem @ 0xc0000000/268435456, 0xd0000000/2097152, 0xd0200000/262144, I/O @ 0x0000e000/256, BIOS @ 0x????????/131072

Those lines from xorg log shows how X sees your videocards.

post lspci -knn so we can help identifying which card corresponds to which id and which values should be in your xorg conf file for "Discrete card as primary GPU" .


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#6 2018-09-14 11:23:38

darklord69
Member
Registered: 2018-09-14
Posts: 4

Re: Get stuck on installing AMD Radeon Driver

Lone_Wolf wrote:
[  2472.029] (--) PCI:*(0@0:2:0) 8086:1916:1028:06c2 rev 7, Mem @ 0xd1000000/16777216, 0xb0000000/268435456, I/O @ 0x0000f000/64, BIOS @ 0x????????/131072
[  2472.030] (--) PCI: (1@0:0:0) 1002:6907:1028:06c2 rev 135, Mem @ 0xc0000000/268435456, 0xd0000000/2097152, 0xd0200000/262144, I/O @ 0x0000e000/256, BIOS @ 0x????????/131072

Those lines from xorg log shows how X sees your videocards.

post lspci -knn so we can help identifying which card corresponds to which id and which values should be in your xorg conf file for "Discrete card as primary GPU" .

Here is the output of the command, thank you for putting your time helping me.

00:00.0 Host bridge [0600]: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Host Bridge/DRAM Registers [8086:1904] (rev 08)
	Subsystem: Dell Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Host Bridge/DRAM Registers [1028:06c2]
	Kernel driver in use: skl_uncore
00:02.0 VGA compatible controller [0300]: Intel Corporation Skylake GT2 [HD Graphics 520] [8086:1916] (rev 07)
	DeviceName:  Onboard IGD
	Subsystem: Dell Skylake GT2 [HD Graphics 520] [1028:06c2]
	Kernel driver in use: i915
	Kernel modules: i915
00:14.0 USB controller [0c03]: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller [8086:9d2f] (rev 21)
	Subsystem: Dell Sunrise Point-LP USB 3.0 xHCI Controller [1028:06c2]
	Kernel driver in use: xhci_hcd
	Kernel modules: xhci_pci
00:14.2 Signal processing controller [1180]: Intel Corporation Sunrise Point-LP Thermal subsystem [8086:9d31] (rev 21)
	Subsystem: Dell Sunrise Point-LP Thermal subsystem [1028:06c2]
	Kernel driver in use: intel_pch_thermal
	Kernel modules: intel_pch_thermal
00:15.0 Signal processing controller [1180]: Intel Corporation Sunrise Point-LP Serial IO I2C Controller #0 [8086:9d60] (rev 21)
	Subsystem: Dell Sunrise Point-LP Serial IO I2C Controller [1028:06c2]
	Kernel driver in use: intel-lpss
	Kernel modules: intel_lpss_pci
00:15.1 Signal processing controller [1180]: Intel Corporation Sunrise Point-LP Serial IO I2C Controller #1 [8086:9d61] (rev 21)
	Subsystem: Dell Sunrise Point-LP Serial IO I2C Controller [1028:06c2]
	Kernel driver in use: intel-lpss
	Kernel modules: intel_lpss_pci
00:16.0 Communication controller [0780]: Intel Corporation Sunrise Point-LP CSME HECI #1 [8086:9d3a] (rev 21)
	Kernel driver in use: mei_me
	Kernel modules: mei_me
00:17.0 SATA controller [0106]: Intel Corporation Sunrise Point-LP SATA Controller [AHCI mode] [8086:9d03] (rev 21)
	Subsystem: Dell Sunrise Point-LP SATA Controller [AHCI mode] [1028:06c2]
	Kernel driver in use: ahci
	Kernel modules: ahci
00:1c.0 PCI bridge [0604]: Intel Corporation Sunrise Point-LP PCI Express Root Port #1 [8086:9d10] (rev f1)
	Kernel driver in use: pcieport
00:1c.4 PCI bridge [0604]: Intel Corporation Sunrise Point-LP PCI Express Root Port #5 [8086:9d14] (rev f1)
	Kernel driver in use: pcieport
00:1c.5 PCI bridge [0604]: Intel Corporation Sunrise Point-LP PCI Express Root Port #6 [8086:9d15] (rev f1)
	Kernel driver in use: pcieport
00:1f.0 ISA bridge [0601]: Intel Corporation Sunrise Point-LP LPC Controller [8086:9d48] (rev 21)
	Subsystem: Dell Sunrise Point-LP LPC Controller [1028:06c2]
00:1f.2 Memory controller [0580]: Intel Corporation Sunrise Point-LP PMC [8086:9d21] (rev 21)
	Subsystem: Dell Sunrise Point-LP PMC [1028:06c2]
00:1f.3 Audio device [0403]: Intel Corporation Sunrise Point-LP HD Audio [8086:9d70] (rev 21)
	Subsystem: Dell Sunrise Point-LP HD Audio [1028:06c2]
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel, snd_soc_skl
00:1f.4 SMBus [0c05]: Intel Corporation Sunrise Point-LP SMBus [8086:9d23] (rev 21)
	Subsystem: Dell Sunrise Point-LP SMBus [1028:06c2]
	Kernel driver in use: i801_smbus
	Kernel modules: i2c_i801
01:00.0 Display controller [0380]: Advanced Micro Devices, Inc. [AMD/ATI] Meso XT [Radeon R5 M315] [1002:6907] (rev 87)
	Subsystem: Dell Meso XT [Radeon R5 M315] [1028:06c2]
	Kernel driver in use: amdgpu
	Kernel modules: amdgpu
02:00.0 Network controller [0280]: Intel Corporation Wireless 3160 [8086:08b3] (rev 83)
	Subsystem: Intel Corporation Dual Band Wireless AC 3160 [8086:8470]
	Kernel driver in use: iwlwifi
	Kernel modules: iwlwifi
03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 0c)
	Subsystem: Dell RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [1028:06c2]
	Kernel driver in use: r8169
	Kernel modules: r8169

Offline

#7 2018-09-14 11:44:29

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 5,564

Re: Get stuck on installing AMD Radeon Driver

Something like

Section "ServerLayout"
    Identifier "layout"
    Screen 0 "amdgpu"
    Inactive "modesetting"
EndSection

Section "Device"
    Identifier  "amdgpu"
    Driver      "amdgpu"
    BusID       "PCI:1:0:0" 
EndSection

Section "Screen"
    Identifier "amdgpu"
    Device "amdgpu"
EndSection

Section "Device"
    Identifier  "modesetting"
    Driver      "modesetting"
    BusID       "PCI:0:2:0"
EndSection

Section "Screen"
    Identifier "modesetting"
    Device "modesetting"
EndSection

and in your xinitrc or wherever you start X:

xrandr --setprovideroutputsource modesetting amdgpu

should do the trick

Offline

#8 2018-09-14 13:02:25

darklord69
Member
Registered: 2018-09-14
Posts: 4

Re: Get stuck on installing AMD Radeon Driver

V1del wrote:

Something like

Section "ServerLayout"
    Identifier "layout"
    Screen 0 "amdgpu"
    Inactive "modesetting"
EndSection

Section "Device"
    Identifier  "amdgpu"
    Driver      "amdgpu"
    BusID       "PCI:1:0:0" 
EndSection

Section "Screen"
    Identifier "amdgpu"
    Device "amdgpu"
EndSection

Section "Device"
    Identifier  "modesetting"
    Driver      "modesetting"
    BusID       "PCI:0:2:0"
EndSection

Section "Screen"
    Identifier "modesetting"
    Device "modesetting"
EndSection

and in your xinitrc or wherever you start X:

xrandr --setprovideroutputsource modesetting amdgpu

should do the trick

I did as you told but there is still an error
[   370.025] (EE) Screen(s) found, but none have a usable configuration.

Here is my log file

[   369.932] (WW) Failed to open protocol names file lib/xorg/protocol.txt
[   369.932] 
X.Org X Server 1.20.1
X Protocol Version 11, Revision 0
[   369.932] Build Operating System: Linux Arch Linux
[   369.932] Current Operating System: Linux arch 4.18.5-arch1-1-ARCH #1 SMP PREEMPT Fri Aug 24 12:48:58 UTC 2018 x86_64
[   369.932] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=b8437cb2-c2f9-42d1-9de9-f973dad79328 rw quiet
[   369.933] Build Date: 09 August 2018  06:37:34PM
[   369.933]  
[   369.933] Current version of pixman: 0.34.0
[   369.933] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[   369.933] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   369.933] (==) Log file: "/home/anhthi/.local/share/xorg/Xorg.0.log", Time: Fri Sep 14 19:51:13 2018
[   369.933] (==) Using config directory: "/etc/X11/xorg.conf.d"
[   369.933] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   369.933] (==) ServerLayout "layout"
[   369.933] (**) |-->Screen "amdgpu" (0)
[   369.933] (**) |   |-->Monitor "<default monitor>"
[   369.934] (**) |   |-->Device "amdgpu"
[   369.934] (**) |   |-->GPUDevice "modesetting"
[   369.934] (**) |   |-->GPUDevice "AMD"
[   369.934] (==) No monitor specified for screen "amdgpu".
	Using a default monitor configuration.
[   369.934] (**) |-->Inactive Device "modesetting"
[   369.934] (==) Automatically adding devices
[   369.934] (==) Automatically enabling devices
[   369.934] (==) Automatically adding GPU devices
[   369.934] (==) Automatically binding GPU devices
[   369.934] (==) Max clients allowed: 256, resource mask: 0x1fffff
[   369.934] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/misc".
[   369.934] 	Entry deleted from font path.
[   369.934] 	(Run 'mkfontdir' on "/usr/share/fonts/misc").
[   369.934] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/Type1".
[   369.934] 	Entry deleted from font path.
[   369.934] 	(Run 'mkfontdir' on "/usr/share/fonts/Type1").
[   369.934] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi".
[   369.934] 	Entry deleted from font path.
[   369.934] 	(Run 'mkfontdir' on "/usr/share/fonts/100dpi").
[   369.934] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi".
[   369.934] 	Entry deleted from font path.
[   369.934] 	(Run 'mkfontdir' on "/usr/share/fonts/75dpi").
[   369.934] (==) FontPath set to:
	/usr/share/fonts/TTF,
	/usr/share/fonts/OTF
[   369.934] (==) ModulePath set to "/usr/lib/xorg/modules"
[   369.934] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[   369.934] (II) Module ABI versions:
[   369.934] 	X.Org ANSI C Emulation: 0.4
[   369.934] 	X.Org Video Driver: 24.0
[   369.934] 	X.Org XInput driver : 24.1
[   369.934] 	X.Org Server Extension : 10.0
[   369.934] (++) using VT number 1

[   369.936] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_37
[   369.937] (II) xfree86: Adding drm device (/dev/dri/card0)
[   369.937] (II) systemd-logind: got fd for /dev/dri/card0 226:0 fd 10 paused 0
[   369.937] (II) xfree86: Adding drm device (/dev/dri/card1)
[   369.938] (II) systemd-logind: got fd for /dev/dri/card1 226:1 fd 11 paused 0
[   369.939] (--) PCI:*(0@0:2:0) 8086:1916:1028:06c2 rev 7, Mem @ 0xd1000000/16777216, 0xb0000000/268435456, I/O @ 0x0000f000/64, BIOS @ 0x????????/131072
[   369.939] (--) PCI: (1@0:0:0) 1002:6907:1028:06c2 rev 135, Mem @ 0xc0000000/268435456, 0xd0000000/2097152, 0xd0200000/262144, I/O @ 0x0000e000/256, BIOS @ 0x????????/131072
[   369.939] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[   369.939] (II) LoadModule: "glx"
[   369.940] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[   369.941] (II) Module glx: vendor="X.Org Foundation"
[   369.941] 	compiled for 1.20.1, module version = 1.0.0
[   369.941] 	ABI class: X.Org Server Extension, version 10.0
[   369.941] (II) LoadModule: "amdgpu"
[   369.941] (II) Loading /usr/lib/xorg/modules/drivers/amdgpu_drv.so
[   369.941] (II) Module amdgpu: vendor="X.Org Foundation"
[   369.941] 	compiled for 1.20.0, module version = 18.0.1
[   369.941] 	Module class: X.Org Video Driver
[   369.941] 	ABI class: X.Org Video Driver, version 24.0
[   369.941] (II) LoadModule: "modesetting"
[   369.941] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[   369.941] (II) Module modesetting: vendor="X.Org Foundation"
[   369.941] 	compiled for 1.20.1, module version = 1.20.1
[   369.941] 	Module class: X.Org Video Driver
[   369.941] 	ABI class: X.Org Video Driver, version 24.0
[   369.941] (II) AMDGPU: Driver for AMD Radeon:
	All GPUs supported by the amdgpu kernel driver
[   369.941] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[   369.942] (II) [KMS] Kernel modesetting enabled.
[   369.942] (II) modeset(G0): using drv /dev/dri/card0
[   369.942] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[   369.942] (II) AMDGPU(0): Creating default Display subsection in Screen section
	"amdgpu" for depth/fbbpp 24/32
[   369.942] (==) AMDGPU(0): Depth 24, (--) framebuffer bpp 32
[   369.942] (II) AMDGPU(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
[   369.942] (==) AMDGPU(0): Default visual is TrueColor
[   369.942] (==) AMDGPU(0): RGB weight 888
[   369.942] (II) AMDGPU(0): Using 8 bits per RGB (8 bit DAC)
[   369.942] (--) AMDGPU(0): Chipset: "AMD Radeon (TM) R5 M315" (ChipID = 0x6907)
[   369.942] (II) Loading sub module "fb"
[   369.942] (II) LoadModule: "fb"
[   369.942] (II) Loading /usr/lib/xorg/modules/libfb.so
[   369.942] (II) Module fb: vendor="X.Org Foundation"
[   369.942] 	compiled for 1.20.1, module version = 1.0.0
[   369.942] 	ABI class: X.Org ANSI C Emulation, version 0.4
[   369.942] (II) Loading sub module "dri2"
[   369.942] (II) LoadModule: "dri2"
[   369.942] (II) Module "dri2" already built-in
[   369.998] (II) Loading sub module "glamoregl"
[   369.998] (II) LoadModule: "glamoregl"
[   369.998] (II) Loading /usr/lib/xorg/modules/libglamoregl.so
[   370.002] (II) Module glamoregl: vendor="X.Org Foundation"
[   370.002] 	compiled for 1.20.1, module version = 1.0.1
[   370.002] 	ABI class: X.Org ANSI C Emulation, version 0.4
[   370.008] (II) AMDGPU(0): glamor X acceleration enabled on AMD Radeon (TM) R5 M315 (ICELAND, DRM 3.26.0, 4.18.5-arch1-1-ARCH, LLVM 6.0.1)
[   370.008] (II) AMDGPU(0): glamor detected, initialising EGL layer.
[   370.008] (==) AMDGPU(0): TearFree property default: auto
[   370.008] (II) AMDGPU(0): KMS Pageflipping: enabled
[   370.008] (WW) AMDGPU(0): No outputs definitely connected, trying again...
[   370.008] (WW) AMDGPU(0): Unable to find connected outputs - setting 1024x768 initial framebuffer
[   370.008] (II) AMDGPU(0): mem size init: gart size :bfd75000 vram size: s:7feb4000 visible:feb4000
[   370.008] (==) AMDGPU(0): DPI set to (96, 96)
[   370.008] (==) AMDGPU(0): Using gamma correction (1.0, 1.0, 1.0)
[   370.008] (II) Loading sub module "ramdac"
[   370.008] (II) LoadModule: "ramdac"
[   370.008] (II) Module "ramdac" already built-in
[   370.008] (EE) AMDGPU(0): No modes.
[   370.009] (II) UnloadModule: "amdgpu"
[   370.009] (II) UnloadSubModule: "glamoregl"
[   370.009] (II) Unloading glamoregl
[   370.009] (II) UnloadSubModule: "fb"
[   370.009] (II) Unloading fb
[   370.009] (==) modeset(G0): Depth 24, (==) framebuffer bpp 32
[   370.009] (==) modeset(G0): RGB weight 888
[   370.009] (==) modeset(G0): Default visual is TrueColor
[   370.009] (II) Loading sub module "glamoregl"
[   370.009] (II) LoadModule: "glamoregl"
[   370.009] (II) Loading /usr/lib/xorg/modules/libglamoregl.so
[   370.009] (II) Module glamoregl: vendor="X.Org Foundation"
[   370.009] 	compiled for 1.20.1, module version = 1.0.1
[   370.009] 	ABI class: X.Org ANSI C Emulation, version 0.4
[   370.015] (II) modeset(G0): glamor X acceleration enabled on Mesa DRI Intel(R) HD Graphics 520 (Skylake GT2) 
[   370.015] (II) modeset(G0): glamor initialized
[   370.016] (II) modeset(G0): Output eDP-1-1 has no monitor section
[   370.016] (II) modeset(G0): Output DP-1-1 has no monitor section
[   370.020] (II) modeset(G0): Output HDMI-1-1 has no monitor section
[   370.021] (II) modeset(G0): EDID for output eDP-1-1
[   370.021] (II) modeset(G0): Manufacturer: BOE  Model: 672  Serial#: 0
[   370.021] (II) modeset(G0): Year: 2015  Week: 1
[   370.021] (II) modeset(G0): EDID Version: 1.4
[   370.021] (II) modeset(G0): Digital Display Input
[   370.021] (II) modeset(G0): 6 bits per channel
[   370.021] (II) modeset(G0): Digital interface is DisplayPort
[   370.021] (II) modeset(G0): Max Image Size [cm]: horiz.: 34  vert.: 19
[   370.021] (II) modeset(G0): Gamma: 2.20
[   370.021] (II) modeset(G0): No DPMS capabilities specified
[   370.021] (II) modeset(G0): Supported color encodings: RGB 4:4:4 
[   370.021] (II) modeset(G0): First detailed timing is preferred mode
[   370.021] (II) modeset(G0): Preferred mode is native pixel format and refresh rate
[   370.021] (II) modeset(G0): redX: 0.590 redY: 0.350   greenX: 0.329 greenY: 0.555
[   370.021] (II) modeset(G0): blueX: 0.152 blueY: 0.118   whiteX: 0.312 whiteY: 0.328
[   370.021] (II) modeset(G0): Manufacturer's mask: 0
[   370.021] (II) modeset(G0): Supported detailed timing:
[   370.021] (II) modeset(G0): clock: 72.3 MHz   Image Size:  344 x 194 mm
[   370.021] (II) modeset(G0): h_active: 1366  h_sync: 1414  h_sync_end 1446 h_blank_end 1526 h_border: 0
[   370.021] (II) modeset(G0): v_active: 768  v_sync: 771  v_sync_end 777 v_blanking: 790 v_border: 0
[   370.021] (II) modeset(G0):  BOE CQ
[   370.021] (II) modeset(G0):  NT156WHM-N32
[   370.021] (II) modeset(G0): EDID (in hex):
[   370.021] (II) modeset(G0): 	00ffffffffffff0009e5720600000000
[   370.021] (II) modeset(G0): 	01190104952213780224109759548e27
[   370.021] (II) modeset(G0): 	1e505400000001010101010101010101
[   370.021] (II) modeset(G0): 	0101010101013e1c56a0500016303020
[   370.021] (II) modeset(G0): 	360058c21000001a0000000000000000
[   370.021] (II) modeset(G0): 	00000000000000000000000000fe0042
[   370.021] (II) modeset(G0): 	4f452043510a202020202020000000fe
[   370.021] (II) modeset(G0): 	004e5431353657484d2d4e33320a002a
[   370.021] (II) modeset(G0): Printing probed modes for output eDP-1-1
[   370.021] (II) modeset(G0): Modeline "1366x768"x60.0   72.30  1366 1414 1446 1526  768 771 777 790 +hsync -vsync (47.4 kHz eP)
[   370.021] (II) modeset(G0): Modeline "1280x720"x120.0  156.12  1280 1376 1512 1744  720 721 724 746 doublescan -hsync +vsync (89.5 kHz d)
[   370.021] (II) modeset(G0): Modeline "1280x720"x120.0  120.75  1280 1304 1320 1360  720 721 724 740 doublescan +hsync -vsync (88.8 kHz d)
[   370.021] (II) modeset(G0): Modeline "1280x720"x59.9   74.50  1280 1344 1472 1664  720 723 728 748 -hsync +vsync (44.8 kHz d)
[   370.021] (II) modeset(G0): Modeline "1280x720"x59.7   63.75  1280 1328 1360 1440  720 723 728 741 +hsync -vsync (44.3 kHz d)
[   370.021] (II) modeset(G0): Modeline "1024x768"x120.1  133.47  1024 1100 1212 1400  768 768 770 794 doublescan -hsync +vsync (95.3 kHz d)
[   370.021] (II) modeset(G0): Modeline "1024x768"x60.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz d)
[   370.021] (II) modeset(G0): Modeline "960x720"x120.0  117.00  960 1024 1128 1300  720 720 722 750 doublescan -hsync +vsync (90.0 kHz d)
[   370.021] (II) modeset(G0): Modeline "928x696"x120.1  109.15  928 976 1088 1264  696 696 698 719 doublescan -hsync +vsync (86.4 kHz d)
[   370.021] (II) modeset(G0): Modeline "896x672"x120.0  102.40  896 960 1060 1224  672 672 674 697 doublescan -hsync +vsync (83.7 kHz d)
[   370.021] (II) modeset(G0): Modeline "1024x576"x119.9   98.50  1024 1092 1200 1376  576 577 580 597 doublescan -hsync +vsync (71.6 kHz d)
[   370.021] (II) modeset(G0): Modeline "1024x576"x119.9   78.38  1024 1048 1064 1104  576 577 580 592 doublescan +hsync -vsync (71.0 kHz d)
[   370.021] (II) modeset(G0): Modeline "1024x576"x59.9   46.50  1024 1064 1160 1296  576 579 584 599 -hsync +vsync (35.9 kHz d)
[   370.021] (II) modeset(G0): Modeline "1024x576"x59.8   42.00  1024 1072 1104 1184  576 579 584 593 +hsync -vsync (35.5 kHz d)
[   370.021] (II) modeset(G0): Modeline "960x600"x119.9   96.62  960 1028 1128 1296  600 601 604 622 doublescan -hsync +vsync (74.6 kHz d)
[   370.021] (II) modeset(G0): Modeline "960x600"x120.0   77.00  960 984 1000 1040  600 601 604 617 doublescan +hsync -vsync (74.0 kHz d)
[   370.021] (II) modeset(G0): Modeline "960x540"x119.9   86.50  960 1024 1124 1288  540 541 544 560 doublescan -hsync +vsync (67.2 kHz d)
[   370.021] (II) modeset(G0): Modeline "960x540"x120.0   69.25  960 984 1000 1040  540 541 544 555 doublescan +hsync -vsync (66.6 kHz d)
[   370.021] (II) modeset(G0): Modeline "960x540"x59.6   40.75  960 992 1088 1216  540 543 548 562 -hsync +vsync (33.5 kHz d)
[   370.021] (II) modeset(G0): Modeline "960x540"x59.8   37.25  960 1008 1040 1120  540 543 548 556 +hsync -vsync (33.3 kHz d)
[   370.021] (II) modeset(G0): Modeline "800x600"x120.0   81.00  800 832 928 1080  600 600 602 625 doublescan +hsync +vsync (75.0 kHz d)
[   370.021] (II) modeset(G0): Modeline "800x600"x60.3   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz d)
[   370.021] (II) modeset(G0): Modeline "800x600"x56.2   36.00  800 824 896 1024  600 601 603 625 +hsync +vsync (35.2 kHz d)
[   370.021] (II) modeset(G0): Modeline "840x525"x120.0   73.12  840 892 980 1120  525 526 529 544 doublescan -hsync +vsync (65.3 kHz d)
[   370.021] (II) modeset(G0): Modeline "840x525"x119.8   59.50  840 864 880 920  525 526 529 540 doublescan +hsync -vsync (64.7 kHz d)
[   370.021] (II) modeset(G0): Modeline "864x486"x59.9   32.50  864 888 968 1072  486 489 494 506 -hsync +vsync (30.3 kHz d)
[   370.021] (II) modeset(G0): Modeline "864x486"x59.6   30.50  864 912 944 1024  486 489 494 500 +hsync -vsync (29.8 kHz d)
[   370.021] (II) modeset(G0): Modeline "700x525"x120.0   61.00  700 744 820 940  525 526 532 541 doublescan +hsync +vsync (64.9 kHz d)
[   370.021] (II) modeset(G0): Modeline "800x450"x119.9   59.12  800 848 928 1056  450 451 454 467 doublescan -hsync +vsync (56.0 kHz d)
[   370.021] (II) modeset(G0): Modeline "800x450"x119.6   48.75  800 824 840 880  450 451 454 463 doublescan +hsync -vsync (55.4 kHz d)
[   370.021] (II) modeset(G0): Modeline "640x512"x120.0   54.00  640 664 720 844  512 512 514 533 doublescan +hsync +vsync (64.0 kHz d)
[   370.021] (II) modeset(G0): Modeline "700x450"x119.9   51.75  700 740 812 924  450 451 456 467 doublescan -hsync +vsync (56.0 kHz d)
[   370.021] (II) modeset(G0): Modeline "700x450"x119.8   43.25  700 724 740 780  450 451 456 463 doublescan +hsync -vsync (55.4 kHz d)
[   370.021] (II) modeset(G0): Modeline "640x480"x120.0   54.00  640 688 744 900  480 480 482 500 doublescan +hsync +vsync (60.0 kHz d)
[   370.021] (II) modeset(G0): Modeline "640x480"x59.9   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz d)
[   370.021] (II) modeset(G0): Modeline "720x405"x59.5   22.50  720 744 808 896  405 408 413 422 -hsync +vsync (25.1 kHz d)
[   370.021] (II) modeset(G0): Modeline "720x405"x59.0   21.75  720 768 800 880  405 408 413 419 +hsync -vsync (24.7 kHz d)
[   370.021] (II) modeset(G0): Modeline "684x384"x119.8   42.62  684 720 788 892  384 385 390 399 doublescan -hsync +vsync (47.8 kHz d)
[   370.021] (II) modeset(G0): Modeline "684x384"x119.7   36.12  684 708 724 764  384 385 390 395 doublescan +hsync -vsync (47.3 kHz d)
[   370.021] (II) modeset(G0): Modeline "640x400"x119.8   41.75  640 676 740 840  400 401 404 415 doublescan -hsync +vsync (49.7 kHz d)
[   370.021] (II) modeset(G0): Modeline "640x400"x120.0   35.50  640 664 680 720  400 401 404 411 doublescan +hsync -vsync (49.3 kHz d)
[   370.021] (II) modeset(G0): Modeline "640x360"x119.7   37.25  640 672 736 832  360 361 364 374 doublescan -hsync +vsync (44.8 kHz d)
[   370.021] (II) modeset(G0): Modeline "640x360"x119.7   31.88  640 664 680 720  360 361 364 370 doublescan +hsync -vsync (44.3 kHz d)
[   370.021] (II) modeset(G0): Modeline "640x360"x59.8   18.00  640 664 720 800  360 363 368 376 -hsync +vsync (22.5 kHz d)
[   370.021] (II) modeset(G0): Modeline "640x360"x59.3   17.75  640 688 720 800  360 363 368 374 +hsync -vsync (22.2 kHz d)
[   370.021] (II) modeset(G0): Modeline "512x384"x120.0   32.50  512 524 592 672  384 385 388 403 doublescan -hsync -vsync (48.4 kHz d)
[   370.021] (II) modeset(G0): Modeline "512x288"x120.0   23.25  512 532 580 648  288 289 292 299 doublescan -hsync +vsync (35.9 kHz d)
[   370.021] (II) modeset(G0): Modeline "512x288"x119.8   21.00  512 536 552 592  288 289 292 296 doublescan +hsync -vsync (35.5 kHz d)
[   370.021] (II) modeset(G0): Modeline "480x270"x119.3   20.38  480 496 544 608  270 271 274 281 doublescan -hsync +vsync (33.5 kHz d)
[   370.021] (II) modeset(G0): Modeline "480x270"x119.6   18.62  480 504 520 560  270 271 274 278 doublescan +hsync -vsync (33.3 kHz d)
[   370.021] (II) modeset(G0): Modeline "400x300"x120.6   20.00  400 420 484 528  300 300 302 314 doublescan +hsync +vsync (37.9 kHz d)
[   370.021] (II) modeset(G0): Modeline "400x300"x112.7   18.00  400 412 448 512  300 300 301 312 doublescan +hsync +vsync (35.2 kHz d)
[   370.021] (II) modeset(G0): Modeline "432x243"x119.8   16.25  432 444 484 536  243 244 247 253 doublescan -hsync +vsync (30.3 kHz d)
[   370.021] (II) modeset(G0): Modeline "432x243"x119.1   15.25  432 456 472 512  243 244 247 250 doublescan +hsync -vsync (29.8 kHz d)
[   370.021] (II) modeset(G0): Modeline "320x240"x120.1   12.59  320 328 376 400  240 245 246 262 doublescan -hsync -vsync (31.5 kHz d)
[   370.021] (II) modeset(G0): Modeline "360x202"x119.0   11.25  360 372 404 448  202 204 206 211 doublescan -hsync +vsync (25.1 kHz d)
[   370.021] (II) modeset(G0): Modeline "360x202"x118.3   10.88  360 384 400 440  202 204 206 209 doublescan +hsync -vsync (24.7 kHz d)
[   370.021] (II) modeset(G0): Modeline "320x180"x119.7    9.00  320 332 360 400  180 181 184 188 doublescan -hsync +vsync (22.5 kHz d)
[   370.021] (II) modeset(G0): Modeline "320x180"x118.6    8.88  320 344 360 400  180 181 184 187 doublescan +hsync -vsync (22.2 kHz d)
[   370.021] (II) modeset(G0): EDID for output DP-1-1
[   370.025] (II) modeset(G0): EDID for output HDMI-1-1
[   370.025] (==) modeset(G0): Using gamma correction (1.0, 1.0, 1.0)
[   370.025] (==) modeset(G0): DPI set to (96, 96)
[   370.025] (II) Loading sub module "fb"
[   370.025] (II) LoadModule: "fb"
[   370.025] (II) Loading /usr/lib/xorg/modules/libfb.so
[   370.025] (II) Module fb: vendor="X.Org Foundation"
[   370.025] 	compiled for 1.20.1, module version = 1.0.0
[   370.025] 	ABI class: X.Org ANSI C Emulation, version 0.4
[   370.025] (EE) Screen(s) found, but none have a usable configuration.
[   370.025] (EE) 
Fatal server error:
[   370.025] (EE) no screens found(EE) 
[   370.025] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[   370.025] (EE) Please also check the log file at "/home/anhthi/.local/share/xorg/Xorg.0.log" for additional information.
[   370.025] (EE) 
[   370.055] (EE) Server terminated with error (1). Closing log file.

Offline

#9 2018-09-14 14:21:57

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 5,564

Re: Get stuck on installing AMD Radeon Driver

Oh, wait, I think I'm an idiot and totally misread that. Remove that xorg.conf then simply add

xrandr --setprovideroutputsource modesetting amdgpu #Verify these names with  xrandr --listproviders, also if that didn't  work try them the other way around
xrandr --auto

to your startup files.

Last edited by V1del (2018-09-14 14:26:06)

Offline

Board footer

Powered by FluxBB