You are not logged in.

#1 2018-09-14 02:34:05

buo
Member
Registered: 2010-04-30
Posts: 9

[SOLVED] X not starting under Virtualbox after kernel/modules upgrade

Edit: it was a glitch on my side; X11 on virtualbox seems to work fine with kernel 4.18.6 and modules 5.2.18-8.

I've been using Arch on a virtualbox VM (current version 5.2.18, windows host) for a few years now. Today, after an upgrade and reboot, I can't start X. Pacman's log shows me that I last night I upgraded linux (plain kernel) from 4.18.5 to 4.18.6, and virtualbox-guest-modules-arch from 5.2.18-7 to 5.2.18-8.

Now, `startx` fails, and X's log shows, among other things:

    (II) UnloadModule: "modesetting"
    (EE) Device(s) detected, but none match those in the config file.
    (EE) Fatal server error: no screens found

Also weird is that I have no virtualbox modules loaded at all: `lsmod | grep vb` returns nothing. When things are working properly, this shows a number of modules.

I think that the problem is due to the upgrade. I downgraded both linux and the modules package, and I can start X again as usual. Is anybody else experiencing this problem? Should I file a bug report?

Last edited by buo (2018-09-14 14:40:10)

Offline

#2 2018-09-14 04:48:40

ooo
Member
Registered: 2013-04-10
Posts: 1,607

Re: [SOLVED] X not starting under Virtualbox after kernel/modules upgrade

Are 'uname -r' and 'pacman -Q linux' reporting the same kernel version?

Offline

#3 2018-09-14 09:05:30

olive
Member
From: Belgium
Registered: 2008-06-22
Posts: 1,425

Re: [SOLVED] X not starting under Virtualbox after kernel/modules upgrade

Recent Virtualbox with recent Xorg uses the modesetting driver (instead of the vbox one). So be sure not to have an outdated Xorg config file. You should also disable glamor (see https://forums.virtualbox.org/viewtopic … 9#p427946). But strange is that the modules don't load. Ensure (as ooo said) that the version of the kernel and virtualbox-guest-modules-arch) match. Could you try to load the modules by hand:

modprobe vboxvideo
modprobe vboxguest
modprobe vboxsf

and see what happens? Possibly examine the content of dmesg after that.

Offline

#4 2018-09-14 14:38:35

buo
Member
Registered: 2010-04-30
Posts: 9

Re: [SOLVED] X not starting under Virtualbox after kernel/modules upgrade

Thanks a lot for your help!

So I went back to the current linux and virtualbox-guest-modules-arch, and in the process I updated to the latest mesa, and I added an X11 config file to set modesetting as described in the virtualbox forum post linked above.

I then rebooted, and everything worked correctly. The vbox modules were loaded on startup, so I don't think mesa or the X11 config file influenced things at all. I can only imagine something went wrong in the previous update, which was fixed by downgrading and then upgrading. I spent a few hours trying to fix this yesterday, I wish I had thought of doing this earlier!

Offline

Board footer

Powered by FluxBB