You are not logged in.

#1 2018-09-15 01:50:51

emacsomancer
Member
Registered: 2014-09-20
Posts: 198

bibtex can't find any files / texlive bibliography not working

On my several years old Arch install, suddenly when I'm using texlive (`latex`, `xelatex`, etc) it is unable to find .bib files (which live at ~/texmf/bibtex/bib/). Even if I copy them into the local directory, it still can't find them.

This is not a problem I've ever had before, and it only seems to be affecting my Arch machine (I have sync'ed files on other non-Arch machines, and bibtex is behaving as expected on them).

I have a vague recollection of some texlive things updating in Arch recently. Has anyone else experienced this? Suggestions on how to proceed?


xelatex reports `Latexmk: Failed to find one or more bibliography files:  'bibliography_main.bib'`. bibtex reports `I couldn't open database file bibliography_main.bib`. Again, whether the relevant bib is at ~/texmf/bibtex/bib/ or even if I copy it into the local directory.

Last edited by emacsomancer (2018-09-15 01:51:06)

Offline

#2 2018-09-15 10:51:11

Stefan Husmann
Member
From: Germany
Registered: 2007-08-07
Posts: 1,066

Re: bibtex can't find any files / texlive bibliography not working

Check your texmf.cnf file. It should have something like

% pBibTeX bibliographies and style files.
BIBINPUTS.pbibtex       = .;$TEXMF/{pbibtex,bibtex}/bib//
BSTINPUTS.pbibtex       = .;$TEXMF/{pbibtex,bibtex}/bst//

Also check if you have more than one such file.

Offline

#3 2018-09-15 16:23:08

emacsomancer
Member
Registered: 2014-09-20
Posts: 198

Re: bibtex can't find any files / texlive bibliography not working

kpsewhich reports:

 $ kpsewhich texmf.cnf
/usr/share/texmf-dist/web2c/texmf.cnf

This file does indeed contain:

% pBibTeX bibliographies and style files.
BIBINPUTS.pbibtex       = .;$TEXMF/{pbibtex,bibtex}/bib//
BSTINPUTS.pbibtex       = .;$TEXMF/{pbibtex,bibtex}/bst//

along with a lot of other settings.

However there appear to be other texmf.cnf files:

$ locate texmf.cnf                          
/etc/texmf/web2c/texmf.cnf
/etc/texmf/web2c/texmf.cnf.pacnew
/home/emacsomancer/.MAIN_SYSTEM.back/etc/texmf/web2c/texmf.cnf
/home/emacsomancer/.MAIN_SYSTEM.back/etc/texmf/web2c/texmf.cnf.pacnew
/home/emacsomancer/.texlive/texmf-config/texmf.cnf
/usr/share/texmf-dist/web2c/texmf.cnf
/var/abs/extra/texlive-core/texmf.cnf

The file at ~/.texlive/texmf-config/texmf.cnf contains *only*:

shell_escape_commands = \
bibtex,bibtex8,\
kpsewhich,\
makeindex,\
mpost,\
repstopdf,\
./vc,\
vc,\

(the vc things there are connected to a version-control thing I set up some time ago)

The other texmf.cnf files seem to have the same contents as /usr/share/texmf-dist/web2c/texmf.cnf.

Last edited by emacsomancer (2018-09-15 16:23:32)

Offline

#4 2018-09-15 17:05:35

Stefan Husmann
Member
From: Germany
Registered: 2007-08-07
Posts: 1,066

Re: bibtex can't find any files / texlive bibliography not working

You have *.pacnew files. Merge them into there counterparts without that extension. And I'd say the ones in your directories under /home can be renamed or even deleted.

Offline

#5 2018-09-15 17:52:34

emacsomancer
Member
Registered: 2014-09-20
Posts: 198

Re: bibtex can't find any files / texlive bibliography not working

Stefan Husmann wrote:

You have *.pacnew files. Merge them into there counterparts without that extension. And I'd say the ones in your directories under /home can be renamed or even deleted.

Do I need to somehow 'refresh' texlive after that?  I've tried recompiling .tex files (removing old .aux, .bbl etc. first) after merging the .pacnew files and removing the texmf.cnf file within my ~, but I get the same result as before.

Offline

#6 2018-09-15 18:05:33

Stefan Husmann
Member
From: Germany
Registered: 2007-08-07
Posts: 1,066

Re: bibtex can't find any files / texlive bibliography not working

Running "texhash" as root should suffice.

Offline

#7 2018-09-15 18:42:15

emacsomancer
Member
Registered: 2014-09-20
Posts: 198

Re: bibtex can't find any files / texlive bibliography not working

Stefan Husmann wrote:

Running "texhash" as root should suffice.

Unfortunately, it still is behaving in the same fashion, even after running texhash as root.

It is very strange, because I've never had this sort of issue before, in the many years I've used Arch and texlive on this machine.

Last edited by emacsomancer (2018-09-15 18:43:30)

Offline

Board footer

Powered by FluxBB