You are not logged in.

#1 2018-09-16 19:06:36

Registered: 2012-02-27
Posts: 124

Baldurs Gate 2 Enhanced edition with mods not working anymore


I have a bit of a strange problem and I am not sure where to post this or where to start.

So here's the story:

Step 1: So, I am playing this game called Baldur's Gate 2 Enhanced Edition with several mods. The modding tools for this game require the game to be installed on a case-insensitive filesystem.
I found a guide that explained how to setup ciopfs for the game. It was working well for several months.

I am starting the game like this:

# /path/to/game/.data --> the game files on a ext4 filesystem
cd /path/to/game
ciopfs .data/ games/
cd games/bg2ee/game

Step 2: I am not using my Arch machine so often anymore, so I am only updating once every 1-2 months.

Step 3: I updated the machine in the beginning of august with roughly 460 packages upgraded, among which linux and fuse and loads of others.
The full list of packages that were upgraded can be found here:

Step 4: The game in the ciopfs environment does not work correctly anymore. It starts, but behaves as it was not modded and crashes when trying to load a savegame.
I don't think it is a problem with the game itself, as I still have an unmodded version (in a different folder on an ext4 filesystem) that works perfectly fine.

Step 5: I was busy with vacation and other real life stuff, so I forgot about it for a while. Today, I updated my system again, and the problem is still there.

So that's the current situation.

The ciopfs command is still running without any error message, and does seem to work, however the game seems to have trouble reading some of the modded files.

What I tried:
- Copy the modded game (from /path/to/game/.data) to an external harddrive, that's NTFS formatted and try to launch the game from there --> game crashes on startup (INFO: LUA ERROR: attempt to index a nil value)

- Connect that external hard drive to a windows 7 machine, copy the windows executable into that folder and run it--> game runs perfectly fine

- Create a vfat filesystem in a loopback file system image and copy the files from /path/to/game/.data onto that filesystem --> game runs perfectly fine

Somehow, I have the feeling that the problem is related to ciopfs.
Of the dependencies of ciopfs (attr  glib2  fuse), only fuse was updated. (By now, also glib2 was updated, but the problem is still the same).
I downgraded fuse to the previous version, but the problem persists.

How can I try to figure out, what causes this problem?


Board footer

Powered by FluxBB