You are not logged in.

#1 2018-09-12 09:42:20

esrevinu
Member
Registered: 2013-12-12
Posts: 17

On gnome 3.30, power button acts as suspend-then-hibernate

Power-button-action is set to 'suspend', but when power button is pressed, the system goes into suspend mode and later turns off if not used for a period of time(default: 3 hours).
In other words, power button on Gnome 3.30 calls systemd-suspend-then-hibernate.service instead of systemd-suspend.service.
On KDE, this is not happening.

 9월 12 18:12:02 lettuce org.gnome.Shell.desktop[7161]: Window manager warning: Overwriting existing binding of keysym ff09 with keysym ff09 (keycode 17).
 9월 12 18:12:07 lettuce systemd-logind[1028]: Delay lock is active (UID 1000/esrevinu, PID 7216/mission-control) but inhibitor timeout is reached.
 9월 12 18:12:07 lettuce systemd[1]: Starting TLP suspend/resume...
 9월 12 18:12:07 lettuce systemd[1]: Started TLP suspend/resume.
 9월 12 18:12:07 lettuce audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=tlp-sleep comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
 9월 12 18:12:07 lettuce kernel: audit: type=1130 audit(1536743527.712:160): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=tlp-sleep comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
 9월 12 18:12:07 lettuce systemd[1]: Reached target Sleep.
 9월 12 18:12:07 lettuce systemd[1]: Starting Suspend; Hibernate if not used for a period of time...
 9월 12 18:12:07 lettuce systemd-sleep[10346]: Suspending system...
 9월 12 18:12:07 lettuce kernel: PM: suspend entry (deep)
 9월 12 18:12:25 lettuce kernel: PM: Syncing filesystems ... done.
 9월 12 18:12:25 lettuce kernel: Freezing user space processes ... (elapsed 0.003 seconds) done.
 9월 12 18:12:25 lettuce kernel: OOM killer disabled.
 9월 12 18:12:25 lettuce kernel: Freezing remaining freezable tasks ... (elapsed 0.001 seconds) done.
 9월 12 18:12:25 lettuce kernel: Suspending console(s) (use no_console_suspend to debug)

Offline

#2 Today 11:05:08

jwang
Member
Registered: 2012-11-13
Posts: 1

Re: On gnome 3.30, power button acts as suspend-then-hibernate

Same behavior here. Searching around, I found this change titled "power: Add Suspend then Hibernate":
https://gitlab.gnome.org/GNOME/gnome-se … e8e6af61eb

It looks like the behavior is unconditional, i.e. it'll always hibernate if possible.

Also found this bug report: "cannot be configured to not hibernate if hardware supports it"
https://gitlab.gnome.org/GNOME/gnome-se … /issues/78

And this thread complaining about Fedora:
https://lwn.net/Articles/764996/

Simplest workaround is probably setting HibernateDelaySec as mentioned in the gitlab issue.

(This thread was the top hit for my Google keywords, so hopefully this link dump helps someone.)

Offline

Board footer

Powered by FluxBB