You are not logged in.

#1 2004-03-11 13:56:45

zeppelin
Member
From: Athens, Greece
Registered: 2004-03-05
Posts: 807
Website

kernel26 package now doesn't boot [FIXED!]

I grabbed the latest kernel pkg. didn't do lilo -v
and now it doesn't boot at all! [stop at the beggining of ..........]

well shouldnt at least boot the last one? [or automatically do lilo -v]

plz help me now

thanks

Offline

#2 2004-03-11 14:15:50

Egil.B
Member
From: Universitas Osloensis
Registered: 2004-02-14
Posts: 116

Re: kernel26 package now doesn't boot [FIXED!]

boot the arch cd.
mount your installation
run lilo -C with the mounted lilo.conf

Offline

#3 2004-03-11 15:32:26

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,753

Re: kernel26 package now doesn't boot [FIXED!]

Boot CD then follow on screen instructions.......


Mr Green

Offline

#4 2004-03-11 18:54:38

zeppelin
Member
From: Athens, Greece
Registered: 2004-03-05
Posts: 807
Website

Re: kernel26 package now doesn't boot [FIXED!]

did that already.
lilo -c path/to/mounted/lilo.conf
but it doesn't work [it gives me some errors regarding the /dev/discs or sth] I don't remember exactly

oh too bad sad

why that PKGBUILD didn't do lilo -v [or at least make sure that the USER will have no doubts about it] sad
oh boy..

at least plz plz to the pkg-guy add an ECHO "DO A LILO -v if you have LILO"  at the end of PKGBUILD

gonna try working on my problem with arch cd sad

Offline

#5 2004-03-11 18:57:10

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: kernel26 package now doesn't boot [FIXED!]

having a lilo run in pkgbuild would do nothing. having an echo line has been mentione before. but everyone who uses lilo *should* know to run lilo after installing a kernel. (since again there is no way to make a package smart enough to run lilo for you)


AKA uknowme

I am not your friend

Offline

#6 2004-03-11 19:04:50

zeppelin
Member
From: Athens, Greece
Registered: 2004-03-05
Posts: 807
Website

Re: kernel26 package now doesn't boot [FIXED!]

well hell I of course know about lilo -v
but what the heck was it on me and I didn't do it [just for testing] I never imagined that the OLD kernel would be broken too!?

anyways an ECHO just for people who might forgotten it or didn't know about it is VERY IMPORTANT.

I had this idea: "when you do 'lilo' you update the MBR" if you don't do it then you still have the old MBR. where exactly am I wrong? {just being very curious}

Offline

#7 2004-03-11 21:46:12

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: kernel26 package now doesn't boot [FIXED!]

zeppelin wrote:

I had this idea: "when you do 'lilo' you update the MBR" if you don't do it then you still have the old MBR. where exactly am I wrong? {just being very curious}

sure you still have the old mbr and it may even point to the right image in /boot but once it gets there and does its thing it fails because the new kernel image is there. this one of the more annoying things about lilo (but i still use it atm too for my crux install)

oh and i agree that there should be a .install file to echo the warning but no one has bothered to make this feature request through the bug tracker yet.


AKA uknowme

I am not your friend

Offline

#8 2004-03-11 22:09:43

zeppelin
Member
From: Athens, Greece
Registered: 2004-03-05
Posts: 807
Website

Re: kernel26 package now doesn't boot [FIXED!]

I can NOT  make it WORK!!!

a) eventhough rescue cd has 2.6.3 doesn't have ntfs/vfat as fs for mount<!!> [as if I can save my linux box only via linux and not WINDOWS]
b) I have again some problems I cannot via setup install a new lilo cause it says [as it used too in the past, cannot chroot to /mnt/etc/lilo.conf and it cannot write there, the lilo.conf in the configure menu is EMPTY] I have the old one [the working one] but I can copy it there.
c) whenever I try (with or without chroot) lilo -C /path/toWORKING/lilo.conf

it refuses me saying that /proc/filesystems don't match or sth like and   {maybe} doesn't like the fact that /dev/hda or /dev/discs/disc0/disc is WHOLE NTFS <?> {part1 is FOR SURE}

SO I WOULD LIKE SOME HELP.
HOW CAN I GET THIS LILO -C path/to/lilo.conf WORK??

i did mount -t reiserfs /dev/discs/disc1/part8 /tmp           [part8 has my root arch]
and then tried everything with /tmp/etc/lilo.conf
but couldn't make it sad

btw if I didn't have SlackWare 9.1 I would still fight to MOUNT VFAT and/or NTFS from the Rescue Arch CD. now I HOPE SOME DEV SEE THIS MORE CLEARLY [ntfs vfat SHOULD BE THERE!!!] or else it's not a rescue

anyways, give your best shot helping me out plZZzzzzzzzzzzz

damn that lilo -v [damn me playing with it]
PLZ PLZ PLZ ADD THE ECHO as a WARNGING!!: DO LILO -v

Offline

#9 2004-03-11 22:22:51

Xentac
Forum Fellow
From: Victoria, BC
Registered: 2003-01-17
Posts: 1,797
Website

Re: kernel26 package now doesn't boot [FIXED!]

1) Stick the rescue cd in.
2) At the isolinux prompt type arch root=/dev/discs/path/to/your/root/partition.  For example, my root partition is /dev/discs/disc1/part1 so I would type: arch root=/dev/discs/disc1/part1 .  I'm pretty sure that it will work with devfs naming schemes, if not it would be this: arch root=/dev/hda1
3) Type: lilo -v
4) Reboot the machine

If you want the message in the kernel upgrade, you should submit a bug report.  It's probably not going to happen until then.


I have discovered that all of mans unhappiness derives from only one source, not being able to sit quietly in a room
- Blaise Pascal

Offline

#10 2004-03-12 09:23:27

zeppelin
Member
From: Athens, Greece
Registered: 2004-03-05
Posts: 807
Website

Re: kernel26 package now doesn't boot [FIXED!]

Xentac wrote:

1) Stick the rescue cd in.
2) At the isolinux prompt type arch root=/dev/discs/path/to/your/root/partition.  For example, my root partition is /dev/discs/disc1/part1 so I would type: arch root=/dev/discs/disc1/part1 .

this doesn't work for me. going to try the /dev/hdb7 and we' ll see. [I'm going to write down the error I get]
I'm submit to bugs. the rescue cd doesn't do ntfs and/or vfat. my hda [whole is ntfs] I hope MBR is somehow neutral so lilo can write to it, eventhough the kernel refuses

Offline

#11 2004-03-12 09:45:45

zeppelin
Member
From: Athens, Greece
Registered: 2004-03-05
Posts: 807
Website

Re: kernel26 package now doesn't boot [FIXED!]

it does NOT work either. if anyone was able to do this before, I would be very pleased.

Offline

#12 2004-03-12 10:01:45

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,753

Re: kernel26 package now doesn't boot [FIXED!]

What about


at shell :

mount /dev/discs/disc0/part3 /mnt #change discs/disc0/part3 to your /root partition
chroot /mnt

HTH

Mr Green


Mr Green

Offline

#13 2004-03-12 10:45:23

zeppelin
Member
From: Athens, Greece
Registered: 2004-03-05
Posts: 807
Website

Re: kernel26 package now doesn't boot [FIXED!]

after a lot of testing and luck I was able to boot arch again tongue [update lilo that is]

what did I do: [i did all that because lilo refuses either to write the map file, or protests about /dev/hda or /dev/discs/disc0/disc {depending if it was Slack or Arch}]

I booted with SlackWare 9.1 Rescue/Install CD {which has vfat}
and which plays without devfs [so /dev/hdb8 was my root arch]

I mounted  my arch root

mount -t reiserfs /dev/hdb8 /tmp

I change the /tmp/etc/lilo.conf to:

boot=/dev/hda
vga=792
default=windows
timeout=300
lba32
prompt

image=/tmp/boot/vmlinuz26         # important change
        label=arch
        root=/dev/hdb8
        read-only

other=/dev/hda1
        label=windows

/boot [the slackware's cd's one] links to /mnt/boot so I did

mkdir /mnt/boot

and then tried to play with lilo a bit

. /tmp/sbin/lilo -C /tmp/etc/lilo.conf -m /tmp/boot/map -M /dev/hda mbr -v

with the above command I have a boot.0300
in /mnt/boot directory
so in the end I just did

cp /mnt/boot/boot.0300 /tmp/boot/

which overwrote the BAD AND UGLY AND OLD [and at last] boot.0300 with the new one [that containted info about the new kernel]
I prayed to Buddha a bit, and then reboot. I there chose arch and OMFG! i was able to boot it tongue

a) I love LILO
b) I love Slackware
c) I love Arch [though I sumbitted some bug reports about the Rescue CD]

mostly I love the fact that I lost some hours do make it work, but now it works as before. On the other hand, I always remember myself trying for days to fix the windows, and then give up [or if i could hack it in a way that would work, then it would be giving me Blue Screens [now dark blue in win2k/xp] of DEATH]

so I must say I love the Penguin tongue

yeahhhhhhhhh

thanks to everyone that helped.
I hope the pkger of kernel would soon add the WARNING [sumbitted bug for that too] and if anyone forgets it or wants to play [like me] then I hope for him that he reads this post, and make it work [i could work with Arch's Live CD too, not sure]

that's all baby.
another success story yeahhhhhhhhh!! :$

Offline

Board footer

Powered by FluxBB