You are not logged in.

#1 2018-09-16 10:11:12

Pjoter
Member
Registered: 2010-10-05
Posts: 16

[SOLVED] Akondai/Kmail constant authorisation request

Hello,

since recent updates of KDE, I get constant authorisation requests from Google/Gmail. Before it wasn't an issue.
I have added the akonadi/kmail to the list of trusted apps in the Google account. The secure password is correctly updated in Kmail settings.

Do you happen to receive the same? It's annoying to see all of sudden 2 to 4 requests in one go to authorise akonadi for an access to my google account data.

Thanks for help.

Kr,

Piotr.

Last edited by Pjoter (2018-09-25 16:51:59)

Offline

#2 2018-09-16 11:24:51

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,558

Re: [SOLVED] Akondai/Kmail constant authorisation request

Yes, this happens if you skip the "@gmail.com" part of your user name. To fix it, change the user name of the account to be the full email address

Offline

#3 2018-09-17 17:00:54

Pjoter
Member
Registered: 2010-10-05
Posts: 16

Re: [SOLVED] Akondai/Kmail constant authorisation request

Hi Arojas,

I changed the username though this happens still. Even if I shutdown/restart, first thing I receive after I login to KDE is the akonadi_imap authentication request.

Thanks for the help.

Piotr.

Offline

#4 2018-09-17 17:09:30

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,558

Re: [SOLVED] Akondai/Kmail constant authorisation request

Just to clarify, you need to change your username in the account settings, *not* in the Google authorization dialog

Offline

#5 2018-09-17 18:25:46

Pjoter
Member
Registered: 2010-10-05
Posts: 16

Re: [SOLVED] Akondai/Kmail constant authorisation request

Hello,

I think I am puzzled, this is what I changed:

Screenshot_20180917_201746.png

Thank you.

Piotr.

Offline

#6 2018-09-25 16:53:44

Pjoter
Member
Registered: 2010-10-05
Posts: 16

Re: [SOLVED] Akondai/Kmail constant authorisation request

I found what was causing the constant Akonadi login request- it's the which authentication method you use. Choosing GMAIL will cause the "issue". Choosing other methods (maybe less secure) helps.

Offline

Board footer

Powered by FluxBB