You are not logged in.

#1 2018-10-03 19:59:26

Nakrule
Member
Registered: 2017-11-23
Posts: 14

[SOLVED] Unable to have natural scrolling working

Hello,

I have the following configuration for my touchpad:

nakrule@mordor ~ % cat /etc/X11/xorg.conf.d/40-touchpad.conf
Section "InputClass"
    Identifier "touchpad"
    Driver "libinput"
    MatchIsTouchpad "on"
    Option "Tapping" "on"
    Option "TappingDrag" "on"
    Option "AccelSpeed" "0.8"
    Option "AccelProfile" "adaptive"
    Option "ScrollMethod" "twofinger"
    Option "MiddleEmulation" "on"
    Option "DisableWhileTyping" "on"
    Option "TappingButtonMap" "lrm"
    Option      "VertScrollDelta"          "-111"
    Option      "HorizScrollDelta"         "-111"
EndSection

Section "InputClass"
    Identifier      "touchpad-ignore-duplicates"
    MatchIsTouchpad "on"
    MatchOS         "Linux"
    MatchDevicePath "/dev/input/mouse*"
    Option          "Ignore" "on"
EndSection

Section "InputClass"
    Identifier  "clickpad-buttons"
    MatchDriver "libinput"
    Option      "SoftButtonAreas" "50% 0 82% 0 0 0 0 0"
    Option      "SecondarySoftButtonAreas" "58% 0 0 15% 42% 58% 0 15%"
EndSection

Section "InputClass"
    Identifier   "Disable-clickpad-buttons-on-Apple-touchpads"
    MatchProduct "Apple|bcm5974"
    MatchDriver  "libinput"
    Option       "SoftButtonAreas" "0 0 0 0 0 0 0 0"
EndSection

According to the Arch wiki, I should add the following lines to have natural scrolling:

Section "InputClass"
    ...
    Option      "VertScrollDelta"          "-111"
    Option      "HorizScrollDelta"         "-111"
    ...
EndSection

However, this does not change the behavior of my trackpad. I'm using a Razer Blade 15. Any idea what I'm doing wrong ?

Thank you.

Last edited by Nakrule (2018-10-04 16:26:34)

Offline

#2 2018-10-03 20:22:34

progandy
Member
Registered: 2012-05-17
Posts: 3,134

Re: [SOLVED] Unable to have natural scrolling working

It seems you are mixing up configuration settings for libinput and synaptics. The libinput page offers this

Option "NaturalScrolling" "true": natural (reverse) scrolling

https://wiki.archlinux.org/index.php/Libinput


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Offline

#3 2018-10-04 15:45:06

Nakrule
Member
Registered: 2017-11-23
Posts: 14

Re: [SOLVED] Unable to have natural scrolling working

Thank you, this has resolved my issue.

Offline

Board footer

Powered by FluxBB