You are not logged in.

#1 2018-10-06 18:57:14

Nakrule
Member
Registered: 2017-11-23
Posts: 14

How to play in 4:3 with black bars with a 16:9 screen

Hi, I'm used to play counter strike in 4:3 with black bars when using a 16:9 resolution. When I configure my resolution in game, the game is stretched to fill the screen instead of having black bars on the left and right side. How can I change this behavior ?

My configuration is a laptop with an Intel and NVIDIA GPU, using the latest NVIDIA driver and bumblebee.

Last edited by Nakrule (2018-10-08 16:41:45)

Offline

#2 2018-10-07 00:49:36

smudge
Member
Registered: 2011-03-20
Posts: 150

Re: How to play in 4:3 with black bars with a 16:9 screen

With nvidia you can put something like:

Section "Screen"
        Identifier   "Screen0"
        Device       "Device0"
        Option       "Metamodes" "DFP-1: nvidia-auto-select; 1920x1080 {ViewPortIn=1440x1080, ViewPortOut=1440x1080+240+0};"
EndSection

in the screen section of file like /etc/X11/xorg.conf.d/20-nvidia.conf. Change DFP-1 for your screen.

Don't suppose anyone knows how to do that with amdgpu?

Offline

#3 2018-10-07 10:45:12

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 6,288

Re: How to play in 4:3 with black bars with a 16:9 screen

For open source drivers , it can be done through xrandr.

try xrandr --display LVDS1 --scale 800x600

(replace LVDS1 with the real name of your screen shown by xrandr -q , and 800x600 with the desired mode)

Last edited by Lone_Wolf (2018-10-07 10:45:29)


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#4 2018-10-07 10:57:13

Gusar
Member
Registered: 2009-08-25
Posts: 3,581

Re: How to play in 4:3 with black bars with a 16:9 screen

Scaling mode is the xrandr setting to, well, set.

xrandr --output eDP1 --set "scaling mode" "Full aspect"

Run "xrandr --props" to see what's available to set.

Offline

#5 2018-10-08 16:34:42

Nakrule
Member
Registered: 2017-11-23
Posts: 14

Re: How to play in 4:3 with black bars with a 16:9 screen

@smudge: I don't have that file. Should I create it ?

@Gusar: My screen is already in full aspect mode.

nakrule@mordor /etc/X11 % xrandr --props                      
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192
eDP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 194mm
	EDID: 
		00ffffffffffff0030e4c00500000000
		001b0104a54f0078eae085a3544e9b26
		0e505400000001010101010101010101
		0101010101015e8780a070384d403020
		350058c21000001b683880a070384d40
		3020350058c21000001b000000000000
		00000000000000000000000000000002
		000c30f20f3c962e12309e00000000a8
	scaling mode: Full aspect 
		supported: Full, Center, Full aspect
	Broadcast RGB: Automatic 
		supported: Automatic, Full, Limited 16:235
	link-status: Good 
		supported: Good, Bad
	CONNECTOR_ID: 71 
		supported: 71
	non-desktop: 0 
		range: (0, 1)
   1920x1080    144.00*+  60.01    59.97    59.96    60.00    59.93
...

Offline

#6 2018-10-09 02:03:11

smudge
Member
Registered: 2011-03-20
Posts: 150

Re: How to play in 4:3 with black bars with a 16:9 screen

If you already have a /etc/X11/xorg.conf file you should be able to put the metamode options in there. Otherwise create /etc/X11/xorg.conf.d/20-nvidia.conf, you'll need device and screen sections.

See: https://wiki.archlinux.org/index.php/NV … figuration

And Thanks Lone_Wolf and Gusar for those tips smile

Offline

#7 2018-10-09 19:43:44

Nakrule
Member
Registered: 2017-11-23
Posts: 14

Re: How to play in 4:3 with black bars with a 16:9 screen

I created the file with the content you sent on your first post, but my game is still in 16:9 hmm

Guess I will have to stick with it.

Thank you anyway. smile

Offline

Board footer

Powered by FluxBB