You are not logged in.

#1 2017-12-27 13:48:57

cribari
Member
From: Recife, Brazil
Registered: 2016-01-28
Posts: 47
Website

[SOLVED] Bluetooth does not work

I installed Arch + KDE Plasma on a laptop that has an Intel 8260 wifi+bluetooth card.

Network:   Card-1: Intel Wireless 8260 driver: iwlwifi
           Card-2: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller driver: r8169

Wifi works, but bluetooth does not work. bluez and bluedevil are installed and the bluetooth service has been enabled:

● bluetooth.service - Bluetooth service
   Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: disabled)
   Active: inactive (dead)
     Docs: man:bluetoothd(8)

rfkill list returns

0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no

I am running the stock Arch kernel (4.14.8-1-ARCH). I booted using the zen kernel but it did not help. Prior to installing Arch on this Laptop I ran Manjaro KDE on it and bluetooth worked flawlessly.

Suggestions are welcome. Thank you in advance.

EDIT: SOLVED by two cold boots.

Last edited by cribari (2017-12-27 16:53:01)


Linux, street photography and Baroque music enthusiast.

Offline

#2 2017-12-27 14:44:40

cribari
Member
From: Recife, Brazil
Registered: 2016-01-28
Posts: 47
Website

Re: [SOLVED] Bluetooth does not work

More information... After issuing

sudo modprobe btusb
sudo systemctl restart bluetooth

systemctl status bluetooth returns

● bluetooth.service - Bluetooth service
   Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: disabled)
   Active: active (running) since Wed 2017-12-27 11:34:48 -03; 4min 31s ago
     Docs: man:bluetoothd(8)
 Main PID: 3602 (bluetoothd)
   Status: "Running"
    Tasks: 1 (limit: 4915)
   CGroup: /system.slice/bluetooth.service
           └─3602 /usr/lib/bluetooth/bluetoothd

Dec 27 11:34:48 darwin5 systemd[1]: Starting Bluetooth service...
Dec 27 11:34:48 darwin5 bluetoothd[3602]: Bluetooth daemon 5.47
Dec 27 11:34:48 darwin5 systemd[1]: Started Bluetooth service.
Dec 27 11:34:48 darwin5 bluetoothd[3602]: Starting SDP server
Dec 27 11:34:48 darwin5 bluetoothd[3602]: Bluetooth management interface 1.14 initialized

However, still no bluetooth adapter found.

[bluetooth]# devices
No default controller available
[bluetooth]# 

The output of lspci is

00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Host Bridge/DRAM Registers (rev 08)
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 520 (rev 07)
00:04.0 Signal processing controller: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem (rev 08)
00:14.0 USB controller: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller (rev 21)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-LP Thermal subsystem (rev 21)
00:15.0 Signal processing controller: Intel Corporation Sunrise Point-LP Serial IO I2C Controller #0 (rev 21)
00:16.0 Communication controller: Intel Corporation Sunrise Point-LP CSME HECI #1 (rev 21)
00:17.0 SATA controller: Intel Corporation Sunrise Point-LP SATA Controller [AHCI mode] (rev 21)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #3 (rev f1)
00:1c.3 PCI bridge: Intel Corporation Device 9d13 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-LP LPC Controller (rev 21)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-LP PMC (rev 21)
00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
00:1f.4 SMBus: Intel Corporation Sunrise Point-LP SMBus (rev 21)
01:00.0 Network controller: Intel Corporation Wireless 8260 (rev 3a)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)

The output of bt-device --list is

**
ERROR:lib/bluez/adapter.c:165:adapter_get_dbus_object_path: assertion failed: (ADAPTER_IS(self))
Aborted (core dumped)

EDIT: The output of lsmod | grep blue is

[cribari@darwin5]: ~>$ lsmod | grep blue
bluetooth             626688  11 btrtl,btintel,bnep,btbcm,btusb
ecdh_generic           24576  1 bluetooth
rfkill                 28672  9 bluetooth,cfg80211
crc16                  16384  2 bluetooth,ext4

Last edited by cribari (2017-12-27 15:03:24)


Linux, street photography and Baroque music enthusiast.

Offline

#3 2017-12-27 16:53:56

cribari
Member
From: Recife, Brazil
Registered: 2016-01-28
Posts: 47
Website

Re: [SOLVED] Bluetooth does not work

SOLVED: Solved by two cold boots.


Linux, street photography and Baroque music enthusiast.

Offline

#4 2018-10-11 21:57:36

azmeuk
Member
Registered: 2012-06-30
Posts: 5

Re: [SOLVED] Bluetooth does not work

Hi. I have the very same problem here (from a XPS13 "16), with the very same symptoms, and about the same results from the command you typed. Loading btusb helped with the bluetooth service, but still no bluetooth adapter found.

I can agree sometimes reboot do work, but sometimes a dozen of reboot is not enough to make it work. I do not really know what to do here to solve this without rebooting.

Offline

#5 2018-10-12 07:24:21

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 5,723

Re: [SOLVED] Bluetooth does not work

About the same results do not have to be the same results. And whatever difference there might be might well be important. Either way this thread is [SOLVED] you should open your own with outputs and details from your own system instead.

https://wiki.archlinux.org/index.php/Co … bumping.22

Closing.

Offline

Board footer

Powered by FluxBB