You are not logged in.

#1 2018-10-11 23:20:33

seumenezes
Member
From: Brazil
Registered: 2013-07-15
Posts: 9

[SOLVED] Bluetooth not working in ThinkPad E470

Hello, I did a fresh Arch install a few days ago, and never got the Bluetooth adapter to work. Strangely enough, it seems to be detected without issues and the btusb driver seems to be properly loaded, however it never appears in the list (accessing it via KDE's settings panel), with the message "No adapters found". What gives?

Relevant output of lspci -nnk | grep -iA3 net; dmesg | egrep -i 'iwl|ath':

04:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 10)
    Subsystem: Lenovo RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [17aa:505b]
    Kernel driver in use: r8169
    Kernel modules: r8169
05:00.0 Network controller [0280]: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter [168c:0042] (rev 31)
    Subsystem: Lenovo QCA9377 802.11ac Wireless Network Adapter [17aa:0901]
    Kernel driver in use: ath10k_pci
    Kernel modules: ath10k_pci
[    2.937331] ath10k_pci 0000:05:00.0: enabling device (0000 -> 0002)
[    2.948073] ath10k_pci 0000:05:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0
[    3.269110] ath10k_pci 0000:05:00.0: qca9377 hw1.1 target 0x05020001 chip_id 0x003821ff sub 17aa:0901
[    3.269118] ath10k_pci 0000:05:00.0: kconfig debug 1 debugfs 1 tracing 1 dfs 0 testmode 0
[    3.270952] ath10k_pci 0000:05:00.0: firmware ver WLAN.TF.1.0-00002-QCATFSWPZ-5 api 5 features ignore-otp crc32 c3e0d04f
[    3.337554] ath10k_pci 0000:05:00.0: board_file api 2 bmi_id N/A crc32 8aedfa4a
[    3.969773] ath10k_pci 0000:05:00.0: htt-ver 3.44 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1
[    3.976762] ath: EEPROM regdomain: 0x6c
[    3.976764] ath: EEPROM indicates we should expect a direct regpair map
[    3.976765] ath: Country alpha2 being used: 00
[    3.976766] ath: Regpair used: 0x6c
[    3.984852] ath10k_pci 0000:05:00.0 wlp5s0: renamed from wlan0

Relevant output of lsusb -tv:

/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/6p, 5000M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/12p, 480M
    |__ Port 6: Dev 2, If 0, Class=Wireless, Driver=btusb, 12M
    |__ Port 6: Dev 2, If 1, Class=Wireless, Driver=btusb, 12M
    |__ Port 7: Dev 3, If 0, Class=Video, Driver=uvcvideo, 480M
    |__ Port 7: Dev 3, If 1, Class=Video, Driver=uvcvideo, 480M
    |__ Port 9: Dev 4, If 0, Class=Vendor Specific Class, Driver=, 12M

I appreciate any help; let me know if there is any other relevant info you want me to post here.

Thanks in advance!

EDIT: I tried both r8169 and r8168 modules, and I have acpi_rev_override kernel parameter turned on, to no avail.

Last edited by seumenezes (2018-10-12 14:34:10)


Não me siga. Estou tão perdido quanto você.
Don't follow me. I am as lost as you.

Offline

#2 2018-10-12 06:52:39

cspack
Member
Registered: 2016-09-01
Posts: 7

Re: [SOLVED] Bluetooth not working in ThinkPad E470

Check your BIOS settings, make sure bluetooth is enabled. If so, check dmesg for bluetooth messages/errors.

Offline

#3 2018-10-12 07:12:14

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 5,476

Re: [SOLVED] Bluetooth not working in ThinkPad E470

Did you enable the bluetooth.service ? Also check with rfkill that it isn't being blocked.

Last edited by V1del (2018-10-12 07:12:44)

Offline

#4 2018-10-12 14:10:01

seumenezes
Member
From: Brazil
Registered: 2013-07-15
Posts: 9

Re: [SOLVED] Bluetooth not working in ThinkPad E470

V1del wrote:

Did you enable the bluetooth.service ?

Oh my, that was easy! But hindsight is 20/20. Thanks a lot!

You guys are the best.


Não me siga. Estou tão perdido quanto você.
Don't follow me. I am as lost as you.

Offline

#5 2018-10-12 14:32:46

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 5,476

Re: [SOLVED] Bluetooth not working in ThinkPad E470

Glad to hear, please mark as [SOLVED] by editing the title in your first post: https://wiki.archlinux.org/index.php/Co … ow_to_post

Offline

Board footer

Powered by FluxBB