You are not logged in.

#1 2018-10-12 10:15:22

karcher
Member
Registered: 2018-01-09
Posts: 43

[SOLVED] LibreOffice doesn't start

Hi all,

yesterday night I've installed updated KDE Plasma packages, not sure if there was also a libreoffice-fresh update, but in any case today LibreOffice Applications won't start.
I tried from console with:
$ libreoffice --calc
but doesn't help.

Any ideas?

Last edited by karcher (2018-10-12 21:18:30)

Offline

#2 2018-10-12 11:20:40

philipW
Member
Registered: 2017-03-21
Posts: 118

Re: [SOLVED] LibreOffice doesn't start

What output do you get in the console when you try to run libreoffice?

Offline

#3 2018-10-12 11:42:44

Haller
Member
Registered: 2018-04-08
Posts: 36

Re: [SOLVED] LibreOffice doesn't start

Look at /var/log/pacman.log to see, if libreoffice was updated.

Start libreoffice with a new profile by moving $HOME/.confg/libreoffice to somewhere else. Is this working?

Offline

#4 2018-10-12 11:53:18

karcher
Member
Registered: 2018-01-09
Posts: 43

Re: [SOLVED] LibreOffice doesn't start

@philipW: There is no output.

@Haller:  libreoffice-fresh updated 5 days ago but I was hibernating for some days and I had Calc open, so I'm still not sure if it was because of the KDE Plasma update or LibreOffice update:
[2018-10-07 01:12] [ALPM] upgraded libreoffice-fresh (6.1.1-3 -> 6.1.2-1)
[2018-10-09 12:43] [PACMAN] Running 'pacman --upgrade --asexplicit libreoffice-extension-languagetool-4.3-1-any.pkg.tar.xz'
[2018-10-09 12:44] [ALPM] upgraded libreoffice-extension-languagetool (4.2-1 -> 4.3-1)

I renamed the config to libreoffice.bak and restarted libreoffice. A new config folder was created but LibreOffice still won't start.

Offline

#5 2018-10-12 12:14:17

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 5,476

Re: [SOLVED] LibreOffice doesn't start

Did you reboot already? There's a chance that there's an interaction issue with old KDE libs and libreoffice trying to initialize the KDE filepicker. It's always advisable to reboot or at least logout and back in on KDE updates to ensure that all libraries are in a consistent state.

Offline

#6 2018-10-12 13:00:22

karcher
Member
Registered: 2018-01-09
Posts: 43

Re: [SOLVED] LibreOffice doesn't start

@V1del
Yes. I always do after system updates.

BTW
On an Antergos VM with KDE Plasma, which also got the Plasma update, libreoffice seems to be working normally.

Offline

#7 2018-10-12 13:01:12

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 8,272
Website

Re: [SOLVED] LibreOffice doesn't start

Please post your full pacman.log


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#8 2018-10-12 13:18:37

karcher
Member
Registered: 2018-01-09
Posts: 43

Re: [SOLVED] LibreOffice doesn't start

@WorMzy;
Here is the link:
https://pastebin.com/bWtKAuQ2

I've only added rows since 01.10.2018 since the whole log is 1.5 MB and pastebin didn't let me to upload it.

Offline

#9 2018-10-12 14:26:39

seth
Member
Registered: 2012-09-03
Posts: 8,476

Re: [SOLVED] LibreOffice doesn't start

What if you enforce the gtk theme?
https://wiki.archlinux.org/index.php/LibreOffice#Theme

Offline

#10 2018-10-12 16:38:07

karcher
Member
Registered: 2018-01-09
Posts: 43

Re: [SOLVED] LibreOffice doesn't start

@seth: I tried all 4 of them:

#export SAL_USE_VCLPLUGIN=gen
#export SAL_USE_VCLPLUGIN=gtk3_kde5
export SAL_USE_VCLPLUGIN=gtk
#export SAL_USE_VCLPLUGIN=gtk3

but none of them helped.

Offline

#11 2018-10-12 20:38:56

seth
Member
Registered: 2012-09-03
Posts: 8,476

Re: [SOLVED] LibreOffice doesn't start

Does it leave a coredump?
Is there maybe a stale zombie process?

Offline

#12 2018-10-12 21:14:23

karcher
Member
Registered: 2018-01-09
Posts: 43

Re: [SOLVED] LibreOffice doesn't start

seth wrote:

Is there maybe a stale zombie process?

That was it!

Silly of me but I didn't check this at all because it was right after restart.
I killed all libreoffice processes and then libreoffice was able to start without a problem.

Thanks all!

Offline

Board footer

Powered by FluxBB