You are not logged in.

#1 2018-10-13 04:25:13

Thales
Member
Registered: 2018-10-13
Posts: 2

Installing custom Arch iso on usb (mkarchiso)

Hi, I have a usb key with a partition (/dev/sdc4) that I can chroot in since my OS is ubuntu 16.04. That partition has a bootstrap arch linux exactly similar to what this blog https://vicente-hernando.appspot.com/ar … ting-linux describes.

I also have a 'custom' arch folder that I have created with the packages I want and I copied that in my arch linux partition.

My ultimate goal would be to install my 'custom' arch iso created here on another usb key but I'm unable to get to the end of the mkarchiso bash script.

The error at the very end of the mkarchiso script is:

useradd: group 'audio.floppy' does not exist

I use the /dev/sdc4 arch_chroot partition to create my iso.
Here are the commands I've used to create the arch_chroot folder inside my usb partition:

sudo mount --bind /media/user/Arch/arch_chroot/root.x86_64/ /media/user/Arch/arch_chroot/root.x86_64/
cd /media/user/Arch/arch_chroot/root.x86_64/
sudo cp /etc/resolv.conf etc
sudo mount -t proc /proc proc
sudo mount --rbind /sys sys
sudo mount --rbind /dev dev
sudo chroot . /bin/bash

Here's the log file for the ./build.sh command

[root@user /]# pacman-key --init
[root@user /]# pacman-key --populate archlinux
[root@user /]# pacman -Syyu
[root@user /]# pacman -S base
[root@user /]# cd liveiso/
[root@user liveiso]# ./build.sh -v 2>&1 | tee log.txt

[mkarchiso] INFO: Configuration settings
[mkarchiso] INFO:                   Command:   init
[mkarchiso] INFO:              Architecture:   x86_64
[mkarchiso] INFO:         Working directory:   work/x86_64
[mkarchiso] INFO:    Installation directory:   arch
[mkarchiso] INFO:        Pacman config file:   work/pacman.conf

[mkarchiso] INFO: Installing packages to 'work/x86_64/airootfs/'...
==> Creating install root at work/x86_64/airootfs
==> Installing packages to work/x86_64/airootfs
:: Synchronizing package databases...
downloading core.db...
downloading extra.db...
downloading community.db...
downloading multilib.db...
:: There are 49 members in group base:
:: Repository core
   1) bash  2) bzip2  3) coreutils  4) cryptsetup  5) device-mapper  6) dhcpcd  7) diffutils  8) e2fsprogs  9) file  10) filesystem  11) findutils  12) gawk  13) gcc-libs  14) gettext
  15) glibc  16) grep  17) gzip  18) inetutils  19) iproute2  20) iputils  21) jfsutils  22) less  23) licenses  24) linux  25) logrotate  26) lvm2  27) man-db  28) man-pages  29) mdadm  
30) nano  31) netctl  32) pacman  33) pciutils  34) perl  35) procps-ng  36) psmisc  37) reiserfsprogs  38) s-nail  39) sed  40) shadow  
41) sysfsutils  42) systemd-sysvcompat  43) tar  44) texinfo  45) usbutils  46) util-linux  47) vi  48) which  49) xfsprogs

Enter a selection (default=all): 
resolving dependencies...
:: There are 2 providers available for resolvconf:
:: Repository core
   1) openresolv  2) systemd-resolvconf

Enter a number (default=1): 
looking for conflicting packages...

Packages (134) acl-2.2.53-1  archlinux-keyring-20181003-1  argon2-20171227-3  attr-2.4.48-1  audit-2.8.4-2  ca-certificates-20180821-1  ca-certificates-mozilla-3.39-1  
ca-certificates-utils-20180821-1  cracklib-2.9.6-1  curl-7.61.1-3  db-5.3.28-4  dbus-1.12.10-2  expat-2.2.6-1  gdbm-1.18-1  glib2-2.58.1-1  gmp-6.1.2-1  
gnupg-2.2.10-1  gnutls-3.5.19-2  gpgme-1.12.0-1  groff-1.22.3-7  hwids-20180518-1  iana-etc-20180913-1  iptables-1:1.6.2-3  json-c-0.13.1-2  kbd-2.0.4-1  
keyutils-1.5.11-1  kmod-25-1  krb5-1.16.1-1  libaio-0.3.111-1  libarchive-3.3.3-1  libassuan-2.5.1-1  libcap-2.25-1  libcap-ng-0.7.9-1  libelf-0.174-1  libffi-3.2.1-2  
libgcrypt-1.8.3-1  libgpg-error-1.32-1  libidn2-2.0.5-1  libksba-1.3.5-1  libldap-2.4.46-2  libmnl-1.0.4-1  libnftnl-1.1.1-1  libnghttp2-1.33.0-1  libnl-3.4.0-1  
libpcap-1.9.0-1  libpipeline-1.5.0-1  libpsl-0.20.2-1  libsasl-2.1.26-13  libseccomp-2.3.3-1  libsecret-0.18.6-1  libssh2-1.8.0-2  libsystemd-239.2-1  libtasn1-4.13-1  
libtirpc-1.1.4-1  libunistring-0.9.10-1  libusb-1.0.22-1  libutil-linux-2.32.1-2  linux-api-headers-4.17.11-1  linux-firmware-20180825.fea76a0-1  lz4-1:1.8.3-1  
mkinitcpio-24-2  mkinitcpio-busybox-1.29.3-1  mpfr-4.0.1-1  ncurses-6.1-4  nettle-3.4-1  npth-1.6-1  openresolv-3.9.0-1  openssl-1.1.1-1  p11-kit-0.23.14-1  
pacman-mirrorlist-20180912-1  pam-1.3.1-1  pambase-20171006-1  pcre-8.42-1  pcre2-10.32-1  pinentry-1.1.0-4  popt-1.16-9  readline-7.0.005-1  sqlite-3.25.2-1  
systemd-239.2-1  thin-provisioning-tools-0.7.6-1  tzdata-2018e-2  xz-5.2.4-1  zlib-1:1.2.11-3  zstd-1.3.5-1  bash-4.4.023-1  bzip2-1.0.6-8  coreutils-8.30-1  
cryptsetup-2.0.4-1  device-mapper-2.02.181-1  dhcpcd-7.0.8-1  diffutils-3.6-1  e2fsprogs-1.44.4-1  file-5.34-1  filesystem-2018.8-1  findutils-4.6.0-2  gawk-4.2.1-1 
 gcc-libs-8.2.1+20180831-1  gettext-0.19.8.1-2  glibc-2.28-4  grep-3.1-1  gzip-1.9-1  inetutils-1.9.4-5  iproute2-4.18.0-1  iputils-20180629.f6aac8d-2 
 jfsutils-1.1.15-6  less-530-1  licenses-20171006-1  linux-4.18.12.arch1-1  logrotate-3.14.0-1  lvm2-2.02.181-1  man-db-2.8.4-1  man-pages-4.16-2  mdadm-4.0-1  
nano-3.1-1  netctl-1.18-1  pacman-5.1.1-1  pciutils-3.6.1-1  perl-5.28.0-1  procps-ng-3.3.15-1  psmisc-23.2-1  reiserfsprogs-3.6.27-1  s-nail-14.9.11-1  sed-4.5-1  shadow-4.6-1  sysfsutils-2.1.0-10  syslinux-6.03-11  systemd-sysvcompat-239.2-1  tar-1.30-1  texinfo-6.5-1  usbutils-010-1  util-linux-2.32.1-2  vi-1:070224-3  
which-2.21-2  xfsprogs-4.17.0-1

Total Installed Size:  848.88 MiB

:: Proceed with installation? [Y/n] 
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
:: Processing package changes...
installing linux-api-headers...
installing tzdata...
installing iana-etc...
installing filesystem...
installing glibc...
Optional dependencies for glibc
    gd: for memusagestat
installing gcc-libs...
installing ncurses...
installing readline...
installing bash...
Optional dependencies for bash
    bash-completion: for tab completion
installing bzip2...
installing attr...
installing acl...
installing gmp...
installing libcap...
installing gdbm...
installing db...
installing perl...
installing openssl...
Optional dependencies for openssl
    ca-certificates [pending]
installing coreutils...
installing libgpg-error...
installing libgcrypt...
installing lz4...
installing xz...
installing libsystemd...
installing device-mapper...
installing popt...
installing libutil-linux...
installing json-c...
installing argon2...
installing cryptsetup...
installing expat...
installing dbus...
installing libmnl...
installing libnftnl...
installing libnl...
installing libusb...
installing libpcap...
installing iptables...
installing zlib...
installing cracklib...
installing e2fsprogs...
installing libsasl...
installing libldap...
installing keyutils...
installing krb5...
installing libtirpc...
installing pambase...
installing pam...
installing kbd...
installing kmod...
installing hwids...
installing libunistring...
installing libidn2...
installing libelf...
installing libseccomp...
installing shadow...
installing libcap-ng...
installing util-linux...
Optional dependencies for util-linux
    python: python bindings to libmount
installing pcre2...
installing audit...
installing systemd...
Initializing machine ID from random generator.
Created symlink /etc/systemd/system/getty.target.wants/getty@tty1.service -> /usr/lib/systemd/system/getty@.service.
Created symlink /etc/systemd/system/multi-user.target.wants/remote-fs.target -> /usr/lib/systemd/system/remote-fs.target.
:: Append 'init=/usr/lib/systemd/systemd' to your kernel command line in your
   bootloader to replace sysvinit with systemd, or install systemd-sysvcompat
Optional dependencies for systemd
    libmicrohttpd: remote journald capabilities
    quota-tools: kernel-level quota management
    systemd-sysvcompat: symlink package to provide sysvinit binaries [pending]
    polkit: allow administration as unprivileged user
    curl: machinectl pull-tar and pull-raw [pending]
installing dhcpcd...
Optional dependencies for dhcpcd
    openresolv: resolvconf support [pending]
installing diffutils...
installing file...
installing findutils...
installing mpfr...
installing gawk...
installing pcre...
installing libffi...
installing glib2...
Optional dependencies for glib2
    python: gdbus-codegen, glib-genmarshal, glib-mkenums, gtester-report
    libelf: gresource inspection tool [installed]
installing gettext...
Optional dependencies for gettext
    git: for autopoint infrastructure updates
installing grep...
installing less...
installing gzip...
installing inetutils...
installing iproute2...
Optional dependencies for iproute2
    linux-atm: ATM support
installing iputils...
Optional dependencies for iputils
    xinetd: for tftpd
installing jfsutils...
installing licenses...
installing linux-firmware...
installing mkinitcpio-busybox...
installing zstd...
installing libarchive...
installing mkinitcpio...
Optional dependencies for mkinitcpio
    xz: Use lzma or xz compression for the initramfs image [installed]
    bzip2: Use bzip2 compression for the initramfs image [installed]
    lzop: Use lzo compression for the initramfs image
    lz4: Use lz4 compression for the initramfs image [installed]
    mkinitcpio-nfs-utils: Support for root filesystem on NFS
installing linux...
Optional dependencies for linux
    crda: to set the correct wireless channels of your country
installing logrotate...
installing libaio...
installing thin-provisioning-tools...
installing lvm2...
installing groff...
Optional dependencies for groff
    netpbm: for use together with man -H command interaction in browsers
    psutils: for use together with man -H command interaction in browsers
    libxaw: for gxditview
installing libpipeline...
installing man-db...
Optional dependencies for man-db
    gzip [installed]
installing man-pages...
installing mdadm...
installing nano...
installing openresolv...
installing netctl...
Optional dependencies for netctl
    dialog: for the menu based wifi assistant
    dhclient: for DHCP support (or dhcpcd)
    dhcpcd: for DHCP support (or dhclient) [installed]
    wpa_supplicant: for wireless networking support
    ifplugd: for automatic wired connections through netctl-ifplugd
    wpa_actiond: for automatic wireless connections through netctl-auto
    ppp: for PPP connections
    openvswitch: for Open vSwitch connections
installing libtasn1...
installing p11-kit...
Created symlink /etc/systemd/user/sockets.target.wants/p11-kit-server.socket -> /usr/lib/systemd/user/p11-kit-server.socket.
installing ca-certificates-utils...
installing ca-certificates-mozilla...
installing ca-certificates...
installing libssh2...
installing libpsl...
installing libnghttp2...
installing curl...
installing npth...
installing libksba...
installing libassuan...
installing libsecret...
Optional dependencies for libsecret
    gnome-keyring: key storage service (or use any other service implementing org.freedesktop.secrets)
installing pinentry...
Optional dependencies for pinentry
    gtk2: gtk2 backend
    qt5-base: qt backend
    gcr: gnome3 backend
installing nettle...
installing gnutls...
Optional dependencies for gnutls
    guile: for use with Guile bindings
installing sqlite...
installing gnupg...
Optional dependencies for gnupg
    libldap: gpg2keys_ldap [installed]
    libusb-compat: scdaemon
    pcsclite: scdaemon
installing gpgme...
installing pacman-mirrorlist...
installing archlinux-keyring...
installing pacman...
Optional dependencies for pacman
    perl-locale-gettext: translation support in makepkg-template
installing pciutils...
installing procps-ng...
installing psmisc...
installing reiserfsprogs...
installing s-nail...
Optional dependencies for s-nail
    smtp-forwarder: for sending mail
installing sed...
installing sysfsutils...
installing systemd-sysvcompat...
installing tar...
installing texinfo...
installing usbutils...
Optional dependencies for usbutils
    python: for lsusb.py usage
    coreutils: for lsusb.py usage [installed]
installing vi...
Optional dependencies for vi
    s-nail: used by the preserve command for notification [installed]
installing which...
installing xfsprogs...
installing syslinux...

==> For setting up Syslinux BIOS using the syslinux-install_update script follow
    https://wiki.archlinux.org/index.php/Syslinux#Automatic_Install
Optional dependencies for syslinux
    perl-crypt-passwdmd5: For md5pass
    perl-digest-sha1: For sha1pass
    mtools: For mkdiskimage and syslinux support
    gptfdisk: For GPT support
    util-linux: For isohybrid [installed]
    efibootmgr: For EFI support
    dosfstools: For EFI support
:: Running post-transaction hooks...
( 1/13) Updating linux module dependencies...
( 2/13) Updating linux initcpios...
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
==> Starting build: 4.18.12-arch1-1-ARCH
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
==> ERROR: failed to detect root filesystem
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
==> Starting build: 4.18.12-arch1-1-ARCH
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: aic94xx
==> WARNING: Possibly missing firmware for module: wd719x
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-fallback.img
==> Image generation successful
( 3/13) Warn about old perl modules
( 4/13) Updating journal message catalog...
( 5/13) Reloading system manager configuration...
  Skipped: Current root is not booted.
( 6/13) Updating udev hardware database...
( 7/13) Applying kernel sysctl settings...
  Skipped: Current root is not booted.
( 8/13) Creating system user accounts...
( 9/13) Creating temporary files...
error: command failed to execute correctly
(10/13) Reloading device manager configuration...
  Skipped: Device manager is not running.
(11/13) Arming ConditionNeedsUpdate...
(12/13) Updating the info directory file...
(13/13) Rebuilding certificate stores...
[mkarchiso] INFO: Packages installed successfully!

[mkarchiso] INFO: Configuration settings
[mkarchiso] INFO:                   Command:   install
[mkarchiso] INFO:              Architecture:   x86_64
[mkarchiso] INFO:         Working directory:   work/x86_64
[mkarchiso] INFO:    Installation directory:   arch
[mkarchiso] INFO:        Pacman config file:   work/pacman.conf
[mkarchiso] INFO:                  Packages:   haveged intel-ucode amd-ucode memtest86+ mkinitcpio-nfs-utils nbd zsh efitools

[mkarchiso] INFO: Installing packages to 'work/x86_64/airootfs/'...
==> Creating install root at work/x86_64/airootfs
==> Installing packages to work/x86_64/airootfs
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
resolving dependencies...
looking for conflicting packages...

Packages (8) amd-ucode-20180825.fea76a0-1  efitools-1.8.1-1  haveged-1.9.4-3  intel-ucode-20180807.a-1  memtest86+-5.01-2  mkinitcpio-nfs-utils-0.3-6  nbd-3.18-1  zsh-5.6.2-1

Total Installed Size:  9.72 MiB

:: Proceed with installation? [Y/n] 
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
:: Processing package changes...
installing haveged...
installing intel-ucode...
installing amd-ucode...
installing memtest86+...
installing mkinitcpio-nfs-utils...
installing nbd...
installing zsh...
installing efitools...
:: Running post-transaction hooks...
(1/4) Updating linux initcpios...
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
==> Starting build: 4.18.12-arch1-1-ARCH
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
==> ERROR: failed to detect root filesystem
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
==> Starting build: 4.18.12-arch1-1-ARCH
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: aic94xx
==> WARNING: Possibly missing firmware for module: wd719x
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-fallback.img
==> Image generation successful
(2/4) Reloading system manager configuration...
  Skipped: Current root is not booted.
(3/4) Creating system user accounts...
(4/4) Arming ConditionNeedsUpdate...
[mkarchiso] INFO: Packages installed successfully!

[mkarchiso] INFO: Configuration settings
[mkarchiso] INFO:                   Command:   install
[mkarchiso] INFO:              Architecture:   x86_64
[mkarchiso] INFO:         Working directory:   work/x86_64
[mkarchiso] INFO:    Installation directory:   arch
[mkarchiso] INFO:        Pacman config file:   work/pacman.conf
[mkarchiso] INFO:                  Packages:   xorg-server xorg-xinit xorg-twm xterm plasma-desktop dolphin konsole xdg-user-dirs bash-completion alsa-utils mlocate file-roller ufw lightdm lightdm-gtk-greeter lightdm-gtk-greeter-settings arch-install-scripts b43-fwcutter broadcom-wl btrfs-progs dhclient dialog dmraid dnsmasq dnsutils dosfstools ethtool exfat-utils f2fs-tools fsarchiver gpm gptfdisk grml-zsh-config grub hdparm ipw2100-fw ipw2200-fw irssi lftp lsscsi mtools ndisc6 nfs-utils nilfs-utils nmap ntfs-3g ntp openconnect partclone parted partimage ppp pptpclient refind-efi rp-pppoe rsync sdparm sg3_utils smartmontools sudo tcpdump testdisk usb_modeswitch vim-minimal vpnc wget wpa_actiond wvdial xl2tpd

[mkarchiso] INFO: Installing packages to 'work/x86_64/airootfs/'...
==> Creating install root at work/x86_64/airootfs
==> Installing packages to work/x86_64/airootfs
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
resolving dependencies...
:: There are 2 providers available for libgl:
:: Repository extra
   1) libglvnd  2) nvidia-340xx-utils

Enter a number (default=1): 
:: There are 2 providers available for phonon-qt5-backend:
:: Repository extra
   1) phonon-qt5-gstreamer  2) phonon-qt5-vlc

Enter a number (default=1): 
looking for conflicting packages...
warning: dependency cycle detected:
warning: harfbuzz will be installed before its freetype2 dependency
warning: dependency cycle detected:
warning: mesa will be installed before its libglvnd dependency
warning: dependency cycle detected:
warning: usbmuxd will be installed before its libimobiledevice dependency
warning: dependency cycle detected:
warning: phonon-qt5-gstreamer will be installed before its phonon-qt5 dependency
warning: dependency cycle detected:
warning: x264 will be installed before its ffmpeg dependency

Packages (436) adwaita-icon-theme-3.30.0-1  alsa-lib-1.1.6-1  aom-1.0.0-1  appstream-0.12.2-1  appstream-qt-0.12.2-1  at-spi2-atk-2.30.0-1  at-spi2-core-2.30.0-2  atk-2.30.0-1  attica-5.50.0-1  avahi-0.7+16+g1cc2b8e-2  baloo-5.50.0-2  baloo-widgets-18.08.2-1  bc-1.07.1-1  breeze-5.14.0-1  breeze-icons-5.50.0-1  cairo-1.15.14-1  cantarell-fonts-1:0.111-1  cdparanoia-10.2-7  cifs-utils-6.8-2  colord-1.4.3-2  convertlit-1.8-8  dconf-0.30.0-1  desktop-file-utils-0.23+4+g92af410-1  ding-libs-0.6.1-2  dnssec-anchors-20181003-1  double-conversion-3.1.1-1  ebook-tools-0.2.2-4  editorconfig-core-c-0.12.2-1  efibootmgr-16-1  efivar-35-1  exiv2-0.26-2  ffmpeg-1:4.0.2-6  fftw-3.3.8-1  flac-1.3.2-1  fontconfig-2:2.13.1+12+g5f5ec56-1  frameworkintegration-5.50.0-1  freetype2-2.9.1-1  fribidi-1.0.5-1  fuse-common-3.2.6-1  fuse2-2.9.8-1  gamin-0.1.10-9  gdk-pixbuf2-2.38.0-1  geoip-1.6.12-1  geoip-database-20180403-1  giflib-5.1.4-1  glib-networking-2.58.0-1  glu-9.0.0-5  gobject-introspection-runtime-1.58.0+2+g1f1dd7f4-2  graphene-1.8.2-1  graphite-1:1.3.12-1  gsettings-desktop-schemas-3.28.1-1  gsm-1.0.18-1  gssproxy-0.8.0-1  gst-plugins-base-1.14.4-1  gst-plugins-base-libs-1.14.4-1  gstreamer-1.14.4-1  gtk-update-icon-cache-3.24.1+8+g220f77d8c1-1  gtk3-3.24.1+8+g220f77d8c1-1  harfbuzz-1.9.0-1  hicolor-icon-theme-0.17-1  hyphen-2.8.8-2  icu-62.1-1  idnkit-1.0-4  ilmbase-2.3.0-1  iso-codes-3.79-1  jack-0.125.0-5  jasper-2.0.14-1  js52-52.9.0-1  json-glib-1.4.4-1  kactivities-5.50.0-1  kactivities-stats-5.50.0-1  kactivitymanagerd-5.14.0-1  karchive-5.50.0-1  kauth-5.50.0-1  kbookmarks-5.50.0-1  kcmutils-5.50.0-1  kcodecs-5.50.0-1  kcompletion-5.50.0-1  kconfig-5.50.0-1  kconfigwidgets-5.50.0-1  kcoreaddons-5.50.0-1  kcrash-5.50.0-1  kdbusaddons-5.50.0-1  kde-cli-tools-5.14.0-1  kdeclarative-5.50.0-1  kdecoration-5.14.0-1  kded-5.50.0-1  kdelibs4support-5.50.0-1  kdesu-5.50.0-1  kdnssd-5.50.0-1  kemoticons-5.50.0-1  kfilemetadata-5.50.0-1  kglobalaccel-5.50.0-1  kguiaddons-5.50.0-1  kholidays-1:5.50.0-1  khotkeys-5.14.0-1  ki18n-5.50.0-1  kiconthemes-5.50.0-1  kidletime-5.50.0-1  kinit-5.50.0-1  kio-5.50.0-1  kio-extras-18.08.2-1  kirigami2-5.50.0-1  kitemmodels-5.50.0-1  kitemviews-5.50.0-1  kjobwidgets-5.50.0-1  kjs-5.50.0-1  kjsembed-5.50.0-1  kmenuedit-5.14.0-1  knetattach-5.14.0-1  knewstuff-5.50.0-1  knotifications-5.50.0-1  knotifyconfig-5.50.0-1  kpackage-5.50.0-1  kparts-5.50.0-1  kpeople-5.50.0-1  kpty-5.50.0-1  krunner-5.50.0-1  kscreenlocker-5.14.0-1  kservice-5.50.0-1  ksysguard-5.14.0-1  ktexteditor-5.50.0-1  ktextwidgets-5.50.0-1  kunitconversion-5.50.0-1  kwallet-5.50.0-1  kwayland-5.50.0-1  kwidgetsaddons-5.50.0-1  kwin-5.14.0-1  kwindowsystem-5.50.0-1  kxmlgui-5.50.0-1  l-smash-2.14.5-1  lame-3.100-2  lcms2-2.9-1  ldb-1:1.3.6-1  libass-0.14.0-1  libasyncns-0.8+3+g68cd5af-1  libatasmart-0.19-4  libavc1394-0.5.4-3  libblockdev-2.20-1  libbluray-1.0.2-2  libbsd-0.9.1-1  libbytesize-1.4-1  libcanberra-0.30+2+gc0620e4-1  libcroco-0.6.12+4+g9ad7287-1  libcups-2.2.8-3  libdaemon-0.14-4  libdatrie-0.2.12-1  libdbusmenu-qt5-0.9.3+16.04.20160218-1  libdmtx-0.7.4-6  libdrm-2.4.95-1  libedit-20180525_3.1-1  libepoxy-1.5.3-1  libevdev-1.5.9-1  libevent-2.1.8-1  libfontenc-1.1.3-2  libgit2-1:0.27.5-1  libglvnd-1.1.0-1  libgudev-232-1  libgusb-0.3.0-1  libibus-1.5.19-1  libice-1.0.9-2  libidn-1.35-1  libiec61883-1.2.0-5  libimobiledevice-1.2.0+66+g5a85432-2  libinput-1.12.1-1  libjpeg-turbo-2.0.0-1  libksysguard-5.14.0-1  libmodplug-0.8.9.0-1  libmtp-1.1.15-1  libnetfilter_conntrack-1.0.7-1  libnewt-0.52.20-2  libnfnetlink-1.0.1-3  libnotify-0.7.7-1  libnsl-1.2.0-1  libogg-1.3.3-3  libomxil-bellagio-0.9.3-2  libpciaccess-0.14-1  libplist-2.0.0+11+gec9ba8b-2  libpng-1.6.35-1  libproxy-0.4.15-8  libpulse-12.2-2  libqalculate-2.6.2-1  libraw1394-2.1.2-1  librsvg-2:2.44.7-1  libsamplerate-0.1.9-1  libsm-1.2.2-3  libsndfile-1.0.28-1  libsoup-2.64.1-1  libsoxr-0.1.3-1  libssh-0.8.3-1  libstemmer-0+337-2  libthai-0.1.28-1  libtheora-1.1.1-4  libtiff-4.0.9-2  libtool-2.4.6+42+gb88cebd5-2  libunwind-1.2.1-1  libusbmuxd-1.0.10+13+gc724e70-1  libutempter-1.1.6-3  libva-2.3.0-1  libvdpau-1.1.1+3+ga21bf7a-1  libvisual-0.4.0-7  libvorbis-1.3.6-1  libvpx-1.7.0-1  libwacom-0.31-1  libwbclient-4.8.5-1  libwebp-1.0.0-1  libx11-1.6.7-1  libxau-1.0.8-3  libxaw-1.0.13-2  libxcb-1.13.1-1  libxcomposite-0.4.4-3  libxcursor-1.1.15-1  libxdamage-1.1.4-3  libxdmcp-1.1.2-2  libxext-1.3.3-2  libxfixes-5.0.3-2  libxfont2-2.0.3-1  libxft-2.3.2-2  libxi-1.7.9-1  libxinerama-1.1.4-1  libxkbcommon-0.8.2-1  libxkbcommon-x11-0.8.2-1  libxkbfile-1.0.9-2  libxklavier-5.4-2  libxml2-2.9.8-5  libxmu-1.1.2-2  libxpm-3.5.12-1  libxrandr-1.5.1-2  libxrender-0.9.10-1  libxres-1.2.0-1  libxshmfence-1.3-1  libxslt-1.1.32+3+g32c88216-1  libxss-1.2.3-1  libxt-1.1.5-2  libxtst-1.2.3-1  libxv-1.0.11-1  libxxf86vm-1.1.4-2  libyaml-0.2.1-1  libzip-1.5.1-1  llvm-libs-7.0.0-1  lm_sensors-3.4.0+5176+dcf23676-1  lmdb-0.9.22-1  lua52-5.2.4-3  lzo-2.10-1  media-player-info-23-1  mesa-18.2.2-1  milou-5.14.0-1  mtdev-1.1.5-2  ndctl-63-1  net-tools-1.60.20180212git-1  nfsidmap-2.3.3-1  noto-fonts-20180322-1  nspr-4.20-1  nss-3.39-1  openal-1.19.1-1  opencore-amr-0.1.5-1  openexr-2.3.0-1  openjpeg2-2.3.0-3  openssl-1.0-1.0.2.p-1  opus-1.2.1-1  orc-0.4.28-1  pango-1.42.4-1  pcsclite-1.8.23-3  phonon-qt5-4.10.1-2  phonon-qt5-gstreamer-4.9.0-5  pixman-0.34.0-1  plasma-framework-5.50.0-1  plasma-integration-5.14.0-1  plasma-workspace-5.14.0-1  polkit-0.115+3+g8638ec5-1  polkit-kde-agent-5.14.0-1  polkit-qt5-0.112.0+git20180107-2  poppler-0.67.0-1  poppler-qt5-0.67.0-1  prison-5.50.0-1  progsreiserfs-0.3.0.5-9  pygobject-devel-3.30.1-3  python-3.7.0-4  python-gobject-3.30.1-3  python2-2.7.15-2  qqc2-desktop-style-5.50.0-1  qrencode-4.0.2-1  qt5-base-5.11.2-1  qt5-declarative-5.11.2-1  qt5-graphicaleffects-5.11.2-1  qt5-location-5.11.2-1  qt5-multimedia-5.11.2-1  qt5-quickcontrols-5.11.2-1  qt5-quickcontrols2-5.11.2-1  qt5-script-5.11.2-1  qt5-sensors-5.11.2-1  qt5-speech-5.11.2-1  qt5-svg-5.11.2-1  qt5-tools-5.11.2-2  qt5-webchannel-5.11.2-1  qt5-webkit-5.212.0alpha2-20  qt5-x11extras-5.11.2-1  qt5-xmlpatterns-5.11.2-1  rest-0.8.1-1  rpcbind-1.2.5-1  sdl2-2.0.8-9  shared-mime-info-1.10-1  slang-2.3.2-1  smbclient-4.8.5-1  solid-5.50.0-1  sonnet-5.50.0-1  sound-theme-freedesktop-0.8-3  speex-1.2.0-1  speexdsp-1.2rc3-3  syntax-highlighting-5.50.0-1  systemsettings-5.14.0-1  taglib-1.11.1-1  talloc-2.1.14-1  tcl-8.6.8-3  tdb-1.3.16-1  tevent-1:0.9.37-1  threadweaver-5.50.0-1  tslib-1.17-1  ttf-hack-3.003-1  udisks2-2.8.1-1  unzip-6.0-12  upower-0.99.8-2  usbmuxd-1.1.0+28+g46bdf3e-1  v4l-utils-1.14.2-1  vid.stab-1.1-2  vim-runtime-8.1.0374-1  volume_key-0.3.11-2  wayland-1.16.0-1  wayland-protocols-1.16-1  wpa_supplicant-1:2.6-12  wvstreams-4.6.1-14  x264-2:155.r0a84d986-2  x265-2.9-1  xbitmaps-1.1.2-1  xcb-proto-1.13-2  xcb-util-0.4.0-2  xcb-util-cursor-0.1.3-1  xcb-util-image-0.4.0-2  xcb-util-keysyms-0.4.0-2  xcb-util-renderutil-0.3.9-2  xcb-util-wm-0.4.1-2  xdg-utils-1.1.3-3  xf86-input-libinput-0.28.0-1  xkeyboard-config-2.24-1  xorg-bdftopcf-1.1-1  xorg-font-util-1.3.1-2  xorg-font-utils-7.6-5  xorg-fonts-encodings-1.0.4-5  xorg-luit-1.1.1-3  xorg-mkfontdir-1.0.7-9  xorg-mkfontscale-1.1.3-1  xorg-server-common-1.20.1-1  xorg-setxkbmap-1.3.1-2  xorg-xauth-1.0.10-1  xorg-xkbcomp-1.4.2-1  xorg-xmessage-1.0.5-1  xorg-xmodmap-1.0.9-2  xorg-xprop-1.2.3-1  xorg-xrdb-1.1.1-1  xorg-xset-1.2.4-1  xorg-xsetroot-1.1.2-1  xorgproto-2018.4-1  xplc-0.3.13-7  xvidcore-1.3.5-1  zip-3.0-8  zita-alsa-pcmi-0.3.2-1  zita-resampler-1.6.2-1  alsa-utils-1.1.6-1  arch-install-scripts-19-1  b43-fwcutter-019-2  bash-completion-2.8-1  bind-tools-9.13.3-1  broadcom-wl-6.30.223.271-51  btrfs-progs-4.17.1-1  dhclient-4.4.1-4  dialog-1:1.3_20180621-1  dmraid-1.0.0.rc16.3-11  dnsmasq-2.79-3  dolphin-18.08.2-1  dosfstools-4.1-1  ethtool-1:4.18-1  exfat-utils-1.3.0-1  f2fs-tools-1.11.0-2  file-roller-3.30.0-1  fsarchiver-0.8.5-1  gpm-1.20.7.r27.g1fd1941-1  gptfdisk-1.0.4-1  grml-zsh-config-0.15.0-1  grub-2:2.02-7  hdparm-9.56-1  ipw2100-fw-1.3-8  ipw2200-fw-3.1-6  irssi-1.1.1-2  konsole-18.08.2-1  lftp-4.8.4-2  lightdm-1:1.28.0-1  lightdm-gtk-greeter-1:2.0.6-1  lightdm-gtk-greeter-settings-1.2.2-3  lsscsi-0.30-1  mlocate-0.26.git.20170220-1  mtools-4.0.18-4  ndisc6-1.0.3-2  nfs-utils-2.3.3-1  nilfs-utils-2.2.7-1  nmap-7.70-2  ntfs-3g-2017.3.23-3  ntp-4.2.8.p12-2  openconnect-1:7.08-1  partclone-0.3.11-1  parted-3.2-6  partimage-0.6.9-12  plasma-desktop-5.14.0-1  ppp-2.4.7-4  pptpclient-1.10.0-1  refind-efi-0.11.3-1  rp-pppoe-3.12-3  rsync-3.1.3-1  sdparm-1.10-1  sg3_utils-1.44-1  smartmontools-6.6-1  sudo-1.8.25.p1-1  tcpdump-4.9.2-1  testdisk-7.0-5  ufw-0.35-5  usb_modeswitch-2.5.2-1  vim-8.1.0374-1  vpnc-0.5.3.svn550-2  wget-1.19.5-1  wpa_actiond-1.4-3  wvdial-1.61-7  xdg-user-dirs-0.17-1  xl2tpd-1.3.12-2  xorg-server-1.20.1-1  xorg-twm-1.0.10-1  xorg-xinit-1.4.0-3  xterm-337-1

Total Download Size:      0.60 MiB
Total Installed Size:  1786.73 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
downloading openal-1.19.1-1-x86_64.pkg.tar.xz...
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
:: Processing package changes...
installing libepoxy...
installing libpng...
installing graphite...
installing harfbuzz...
Optional dependencies for harfbuzz
    cairo: hb-view program [pending]
installing freetype2...
installing libfontenc...
installing xorgproto...
installing libxfont2...
installing pixman...
installing xkeyboard-config...
installing xcb-proto...
installing libxdmcp...
installing libxau...
installing libxcb...
installing libx11...
installing libxkbfile...
installing xorg-xkbcomp...
installing xorg-setxkbmap...
installing xorg-server-common...
installing libunwind...
installing libxext...
installing libpciaccess...
installing libdrm...
installing icu...
installing libxml2...
installing wayland...
installing libxxf86vm...
installing libxfixes...
installing libxdamage...
installing libxshmfence...
installing libomxil-bellagio...
installing libedit...
installing llvm-libs...
installing lm_sensors...
Optional dependencies for lm_sensors
    rrdtool: for logging with sensord
installing mesa...
Optional dependencies for mesa
    opengl-man-pages: for the OpenGL API man pages
    mesa-vdpau: for accelerated video playback
    libva-mesa-driver: for accelerated video playback
installing libglvnd...
installing mtdev...
installing libevdev...
installing libgudev...
installing libwacom...
installing libinput...
Optional dependencies for libinput
    gtk3: libinput debug-gui [pending]
    python-pyudev: libinput measure
    python-evdev: libinput measure
installing xf86-input-libinput...
installing xorg-server...
>>> xorg-server has now the ability to run without root rights with
    the help of systemd-logind. xserver will fail to run if not launched
    from the same virtual terminal as was used to log in.
    Without root rights, log files will be in ~/.local/share/xorg/ directory.

    Old behavior can be restored through Xorg.wrap config file.
    See Xorg.wrap man page (man xorg.wrap).
installing libice...
installing libsm...
installing libxt...
installing libxmu...
installing xorg-xauth...
installing xorg-xrdb...
Optional dependencies for xorg-xrdb
    gcc: for preprocessing
    mcpp: a lightweight alternative for preprocessing
installing xorg-xmodmap...
installing xorg-xinit...
Optional dependencies for xorg-xinit
    xorg-twm [pending]
    xterm [pending]
installing xorg-twm...
installing fontconfig...
  
  Fontconfig configuration is done via /etc/fonts/conf.avail and conf.d.
  Read /etc/fonts/conf.d/README for more information.

  Configuration via /etc/fonts/local.conf is still possible,
  but is no longer recommended for options available in conf.avail.

  Main systemwide configuration should be done by symlinks
  (especially for autohinting, sub-pixel and lcdfilter):
  
  cd /etc/fonts/conf.d
  ln -s ../conf.avail/XX-foo.conf
  
  Check also https://wiki.archlinux.org/index.php/Font_Configuration
  and https://wiki.archlinux.org/index.php/Fonts.

Rebuilding fontconfig cache... done.
installing libxrender...
installing libxft...
installing libxpm...
installing libxaw...
installing xorg-luit...
installing xbitmaps...
installing libutempter...
installing xterm...
installing libjpeg-turbo...
installing xcb-util-keysyms...
installing xcb-util-renderutil...
installing xorg-xset...
installing xdg-utils...
Optional dependencies for xdg-utils
    kde-cli-tools: for KDE Plasma5 support in xdg-open [pending]
    exo: for Xfce support in xdg-open
    xorg-xprop: for Xfce support in xdg-open [pending]
    pcmanfm: for LXDE support in xdg-open
    perl-file-mimeinfo: for generic support in xdg-open
    perl-net-dbus: Perl extension to dbus used in xdg-screensaver
    perl-x11-protocol: Perl X11 protocol used in xdg-screensaver
installing shared-mime-info...
installing xcb-util-wm...
installing libxi...
installing xcb-util...
installing xcb-util-image...
installing tslib...
installing libxkbcommon...
installing libxkbcommon-x11...
installing libproxy...
Optional dependencies for libproxy
    networkmanager: NetworkManager configuration module
    perl: Perl bindings [installed]
    python2: Python 2.x bindings [pending]
    python: Python 3.x bindings [pending]
    glib2: gsettings configuration module [installed]
    webkit2gtk: PAC proxy support (Webkit2gtk engine)
installing libtiff...
Optional dependencies for libtiff
    freeglut: for using tiffgt
installing libdaemon...
installing avahi...
Optional dependencies for avahi
    gtk3: avahi-discover, avahi-discover-standalone, bshell, bssh, bvnc [pending]
    gtk2: gtk2 bindings
    qt4: qt4 bindings
    qt5-base: qt5 bindings [pending]
    pygtk: avahi-bookmarks
    python2-twisted: avahi-bookmarks
    mono: mono bindings
    nss-mdns: NSS support for mDNS
    python-gobject: avahi-discover [pending]
    python-dbus: avahi-discover
installing libcups...
installing double-conversion...
installing qt5-base...
Optional dependencies for qt5-base
    qt5-svg: to use SVG icon themes [pending]
    postgresql-libs: PostgreSQL driver
    libmariadbclient: MariaDB driver
    unixodbc: ODBC driver
    libfbclient: Firebird/iBase driver
    freetds: MS SQL driver
    gtk3: GTK platform plugin [pending]
installing qt5-svg...
installing kcoreaddons...
Optional dependencies for kcoreaddons
    python-pyqt5: for the Python bindings
installing js52...
installing polkit...
installing polkit-qt5...
installing kauth...
Optional dependencies for kauth
    python-pyqt5: for the Python bindings
installing kcodecs...
Optional dependencies for kcodecs
    python-pyqt5: for the Python bindings
installing kconfig...
Optional dependencies for kconfig
    python-pyqt5: for the Python bindings
installing qt5-x11extras...
installing kguiaddons...
Optional dependencies for kguiaddons
    python-pyqt5: for the Python bindings
installing qt5-xmlpatterns...
installing qt5-declarative...
installing ki18n...
Optional dependencies for ki18n
    python-pyqt5: for the Python bindings
    python: to compile .ts files [pending]
installing kwidgetsaddons...
Optional dependencies for kwidgetsaddons
    python-pyqt5: for the Python bindings
installing kconfigwidgets...
Optional dependencies for kconfigwidgets
    python-pyqt5: for the Python bindings
installing kitemviews...
Optional dependencies for kitemviews
    python-pyqt5: for the Python bindings
installing karchive...
installing kiconthemes...
Optional dependencies for kiconthemes
    breeze-icons: fallback icon theme [pending]
installing kdbusaddons...
Optional dependencies for kdbusaddons
    python-pyqt5: for the Python bindings
installing kwindowsystem...
installing kcrash...
Optional dependencies for kcrash
    drkonqi: KDE crash handler application
installing polkit-kde-agent...
installing kjs...
installing kjsembed...
installing media-player-info...
installing libplist...
installing libusbmuxd...
installing usbmuxd...
installing libimobiledevice...
installing upower...
installing libatasmart...
installing lzo...
installing btrfs-progs...
Optional dependencies for btrfs-progs
    python: libbtrfsutil python bindings [pending]
installing dosfstools...
installing dmraid...
installing gptfdisk...
installing libbytesize...
installing ndctl...
installing parted...
installing nspr...
installing nss...
installing volume_key...
Optional dependencies for volume_key
    python: for python bindings [pending]
installing libyaml...
installing libblockdev...
installing udisks2...
Optional dependencies for udisks2
    gptfdisk: GUID partition table support [installed]
    ntfs-3g: NTFS filesystem management support [pending]
    dosfstools: VFAT filesystem management support [installed]
    libiscsi: iSCSI support
installing solid...
Optional dependencies for solid
    qt5-declarative: QML bindings [installed]
installing kjobwidgets...
Optional dependencies for kjobwidgets
    python-pyqt5: for the Python bindings
installing kglobalaccel...
installing kcompletion...
Optional dependencies for kcompletion
    python-pyqt5: for the Python bindings
installing kservice...
installing sonnet...
Optional dependencies for sonnet
    hunspell: spell checking via hunspell
    aspell: spell checking via aspell
    hspell: spell checking for Hebrew
    libvoikko: Finnish support via Voikko
installing gstreamer...
installing orc...
installing libxv...
installing iso-codes...
installing gst-plugins-base-libs...
installing alsa-lib...
Optional dependencies for alsa-lib
    python2: for python smixer plugin [pending]
installing cdparanoia...
installing libvisual...
installing libogg...
installing libvorbis...
installing libtheora...
installing libdatrie...
installing libthai...
installing cairo...
installing fribidi...
installing pango...
installing opus...
installing graphene...
installing gst-plugins-base...
installing libasyncns...
installing libxtst...
installing flac...
installing libsndfile...
installing libpulse...
installing openal...
Optional dependencies for openal
    qt5-base: alsoft-config GUI Configurator [installed]
    fluidsynth: MIDI rendering
installing qt5-multimedia...
Optional dependencies for qt5-multimedia
    qt5-declarative: QML bindings [installed]
    gst-plugins-good: camera support, additional plugins
    gst-plugins-bad: camera support, additional plugins
    gst-plugins-ugly: additional plugins
    gst-libav: ffmpeg plugin
installing qt5-speech...
Optional dependencies for qt5-speech
    flite: flite TTS backend
    speech-dispatcher: speech-dispatcher TTS backend
installing ktextwidgets...
installing attica...
installing kxmlgui...
installing kbookmarks...
installing libxslt...
installing libtool...
installing tdb...
Optional dependencies for tdb
    python2: for python bindings [pending]
installing sound-theme-freedesktop...
installing libcanberra...
Optional dependencies for libcanberra
    libcanberra-pulse: PulseAudio driver
    libcanberra-gstreamer: GStreamer driver
installing libdbusmenu-qt5...
installing knotifications...
installing kwallet...
Optional dependencies for kwallet
    kwalletmanager: Configuration GUI
installing desktop-file-utils...
installing qt5-script...
installing kio...
Optional dependencies for kio
    kio-extras: extra protocols support (sftp, fish and more) [pending]
    kdoctools: for the help kioslave
    knetattach: to add new kio-remote entries [pending]
installing phonon-qt5-gstreamer...
Optional dependencies for phonon-qt5-gstreamer
    pulseaudio: PulseAudio support
    gst-plugins-good: PulseAudio support and good codecs
    gst-plugins-bad: additional codecs
    gst-plugins-ugly: additional codecs
    gst-libav: libav codec
installing phonon-qt5...
Optional dependencies for phonon-qt5
    pulseaudio: PulseAudio support
    qt5-tools: Designer plugin [pending]
installing knotifyconfig...
installing libxres...
installing qt5-location...
installing qt5-sensors...
Optional dependencies for qt5-sensors
    qt5-declarative: QML bindings [installed]
installing qt5-webchannel...
installing giflib...
installing libwebp...
Optional dependencies for libwebp
    freeglut: vwebp viewer
installing libxcomposite...
installing hyphen...
installing qt5-webkit...
Optional dependencies for qt5-webkit
    gst-plugins-good: Webm codec support
installing libksysguard...
installing kparts...
installing syntax-highlighting...
installing libgit2...
installing editorconfig-core-c...
installing ktexteditor...
installing libqalculate...
Optional dependencies for libqalculate
    gnuplot: for plotting support
installing hicolor-icon-theme...
installing qt5-tools...
Optional dependencies for qt5-tools
    clang: for qdoc
    qt5-webkit: for Qt Assistant [installed]
installing kpty...
installing kdesu...
installing kpackage...
installing kdeclarative...
installing kcmutils...
installing kinit...
installing kactivities...
Optional dependencies for kactivities
    qt5-declarative: QML bindings [installed]
installing kde-cli-tools...
Optional dependencies for kde-cli-tools
    plasma-workspace: for kcmshell5 [pending]
installing bc...
installing libxcursor...
Optional dependencies for libxcursor
    gnome-themes-standard: fallback icon theme
installing xorg-xsetroot...
installing kactivitymanagerd...
installing kholidays...
Optional dependencies for kholidays
    qt5-declarative: QML bindings [installed]
installing xorg-xmessage...
installing xorg-xprop...
installing kwayland...
installing qt5-quickcontrols...
installing qt5-quickcontrols2...
Optional dependencies for qt5-quickcontrols2
    qt5-graphicaleffects: for the Material style [pending]
installing qt5-graphicaleffects...
installing kirigami2...
installing plasma-framework...
installing threadweaver...
installing krunner...
installing milou...
installing libdmtx...
installing qrencode...
installing prison...
Optional dependencies for prison
    qt5-declarative: QML bindings [installed]
installing libxss...
installing kidletime...
installing kscreenlocker...
installing xcb-util-cursor...
installing knewstuff...
Optional dependencies for knewstuff
    kirigami2: QML components [installed]
installing frameworkintegration...
Optional dependencies for frameworkintegration
    appstream-qt: dependency resolving via AppStream [pending]
    packagekit-qt5: dependency resolving via AppStream
installing kdecoration...
installing breeze-icons...
installing fftw...
installing breeze...
Optional dependencies for breeze
    breeze-gtk: Breeze widget style for GTK applications
    kcmutils: for breeze-settings [installed]
installing kwin...
Optional dependencies for kwin
    qt5-virtualkeyboard: virtual keyboard support for kwin-wayland
installing noto-fonts...
Optional dependencies for noto-fonts
    noto-fonts-cjk: CJK characters
    noto-fonts-emoji: Emoji characters
    noto-fonts-extra: additional variants (condensed, semi-bold, extra-light)
installing xorg-fonts-encodings...
installing xorg-bdftopcf...
installing xorg-mkfontscale...
installing xorg-mkfontdir...
Creating X fontdir indices... done.
installing xorg-font-util...
installing xorg-font-utils...
installing ttf-hack...
installing qqc2-desktop-style...
installing plasma-integration...
installing kunitconversion...
installing kitemmodels...
Optional dependencies for kitemmodels
    python-pyqt5: for the Python bindings
installing kemoticons...
installing kded...
installing kdelibs4support...
installing plasma-workspace...
Optional dependencies for plasma-workspace
    plasma-workspace-wallpapers: additional wallpapers
    gpsd: GPS based geolocation
    networkmanager-qt: IP based geolocation
    kdepim-addons: displaying PIM events in the calendar
    appmenu-qt4: global menu support for Qt4 applications
    appmenu-gtk-module: global menu support for GTK2 and some GTK3 applications
    qt5-virtualkeyboard: virtual keyboard support in lock screen
    baloo: Baloo search runner [pending]
    appstream-qt: package search runner [pending]
installing khotkeys...
installing kmenuedit...
installing libstemmer...
installing appstream...
installing appstream-qt...
installing kactivities-stats...
installing systemsettings...
Optional dependencies for systemsettings
    khtml: for the tree view
installing ksysguard...
installing kpeople...
Optional dependencies for kpeople
    qt5-declarative: QML bindings [installed]
installing exiv2...
installing lcms2...
installing openjpeg2...
installing poppler...
Optional dependencies for poppler
    poppler-data: encoding data to display PDF documents containing CJK characters
installing poppler-qt5...
installing taglib...
installing aom...
installing gsm...
installing libsamplerate...
installing zita-alsa-pcmi...
installing zita-resampler...
installing jack...
Optional dependencies for jack
    celt: NetJACK driver
    libffado: FireWire support
    realtime-privileges: Acquire realtime privileges
installing lame...
installing libraw1394...
installing libavc1394...
installing libiec61883...
installing libmodplug...
installing libsoxr...
installing libssh...
installing libvdpau...
installing opencore-amr...
installing libibus...
installing sdl2...
Optional dependencies for sdl2
    alsa-lib: ALSA audio driver [installed]
    libpulse: PulseAudio audio driver [installed]
installing speexdsp...
installing speex...
installing v4l-utils...
Optional dependencies for v4l-utils
    qt5-base [installed]
    alsa-lib [installed]
installing libass...
installing libbluray...
Optional dependencies for libbluray
    java-runtime=8: BD-J library
installing libva...
Optional dependencies for libva
    libva-vdpau-driver: backend for Nvidia and AMD cards
    libva-intel-driver: backend for Intel cards
installing vid.stab...
installing libvpx...
installing l-smash...
installing x264...
installing x265...
installing xvidcore...
installing ffmpeg...
Optional dependencies for ffmpeg
    ladspa: LADSPA filters
installing libzip...
installing convertlit...
installing ebook-tools...
installing kfilemetadata...
Optional dependencies for kfilemetadata
    catdoc: Extract text from Office 98 files
installing lmdb...
installing baloo...
Optional dependencies for baloo
    qt5-declarative: QML bindings [installed]
installing knetattach...
installing plasma-desktop...
Optional dependencies for plasma-desktop
    plasma-nm: Network manager applet
    powerdevil: power management
    ibus: kimpanel IBUS support
    scim: kimpanel SCIM support
    discover: manage applications installation from the launcher
installing baloo-widgets...
installing kdnssd...
installing talloc...
Optional dependencies for talloc
    python2: for python bindings [pending]
installing libbsd...
installing libwbclient...
installing cifs-utils...
installing tevent...
Optional dependencies for tevent
    python2: for python bindings [pending]
installing ldb...
Optional dependencies for ldb
    python2: for python bindings [pending]
installing libnsl...
installing python2...
Optional dependencies for python2
    tk: for IDLE
    python2-setuptools
    python2-pip
installing gamin...
Optional dependencies for gamin
    python2: for the python module [installed]
installing smbclient...
installing glu...
installing ilmbase...
installing openexr...
installing libmtp...
installing kio-extras...
Optional dependencies for kio-extras
    qt5-webengine: HTML thumbnailer
    qt5-imageformats: thumbnails for additional image formats
    kimageformats: thumbnails for additional image formats
    taglib: audio file thumbnails [installed]
    khtml: man kioslave
    phonon-qt5: audio file previews [installed]
installing dolphin...
Optional dependencies for dolphin
    kde-cli-tools: for editing file type options [installed]
    ffmpegthumbs: video thumbnails
    ruby: installing new service menus from KDE Store
    kdegraphics-thumbnailers: PDF and PS thumbnails
    konsole: terminal panel [pending]
    purpose: share context menu
installing konsole...
Optional dependencies for konsole
    keditbookmarks: to manage bookmarks
installing xdg-user-dirs...
Created symlink /etc/systemd/user/default.target.wants/xdg-user-dirs-update.service -> /usr/lib/systemd/user/xdg-user-dirs-update.service.
installing bash-completion...
installing alsa-utils...
installing mlocate...
installing atk...
installing libxinerama...
installing libxrandr...
installing jasper...
Optional dependencies for jasper
    jasper-doc: documentation
    freeglut: jiv support
    glu: jiv support [installed]
installing gdk-pixbuf2...
installing dconf...
installing at-spi2-core...
Optional dependencies for at-spi2-core
    dbus-broker: Alternative bus implementation
installing at-spi2-atk...
installing libcroco...
installing librsvg...
installing gtk-update-icon-cache...
installing adwaita-icon-theme...
installing json-glib...
installing wayland-protocols...
installing cantarell-fonts...
installing libgusb...
installing colord...
Optional dependencies for colord
    argyllcms: color profiling
    colord-sane: SANE support
installing gsettings-desktop-schemas...
installing glib-networking...
installing libsoup...
installing rest...
installing gtk3...
installing libnotify...
installing zip...
installing unzip...
installing file-roller...
Optional dependencies for file-roller
    p7zip: 7z, arj, exe and encrypted zip files support
    unrar: better RAR archive support
    unace: ACE archive support
    lrzip: lrzip archive support
installing python...
Optional dependencies for python
    python-setuptools
    python-pip
    sqlite [installed]
    mpdecimal: for decimal
    xz: for lzma [installed]
    tk: for tkinter
installing ufw...
installing libxklavier...
installing lightdm...
Optional dependencies for lightdm
    accountsservice: Enhanced user accounts handling
    lightdm-gtk-greeter: GTK greeter [pending]
    xorg-server-xephyr: LightDM test mode
installing lightdm-gtk-greeter...
installing gobject-introspection-runtime...
installing pygobject-devel...
installing python-gobject...
Optional dependencies for python-gobject
    cairo: Cairo bindings [installed]
installing lightdm-gtk-greeter-settings...
installing arch-install-scripts...
installing b43-fwcutter...
installing broadcom-wl...
installing dhclient...
installing dialog...
installing libnfnetlink...
installing libnetfilter_conntrack...
installing dnsmasq...
installing geoip-database...
installing geoip...
Optional dependencies for geoip
    geoip-database-extra: city/ASN databases (not needed for country lookups)
installing idnkit...
installing dnssec-anchors...
installing bind-tools...
Optional dependencies for bind-tools
    python: for python scripts [installed]
installing ethtool...
installing fuse-common...
installing fuse2...
installing exfat-utils...
installing f2fs-tools...
installing fsarchiver...
installing gpm...
installing grml-zsh-config...
installing grub...
Generating grub.cfg.example config file...
This may fail on some machines running a custom kernel.
done.
Optional dependencies for grub
    freetype2: For grub-mkfont usage [installed]
    fuse2: For grub-mount usage [installed]
    dosfstools: For grub-mkrescue FAT FS and EFI support [installed]
    efibootmgr: For grub-install EFI support [pending]
    libisoburn: Provides xorriso for generating grub rescue iso using grub-mkrescue
    os-prober: To detect other OSes when generating grub.cfg in BIOS systems
    mtools: For grub-mkrescue FAT FS support [pending]
installing hdparm...
Optional dependencies for hdparm
    bash: for wiper.sh script [installed]
installing ipw2100-fw...
installing ipw2200-fw...
installing irssi...
Optional dependencies for irssi
    perl-libwww: for the scriptassist script
installing lftp...
Optional dependencies for lftp
    perl: needed for convert-netscape-cookies and verify-file [installed]
installing lsscsi...
installing mtools...
Optional dependencies for mtools
    libx11: required by floppyd [installed]
    libsm: required by floppyd [installed]
installing ndisc6...
installing rpcbind...
installing nfsidmap...
installing ding-libs...
installing gssproxy...
installing libevent...
Optional dependencies for libevent
    python2: to use event_rpcgen.py [installed]
installing nfs-utils...
Optional dependencies for nfs-utils
    sqlite: for nfsdcltrack usage [installed]
    python: for nfsiostat and mountstats usage [installed]
installing nilfs-utils...
installing lua52...
installing nmap...
Optional dependencies for nmap
    pygtk: zenmap
    sudo: privilege escalation for zenmap [pending]
    xterm: privilege escalation for zenmap [installed]
    kde-cli-tools: privilege escalation for zenmap [installed]
installing ntfs-3g...
installing ntp...
installing vpnc...
Optional dependencies for vpnc
    openresolv: Let vpnc manage resolv.conf [installed]
installing pcsclite...
installing openconnect...
installing progsreiserfs...
installing partclone...
installing slang...
installing libnewt...
Optional dependencies for libnewt
    tcl: whiptcl support [pending]
    python: libnewt support with the _snack module [installed]
    python2: libnewt support with the _snack module [installed]
installing partimage...
installing ppp...
installing pptpclient...
installing efivar...
installing efibootmgr...
installing refind-efi...

rEFInd UEFI application has been installed at /usr/share/refind/refind_*.efi

Other UEFI applications have been installed at /usr/share/refind/tools_*/

UEFI drivers have been installed at /usr/share/refind/drivers_*/

Copy the efi application (according to your UEFI ARCH) 
and /usr/share/refind/refind.conf-sample to a sub-directory of <EFISYS>/EFI/
as refind.conf and add an entry to firmware boot menu using efibootmgr
or mactel-boot (for Macs)

rEFInd Icons have been installed at /usr/share/refind/icons/
rEFInd Fonts have been installed at /usr/share/refind/fonts/

HTML Documentation is available at /usr/share/refind/docs/html/

More info: https://wiki.archlinux.org/index.php/rEFInd 

Optional dependencies for refind-efi
    sudo: privilege elevation [pending]
    parted: For finding ESP [installed]
    imagemagick: For refind-mkfont script
    python: For refind-mkdefault script [installed]
    sbsigntools: For EFI binary signing
installing net-tools...
installing rp-pppoe...
>>> The kernel-mode plugin has a new place.
>>> It's now located under /usr/lib/rp-pppoe/rp-pppoe.so
>>> Change LINUX_PLUGIN to the new path in your /etc/ppp/pppoe.conf
installing rsync...
installing sdparm...
installing sg3_utils...
installing smartmontools...
Optional dependencies for smartmontools
    s-nail: to get mail alerts to work [installed]
installing sudo...
installing tcpdump...
installing testdisk...
installing tcl...
installing usb_modeswitch...
installing vim-runtime...
Optional dependencies for vim-runtime
    sh: support for some tools and macros [installed]
    python: demoserver example tool [installed]
    gawk: mve tools upport [installed]
installing vim...
Optional dependencies for vim
    python2: Python 2 language support [installed]
    python: Python 3 language support [installed]
    ruby: Ruby language support
    lua: Lua language support
    perl: Perl language support [installed]
    tcl: Tcl language support [installed]
installing libidn...
installing wget...
Optional dependencies for wget
    ca-certificates: HTTPS downloads [installed]
installing openssl-1.0...
Optional dependencies for openssl-1.0
    ca-certificates [installed]
installing wpa_supplicant...
installing wpa_actiond...
installing xplc...
installing wvstreams...
installing wvdial...
installing xl2tpd...
:: Running post-transaction hooks...
( 1/20) Updating linux module dependencies...
( 2/20) Updating linux initcpios...
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
==> Starting build: 4.18.12-arch1-1-ARCH
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
==> ERROR: failed to detect root filesystem
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
==> Starting build: 4.18.12-arch1-1-ARCH
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: aic94xx
==> WARNING: Possibly missing firmware for module: wd719x
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-fallback.img
==> Image generation successful
( 3/20) Warn about old perl modules
( 4/20) Updating fontconfig cache...
( 5/20) Probing GDK-Pixbuf loader modules...
( 6/20) Updating GIO module cache...
( 7/20) Compiling GSettings XML schema files...
( 8/20) Probing GTK3 input method modules...
( 9/20) Updating icon theme caches...
(10/20) Reloading system manager configuration...
  Skipped: Current root is not booted.
(11/20) Updating udev hardware database...
(12/20) Creating system user accounts...
(13/20) Creating temporary files...
error: command failed to execute correctly
(14/20) Reloading device manager configuration...
  Skipped: Device manager is not running.
(15/20) Arming ConditionNeedsUpdate...
(16/20) Updating the info directory file...
(17/20) Updating the appstream cache...
AppStream cache update completed successfully.
(18/20) Updating the desktop file MIME type cache...
(19/20) Updating the MIME type database...
(20/20) Updating X fontdir indices...
[mkarchiso] INFO: Packages installed successfully!

[mkarchiso] INFO: Configuration settings
[mkarchiso] INFO:                   Command:   run
[mkarchiso] INFO:              Architecture:   x86_64
[mkarchiso] INFO:         Working directory:   work/x86_64
[mkarchiso] INFO:    Installation directory:   arch
[mkarchiso] INFO:               Run command:   mkinitcpio -c /etc/mkinitcpio-archiso.conf -k /boot/vmlinuz-linux -g /boot/archiso.img

==> Starting build: 4.18.12-arch1-1-ARCH
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [memdisk]
  -> Running build hook: [archiso_shutdown]
  -> Running build hook: [archiso]
  -> Running build hook: [archiso_loop_mnt]
  -> Running build hook: [archiso_kms]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: aic94xx
==> WARNING: Possibly missing firmware for module: wd719x
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
==> Generating module dependencies
==> Creating xz-compressed initcpio image: /boot/archiso.img
==> Image generation successful
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 20016  100 20016    0     0  35806      0 --:--:-- --:--:-- --:--:-- 35806

[mkarchiso] INFO: Configuration settings
[mkarchiso] INFO:                   Command:   run
[mkarchiso] INFO:              Architecture:   x86_64
[mkarchiso] INFO:         Working directory:   work/x86_64
[mkarchiso] INFO:    Installation directory:   arch
[mkarchiso] INFO:               Run command:   /root/customize_airootfs.sh

Generating locales...
  en_US.UTF-8... done
Generation complete.
useradd: group 'audio.floppy' does not exist

Any help would be greatly appreciated.
Thank you.

Offline

#2 2018-10-13 10:05:57

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 6,288

Re: Installing custom Arch iso on usb (mkarchiso)

The guide you're following is NOT about creating a custom iso.

It deals with creating a full archlinux install that runs from an usb device.
mkarchiso is not needed for that at all.

Check https://wiki.archlinux.org/index.php/In … ting_Linux


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#3 2018-10-13 20:39:28

Thales
Member
Registered: 2018-10-13
Posts: 2

Re: Installing custom Arch iso on usb (mkarchiso)

Thanks for replying.

I only wanted to mix that blogspot guide with building my own iso and installing it on my usb. Sorry for not having formulated more clearly.

With a usb key that I can chroot in, I also have a folder (on my hard drive) that I have modified the pacman.x86_64 files for choosing the packages and DM I want so that I can build my custom iso. I cannot run the ./build.sh command with the folder with the pacman.x86_64 file on my hard drive because I lack the space needed to do so. So I move the folder with the modified pacman.86_64 to my usb and try to run it from a chrooted environnment so that I can build the iso on my usb key.

When I run this command to build my iso:

[root@user liveiso]# ./build.sh -v 2>&1 | tee log.txt

I get this error and I cannot recover from it:

useradd: group 'audio.floppy' does not exist

Than you

Offline

#4 2018-10-13 21:01:17

duaner
Member
Registered: 2018-10-13
Posts: 6

Re: Installing custom Arch iso on usb (mkarchiso)

The problem is that something is trying to create a user with groups "audio,floppy", but someone has typed a period instead of a comma. I'm guessing you added groups to a script at some point and added a typo.

Offline

Board footer

Powered by FluxBB