You are not logged in.

#1 2018-10-13 21:02:28

edolnx
Member
Registered: 2018-10-13
Posts: 1

4k Display no longer working on RX480 system after updates

Greetings Everyone -

I have a FX-8350 based system with an RX-480 that runs two monitors. One is a Crossover 289K (3840x2960 native) and the other is a Crossover WQHD (2560x1440 native). They both worked until I did a recent upgrade (I was probably a month behind on `pacman -Syu`) and now I can only get the 4k monitor to display at 2560x1440. The other resolutions seem to sync (OSD shows the correct resolution and frame rate), and KDE thinks it's there, but there is no output. Both monitors are connected via DisplayPort. I have tried with the 4k via HDMI and that gives some strange output (it thinks it's now a laptop with an external monitor, and attempting screen orientation and rotation corrupts output on both displays). I'm using the `amdgpu` drivers and Xorg (which hasn't changed since prior to the update).

Some searching through these forums implies that 4k on the RX480 has always been touch and go. Is it time for me to bite the bullet and upgrade to a RX580? Any other suggestions?

Offline

Board footer

Powered by FluxBB