You are not logged in.

#1 2006-07-29 13:25:38

Registered: 2005-10-20
Posts: 28

kernel2.6.17.7 initrd resp. initramfs


I wanted to updated my kernel.
Since I need to disable/enable some options in the .config, (SMP, PREEMPT and PWC) I downloaded it and did the /usr/src/linux compilation.

After I was done, I got a kernel panic like this

VFS: Cannot open root device "hda5" or unknown-block(0,0) 
Please append a correct "root=" boot option 
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

I searched the ArchWiki and Forum for this error and found that at some kernel update, modules are handled differently and that you now need to include a initrd.img file for booting modules. I couldn't find any such file in /usr/src/linux. But I found that there is another method, to create an alternative file with mkinitramfs. So I tried this for the new kernel:

 mkinitramfs kernel=

and put the resulting file to /boot and included it in my menu.lst:

title  Arch Linux [/boot/vmlinuz26]
root   (hd0,4)
kernel /boot/vmlinuz26 root=/dev/hda5 ro devfs=nomount
initrd /boot/initramfs-

title  Arch Linux [/boot/vmlinuz26-backup]
root   (hd0,4)
kernel /boot/vmlinuz26-backup root=/dev/hda5 ro devfs=nomount

I am currently running the second entry.
Booting the first entry still results in the kernel panic error shown above.
So I figure I have not yet understood how to deal with this new initrd / initramfs situation.

Can anyone tell me what I need to do, to get the new kernel and maybe explain to me why this change to initrd / intramfs and how it works.

Thank you!


#2 2006-07-29 20:57:49

Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,839

Re: kernel2.6.17.7 initrd resp. initramfs

Can I assume it's a while since you upgraded this machine? Arch switched to initrd in October of last year. mkinitramfs was introduced for the beyond kernel, although it also worked with the standard Arch kernel, but the current preferred method is mkinitcpio - all the details are here.


#3 2006-07-30 08:42:19

Registered: 2005-10-20
Posts: 28

Re: kernel2.6.17.7 initrd resp. initramfs

Thanks for the help.
I waited upgrading the risky stuff till I had some more time.

I followed the mkinitcpio wiki, I found no reason to change the original /etc/mkinitcpio.conf and used it to create a kernel26.img for the new kernel using the command:

 mkinitcpio -g /boot/kernel26.img -k 

Then I changed the initrd line in the menu.lst to

initrd /boot/kernel26.img

Still... booting the kernel i get the same error, I posted above.
Here's some more information I forgot to mention.
Right before the kernel panic, the screen changes it's resolution to a much higher one, it has never done this booting other kernels.
Before the kernel panic most stuff seems to be reckognized correctly, except the soundcard, which yields some errors.

Please tell me, where/how I could find out what's going on wrong there, or/and if I still am doing anything wrong conercing these new mkinit / modules / .img thingie.



Board footer

Powered by FluxBB