You are not logged in.

#1 2018-11-06 15:30:57

digitalone
Member
Registered: 2011-08-19
Posts: 159

[SOLVED] How to control volume Normalization on Pulseaudio dfault sink

Hello everyone. I'm a Plasma 5 user and I always had with Arch on my HP laptop an issue with audio. Either with ALSA and Pulseaudio (I'm using Pulseaudio now), there was a big difference in volume level between various applications and audio/video files. Besides, some videos I watch on mpv had an high dynamic range which led me to adjust the volume control over and over and it was very frustrating. These happened either with speakers and earphones.

So, I tried everything and finally managed to resolve this issue with the best solution for my experience: Pulseeffects with Maximizer and Auto Gain modules activated for audio output. Audio stream from every application goes into Maximizer module (despite its name, it can act as a limiter) with Ceiling to -3 dB and Threshold to 0 (it compresses the signal a little bit), then it goes into Auto Gain where it's normalized to Target -10. 

To get these things working at the next reboot, I selected "Enable at startup" and "Enable for all applications" from Pulseeffects configuration. So now I have "PulseEffects(apps)" as system default audio sink (after closing PulseEffects, I had to choose it as default from Plasma audio system settings) and at every reboot I see it as default from plasma-pa applet in the system tray. It's very good because now I rarely have to change volume when I'm watching/listening something.

So, everything OK, right? Well, not really. With this configuration, when I'm not reproducing anything, if I press one of the volume buttons on my keyboard, it changes the volume on the "PulseEffects(apps)" sink and it's right this way because it's the default sink.

But whenever I'm reproducing something (YouTube on Chromium or something with mpv), either with speakers and earphones, it changes the volume on "Stereo Internal Audio" sink linked to the HDA Realtek ALC3227 audio adapter. And PulseEffects(apps) is always the default sink.

Why this kind of behavior? It's not really bad, but whenever I'm going to watch something I have to adjust PulseEffects(apps) to 100% and wait the audio stream to start to control Stereo Internal Audio. Is there a reason to this? I might start a reproduction with PulseEffects(apps) to 30% and controlling Stereo Internal Audio from keyboard is meaningless because the volume will result always low.

Is there a way to always control the default sink? It should be the default sink for some reason.

Thank you anyway.

Last edited by digitalone (2018-11-06 20:22:16)

Offline

#2 2018-11-06 20:16:32

digitalone
Member
Registered: 2011-08-19
Posts: 159

Re: [SOLVED] How to control volume Normalization on Pulseaudio dfault sink

Removed plasma-pa and installed kmix. It works good now. In kmix configuration it's enough to select Stereo Internal Audio as primary stream (the default sink remains PulseEffects(apps)) and the volume is changed where is has to be controlled, even during reproduction.

plasma-pa is very bad, use kmix instead. Cheers.

Offline

#3 2018-11-07 09:50:37

digitalone
Member
Registered: 2011-08-19
Posts: 159

Re: [SOLVED] How to control volume Normalization on Pulseaudio dfault sink

Offline

Board footer

Powered by FluxBB