You are not logged in.

#1 2018-10-28 03:20:20

pedrofleck
Member
From: Porto Alegre, Brazil
Registered: 2013-11-17
Posts: 44
Website

Lutris says it's in 0.4.18.1, but it's suposed to be in 0.4.21.1

I have Lutris updated, and I used the package since it was on AUR. However, since it went to the community repo, even though I update it, it keeps saying in "about" that the version is 0.4.18.1. I tried reinstalling, removing it and installing again, clearing pacman cache and nothing worked.

Offline

#2 2018-10-28 13:29:22

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 6,375

Re: Lutris says it's in 0.4.18.1, but it's suposed to be in 0.4.21.1

output of pacman -Qs lutris and which lutris ?

If you create a new user, does lutris still show 0.4.18.1 for that user ?

Last edited by Lone_Wolf (2018-10-28 13:29:41)


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#3 2018-10-28 19:15:44

pedrofleck
Member
From: Porto Alegre, Brazil
Registered: 2013-11-17
Posts: 44
Website

Re: Lutris says it's in 0.4.18.1, but it's suposed to be in 0.4.21.1

Output:
local/lutris 0.4.21.1-1
    Open Gaming Platform
What do you mean with "which" lutris? The package "lutris" from the "community" repo. I won't be creating a new user for that.
EDIT:
It's not just a "typo" in the version shown in about, considering the changelog, it doesn't have 0.4.21 new features.

Last edited by pedrofleck (2018-10-28 19:19:51)

Offline

#4 2018-10-28 20:28:11

progandy
Member
Registered: 2012-05-17
Posts: 3,182

Re: Lutris says it's in 0.4.18.1, but it's suposed to be in 0.4.21.1

What do you mean with "which" lutris?

The shell command "which".

$ which lutris
$ which -a lutris
$ lutris --version
$ /usr/bin/lutris --version

Last edited by progandy (2018-10-28 20:28:51)


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Offline

#5 2018-11-01 06:24:08

pedrofleck
Member
From: Porto Alegre, Brazil
Registered: 2013-11-17
Posts: 44
Website

Re: Lutris says it's in 0.4.18.1, but it's suposed to be in 0.4.21.1

Either "which" or "which -a" output "/usr/bin/lutris"
The --version command output "unknown option". I tried lutris --help and there isn't a command to output the version.

Offline

#6 2018-11-01 08:54:39

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 6,375

Re: Lutris says it's in 0.4.18.1, but it's suposed to be in 0.4.21.1

Hmm, had expected which to output more then one lutris command.

The --version command output "unknown option". I tried lutris --help and there isn't a command to output the version.

That doesn't match what i get .

$ lutris --help

(lutris:4024): Gtk-WARNING **: 09:40:53.192: Theme parsing error: gtk.css:127:35: The style property GtkButton:child-displacement-x is deprecated and shouldn't be used anymore. It will be removed in a future version

(lutris:4024): Gtk-WARNING **: 09:40:53.193: Theme parsing error: gtk.css:128:35: The style property GtkButton:child-displacement-y is deprecated and shouldn't be used anymore. It will be removed in a future version

(lutris:4024): Gtk-WARNING **: 09:40:53.194: Theme parsing error: gtk.css:132:46: The style property GtkScrolledWindow:scrollbars-within-bevel is deprecated and shouldn't be used anymore. It will be removed in a future version
Usage:
  lutris [OPTION…] URI

Run a game directly by adding the parameter lutris:rungame/game-identifier.
If several games share the same identifier you can use the numerical ID (displayed when running lutris --list-games) and add lutris:rungameid/numerical-id.
To install a game, add lutris:install/game-identifier.

Help Options:
  -h, --help                 Show help options
  --help-all                 Show all help options
  --help-gapplication        Show GApplication options
  --help-gtk                 Show GTK+ Options

Application Options:
  -v, --version              Print the version of Lutris and exit
  -d, --debug                Show debug messages
  -i, --install              Install a game from a yml file
  -e, --exec                 Execute a program with the lutris runtime
  -l, --list-games           List all games in database
  -o, --installed            Only list installed games
  -s, --list-steam-games     List available Steam games
  --list-steam-folders       List all known Steam library folders
  -j, --json                 Display the list of games in JSON format
  --reinstall                Reinstall game
  --display=DISPLAY          X display to use

$ lutris -v

(lutris:4042): Gtk-WARNING **: 09:41:24.804: Theme parsing error: gtk.css:127:35: The style property GtkButton:child-displacement-x is deprecated and shouldn't be used anymore. It will be removed in a future version

(lutris:4042): Gtk-WARNING **: 09:41:24.804: Theme parsing error: gtk.css:128:35: The style property GtkButton:child-displacement-y is deprecated and shouldn't be used anymore. It will be removed in a future version

(lutris:4042): Gtk-WARNING **: 09:41:24.805: Theme parsing error: gtk.css:132:46: The style property GtkScrolledWindow:scrollbars-within-bevel is deprecated and shouldn't be used anymore. It will be removed in a future version
lutris-0.4.21.1
[panoramix@obelix ~]$ lutris --version

(lutris:4056): Gtk-WARNING **: 09:41:31.656: Theme parsing error: gtk.css:127:35: The style property GtkButton:child-displacement-x is deprecated and shouldn't be used anymore. It will be removed in a future version

(lutris:4056): Gtk-WARNING **: 09:41:31.656: Theme parsing error: gtk.css:128:35: The style property GtkButton:child-displacement-y is deprecated and shouldn't be used anymore. It will be removed in a future version

(lutris:4056): Gtk-WARNING **: 09:41:31.657: Theme parsing error: gtk.css:132:46: The style property GtkScrolledWindow:scrollbars-within-bevel is deprecated and shouldn't be used anymore. It will be removed in a future version
lutris-0.4.21.1
$


Please post the the content of /usr/bin/lutris and the output of

$ lutris --help
$ pacman -Qkk lutris

Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#7 2018-11-01 09:01:38

progandy
Member
Registered: 2012-05-17
Posts: 3,182

Re: Lutris says it's in 0.4.18.1, but it's suposed to be in 0.4.21.1

0.4.21 does have the version command, maybe there is something wrong with the import path in python.

$ python -v -m lutris.gui.application 2>&1 | grep application
# /usr/lib/python3.7/site-packages/lutris/gui/__pycache__/application.cpython-37.pyc matches /usr/lib/python3.7/site-packages/lutris/gui/application.py
# code object from '/usr/lib/python3.7/site-packages/lutris/gui/__pycache__/application.cpython-37.pyc'
  File "/usr/lib/python3.7/site-packages/lutris/gui/application.py", line 35, in <module>

And did you try it with a new user as Lone_Wolf suggested?


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Offline

#8 2018-11-08 23:36:59

pedrofleck
Member
From: Porto Alegre, Brazil
Registered: 2013-11-17
Posts: 44
Website

Re: Lutris says it's in 0.4.18.1, but it's suposed to be in 0.4.21.1

lutris --help:

 Uso:
  lutris [OPÇÃO…] URI

Run a game directly by adding the parameter lutris:rungame/game-identifier.
If several games share the same identifier you can use the numerical ID (displayed when running lutris --list-games) and add lutris:rungameid/numerical-id.
To install a game, add lutris:install/game-identifier.

Opções de ajuda:
  -h, --help                       Mostra opções de ajuda
  --help-all                       Mostra todas as opções de ajuda
  --help-gapplication              Mostra as opções do GApplication
  --help-gtk                       Mostra as opções do GTK+

Opções de aplicativo:
  -d, --debug                      Show debug messages
  -i, --install                    Install a game from a yml file
  -e, --exec                       Execute a program with the lutris runtime
  -l, --list-games                 List all games in database
  -o, --installed                  Only list installed games
  -s, --list-steam-games           List available Steam games
  --list-steam-folders             List all known Steam library folders
  -j, --json                       Display the list of games in JSON format
  --reinstall                      Reinstall game
  --display=MONITOR                Monitor do X a ser utilizado 

pacman -Qkk lutris says it has a total of 485 files, 0 files modified (free translation)

I have zero knowledge about Python, but it is different from yours.

 $ python -v -m lutris.gui.application 2>&1 | grep application
# /usr/lib/python3.7/lutris/gui/__pycache__/application.cpython-37.pyc matches /usr/lib/python3.7/lutris/gui/application.py
# code object from '/usr/lib/python3.7/lutris/gui/__pycache__/application.cpython-37.pyc'
  File "/usr/lib/python3.7/lutris/gui/application.py", line 32, in <module>

I didn't try a new user because I don't have a lot of time (sorry about the long delay in the response, btw). It won't fix Lutris in my main user too, and it is the only application I know that has this problem.

Offline

#9 2018-11-08 23:42:52

Slithery
Forum Moderator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 2,960

Re: Lutris says it's in 0.4.18.1, but it's suposed to be in 0.4.21.1

pedrofleck wrote:

I didn't try a new user because I don't have a lot of time (sorry about the long delay in the response, btw). It won't fix Lutris in my main user too

That's really not the point - It doesn't matter whether it works or not but the answer to the question is a vital step in pinning down the cause of the issue.

Please post all of the information that we ask for or there's really no point in posting at all - we don't go to the effort of asking questions because they're irrelevant smile


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

Board footer

Powered by FluxBB