You are not logged in.

#1 2018-11-09 09:41:12

Rootsquash
Member
Registered: 2014-06-29
Posts: 17

[Solved] octave won't start (GNU Octave, 4.4.1,'std::out_of_range')

Hi, quick question:

I just tried installing octave, but it won't start:

host ~ # pacman -Syu
host ~ # pacman -Qs octave
host ~ # pacman -S octave
[installing]
user@host ~ $ octave
GNU Octave, version 4.4.1
Copyright (C) 2018 John W. Eaton and others.
This is free software; see the source code for copying conditions.
There is ABSOLUTELY NO WARRANTY; not even for MERCHANTABILITY or
FITNESS FOR A PARTICULAR PURPOSE.  For details, type 'warranty'.

Octave was configured for "x86_64-pc-linux-gnu".

Additional information about Octave is available at https://www.octave.org.

Please contribute if you find this software useful.
For more information, visit https://www.octave.org/get-involved.html

Read https://www.octave.org/bugs.html to learn how to submit bug reports.
For information about changes from previous versions, type 'news'.

terminate called after throwing an instance of 'std::out_of_range'
  what():  basic_string::substr: __pos (which is 17) > this->size() (which is 16)
fatal: caught signal Aborted -- stopping myself...
Aborted (core dumped)
user@host ~ $

Does this justify a bug report (https://bugs.archlinux.org/?project=5&string=octave or upstream?) or does octave work for you guys and it's just my stupidity?

"Rootsquash"

Last edited by Rootsquash (2018-11-12 10:11:38)

Offline

#2 2018-11-09 09:53:16

flortsch
Member
From: Linz, Austria
Registered: 2015-07-21
Posts: 33
Website

Re: [Solved] octave won't start (GNU Octave, 4.4.1,'std::out_of_range')

Just gave it a quick shot and installed the package.
For me it's working, but I think the bug should be reported upstream.

Does the GUI version work for you?

Last edited by flortsch (2018-11-09 09:57:29)

Offline

#3 2018-11-09 10:45:31

mpan
Member
Registered: 2012-08-01
Posts: 446
Website

Re: [Solved] octave won't start (GNU Octave, 4.4.1,'std::out_of_range')

Rootsquash:
Report that upstream. There is some fault in logic that causes invalid arguments to be passed to substr — so not an Arch thing.

It also works for me, so perhaps this is related to configuration. So keep your Octave configuration to facilitate debugging by the GNU team.


Sometimes I’m a bit harsh — don’t get offended too easily!
PGP: 7C848198AE93D3BB | Coreutils SHA2 performance
Russian roulette: curl "https://ptpb.pw/$(cat /dev/urandom | tr -cd [:alnum:] | head -c 4)" | sudo bash

Offline

#4 2018-11-09 11:02:28

Rootsquash
Member
Registered: 2014-06-29
Posts: 17

Re: [Solved] octave won't start (GNU Octave, 4.4.1,'std::out_of_range')

Neither octave nor octave-cli start, they both produce the same error.
rm -r ./config/octave didn't change anything.

I'll report it upstream and then set this thread to "solved", thx.

-> https://savannah.gnu.org/bugs/?55013

Last edited by Rootsquash (2018-11-12 10:10:56)

Offline

Board footer

Powered by FluxBB