You are not logged in.

#1 2018-11-09 12:02:40

dreieck
Member
Registered: 2012-10-08
Posts: 13

[SOLVED]libreoffice-still requires libicuuc.so.62, but .63 is installe

After a full system upgrade, when I want to start [tt]libreoffice[/tt], I get the following messages printed to stderr:

Warning: failed to read path from javaldx
/usr/lib/libreoffice/program/soffice.bin: error while loading shared libraries: libicuuc.so.62: cannot open shared object file: No such file or directory

[tt]ls -F1 /usr/lib/libicuuc.so*[/tt]:

usr/lib/libicuuc.so@
/usr/lib/libicuuc.so.63@
/usr/lib/libicuuc.so.63.1*

[tt]pacman -Qo /usr/lib/libicuuc.so* /usr/lib/libreoffice/program/soffice.bin[/tt]:

/usr/lib/libicuuc.so is owned by icu 63.1-2
/usr/lib/libicuuc.so.63 is owned by icu 63.1-2
/usr/lib/libicuuc.so.63.1 is owned by icu 63.1-2
/usr/lib/libreoffice/program/soffice.bin is owned by libreoffice-still 6.0.6-3

Last edited by dreieck (2018-11-09 12:32:46)

Offline

#2 2018-11-09 12:07:08

Slithery
Forum Moderator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 2,960

Re: [SOLVED]libreoffice-still requires libicuuc.so.62, but .63 is installe

Current version of libreoffice-still in the repos is 6.0.7-1.

Is your mirror up to date?


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

#3 2018-11-09 12:31:04

dreieck
Member
Registered: 2012-10-08
Posts: 13

Re: [SOLVED]libreoffice-still requires libicuuc.so.62, but .63 is installe

Slithery wrote:

Current version of libreoffice-still in the repos is 6.0.7-1.

Is your mirror up to date?

Thanks.

After commenting out http://archlinux.mirror.dkm.cz/pub/arch … o/os/$arch I got a couple of updates.

Offline

Board footer

Powered by FluxBB