You are not logged in.

#1 2018-11-09 12:35:50

jdevelop
Member
Registered: 2014-04-18
Posts: 27

CPU frequency - Thinkpad T540p, kernel 4.18.16 and TLP

I stumbled over some strange problem - the CPU frequency is set to the minimum by TLP no matter whether it is on AC or battery.

cpupower frequency-info 
analyzing CPU 0:
  driver: intel_pstate
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency:  Cannot determine or is not supported.
  hardware limits: 800 MHz - 3.80 GHz
  available cpufreq governors: performance powersave
  current policy: frequency should be within 800 MHz and 800 MHz.
                  The governor "performance" may decide which speed to use
                  within this range.
  current CPU frequency: Unable to call hardware
  current CPU frequency: 798 MHz (asserted by call to kernel)
  boost state support:
    Supported: yes
    Active: yes

relevant section of /etc/default/tlp

CPU_SCALING_GOVERNOR_ON_AC=performance
CPU_SCALING_GOVERNOR_ON_BAT=powersave

CPU_SCALING_MIN_FREQ_ON_AC=1800MHz
CPU_SCALING_MAX_FREQ_ON_AC=2800MHz
CPU_SCALING_MIN_FREQ_ON_BAT=900MHz
CPU_SCALING_MAX_FREQ_ON_BAT=2000MHz

CPU_MIN_PERF_ON_AC=40
CPU_MAX_PERF_ON_AC=100
CPU_MIN_PERF_ON_BAT=20
CPU_MAX_PERF_ON_BAT=50

The battery is okay:

upower -i /org/freedesktop/UPower/devices/battery_BAT0
  native-path:          BAT0
  vendor:               LGC
  model:                45N1153
  serial:               397
  power supply:         yes
  updated:              Fri 09 Nov 2018 07:30:29 AM EST (0 seconds ago)
  has history:          yes
  has statistics:       yes
  battery
    present:             yes
    rechargeable:        yes
    state:               discharging
    warning-level:       none
    energy:              74.33 Wh
    energy-empty:        0 Wh
    energy-full:         93.51 Wh
    energy-full-design:  99.46 Wh
    energy-rate:         16.969 W
    voltage:             11.9 V
    time to empty:       4.4 hours
    percentage:          79%
    capacity:            94.0177%
    technology:          lithium-ion
    icon-name:          'battery-full-symbolic'
  History (charge):
    1541766629  0.000   unknown
  History (rate):
    1541766629  0.000   unknown

and I have 135W power brick.

I can easily set the frequency manually:

cpupower frequency-set -u 2800MHz
Setting cpu: 0
Setting cpu: 1
Setting cpu: 2
Setting cpu: 3
Setting cpu: 4
Setting cpu: 5
Setting cpu: 6
Setting cpu: 7

and then

cpupower frequency-info                               
analyzing CPU 0:
  driver: intel_pstate
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency:  Cannot determine or is not supported.
  hardware limits: 800 MHz - 3.80 GHz
  available cpufreq governors: performance powersave
  current policy: frequency should be within 800 MHz and 2.80 GHz.
                  The governor "performance" may decide which speed to use
                  within this range.
  current CPU frequency: Unable to call hardware
  current CPU frequency: 1.90 GHz (asserted by call to kernel)
  boost state support:
    Supported: yes
    Active: yes

with i7z I can confirm that the frequency is set.


Setting the /sys/module/processor/parameters/ignore_ppc to 1 doesn't help either.

Is that a bug in TLP?

Offline

Board footer

Powered by FluxBB