You are not logged in.

#1 2018-11-10 11:45:58

Yann
Member
Registered: 2017-11-23
Posts: 35

[compton] flickering with i3 since compton-3.0-1

Hi everyone,

Since the compton-3.0-1 update I got flickering screens. I am on 4.18.16-arch1-1-ARCH with i3 version 4.15.0.1-107-g34cf107. I retried with the new compton-3.0-4 version and still have a huge flickering.

I tried to set in my compton.conf:

backend = "xrender"; # instead of backend = "glx";
unredir-if-possible = false;

Flickering still here. Does someone has an idea?

Thanks for your time.

Offline

#2 2018-11-10 16:16:53

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 16,218

Re: [compton] flickering with i3 since compton-3.0-1

You may want to provide more information,   What GPU are you using?
Does everything flicker?  Or just some programs?
What type of display are you using?  What is the interface (LVDS. DHMI, DP, SXGA?....)
interlaced or progressive?
refresh rates?  Screen size?


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#3 2018-11-10 17:27:44

Yann
Member
Registered: 2017-11-23
Posts: 35

Re: [compton] flickering with i3 since compton-3.0-1

Thanks for your reply,

ok, more info:

For the display:         
       description: VGA compatible controller
       product: G96M [GeForce 9600M GT]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nouveau latency=0

The cpu:
          description: CPU
          product: Intel(R) Core(TM)2 Duo CPU     T9400  @ 2.53GHz
          vendor: Intel Corp.
          physical id: 4
          bus info: cpu@0
          version: CPU Version
          slot: U2E1
          size: 2526MHz
          capacity: 2534MHz
          width: 64 bits
          clock: 266MHz


All the programs are flickering, even the i3bar. When I don't have any window open the background is not flickering (only i3 bar, the only program opened).

I have an Acer laptop connected through HDMI to an external screen, both are flickering, the same when I disconnect it. The flickering is permanent but doesn't have a perfect frequency. It's close to three time per second. The primary screen (my laptop) is 1440x900.

Did I give enough infos?

Thanks.

Offline

#4 2018-11-10 18:07:04

x33a
Forum Moderator
Registered: 2009-08-15
Posts: 4,559
Website

Re: [compton] flickering with i3 since compton-3.0-1

Do you get anything in your Xorg log or systemd journal when the flickering is happening?

Offline

#5 2018-11-10 20:35:31

Yann
Member
Registered: 2017-11-23
Posts: 35

Re: [compton] flickering with i3 since compton-3.0-1

No, nothing in particular in both.

Offline

#6 2018-11-10 20:57:05

hiciu
Member
Registered: 2010-08-11
Posts: 82

Re: [compton] flickering with i3 since compton-3.0-1

Hi,

Does this describe your issue? https://github.com/yshui/compton/issues/33

Offline

#7 2018-11-10 21:37:16

Yann
Member
Registered: 2017-11-23
Posts: 35

Re: [compton] flickering with i3 since compton-3.0-1

Yes, it looks very similar.
I understand that you used git bisect to find the bad commit. What do you suggest?

Offline

Board footer

Powered by FluxBB