You are not logged in.

#1 2018-11-14 07:48:25

Troels
Member
From: Denmark
Registered: 2009-03-01
Posts: 11

[SOLVED] Slow input after recent update

Hello

Scrolling, and pretty much everything related to input has become really laggy after I rebooted earlier today. I notice this most in Qutebrowser, but I am quite sure it also affects other apps, although Qutebrowser is the only app in which I scroll with my touchpad.

CPU usage is normal even though scrolling and typing is choppy. Youtube videos play smoothly.

I am quite certain it has something to do with the update yesterday. I suspect it because I earlier this month was trying out the testing repo and encountered the exact same behaviour after a similar upgrade. I didn't want to report a bug, since it was testing, and figured it would be solved by the time it reached the main repos. Apparently not.

I run sway-git on Wayland without Xwayland. I have an Intel and an Nvidia GPU. I don't use the Nvidia one and nouveau is blacklisted.

List of packages included in the suspected upgrade yesterday:

ca-certificates-utils
ca-certificates-mozilla
ca-certificates
libssh2
linux-firmware
popt
linux
mdadm
nss
libxrender
pixman
cairomm
flac
giflib
libasyncns
libcaca
libcanberra
libcroco
libsndfile
libxi
libxtst
libmikmod
libmodplug
libmpcdec
libnotify
libpaper
libraw1394
libsamplerate
libunwind
libxpm
libxv
opencore-amr
speex
t1lib
taglib
uchardet
portaudio
tre

What logs can I more provide?

Last edited by Troels (2018-11-15 06:46:25)

Offline

#2 2018-11-14 07:51:11

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 26,203
Website

Re: [SOLVED] Slow input after recent update

Please use code tags when pasting to the boards: https://wiki.archlinux.org/index.php/Co … s_and_code


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#3 2018-11-15 06:46:06

Troels
Member
From: Denmark
Registered: 2009-03-01
Posts: 11

Re: [SOLVED] Slow input after recent update

I solved it. It turns out the slow performance was due me having set the kernel parameter i915.enable_psr=1. After I removed that the performance returned to normal. So I guess it was after all due to the kernel upgrade.

Offline

Board footer

Powered by FluxBB