You are not logged in.

#1 2018-10-29 21:37:20

afader
Member
Registered: 2013-09-12
Posts: 44

Zsnes opengl or sdl segfault after upgrading

Zsnes used to work fine, but an update to mesa or nvidia proprietary drivers I suspect broke something.

sudo coredumpctl gdb zsnes          
                                                                                                        
           PID: 3762 (zsnes)
           UID: 1000 (andrew)
           GID: 142 (docker)
        Signal: 11 (SEGV)
     Timestamp: Mon 2018-10-29 17:34:05 EDT (7s ago)
  Command Line: zsnes
    Executable: /usr/bin/zsnes
 Control Group: /user.slice/user-1000.slice/session-2.scope
          Unit: session-2.scope
         Slice: user-1000.slice
       Session: 2
     Owner UID: 1000 (andrew)
       Boot ID: e2fee3a7c21a46bebfadd94fe98c9218
    Machine ID: 2e13b14e07a644dd8d93b702997bc463
      Hostname: obsidian
       Storage: /var/lib/systemd/coredump/core.zsnes.1000.e2fee3a7c21a46bebfadd94fe98c9218.3762.1540848845000000.lz4
       Message: Process 3762 (zsnes) of user 1000 dumped core.
                
                Stack trace of thread 3762:
                #0  0x00000000f7645eeb __glDispatchCheckMultithreaded (libGLdispatch.so.0)
                #1  0x00000000f77f89cf glXGetProcAddressARB (libGLX.so.0)
                #2  0x00000000f7dd56db n/a (libSDL-1.2.so.0)
                #3  0x00000000f7dd5bfb n/a (libSDL-1.2.so.0)
                #4  0x00000000f7ddae1a n/a (libSDL-1.2.so.0)
                #5  0x00000000f7ddb3b2 n/a (libSDL-1.2.so.0)
                #6  0x00000000f7dc950e SDL_SetVideoMode (libSDL-1.2.so.0)
                #7  0x0000000056a0c4c7 n/a (zsnes)
                #8  0x0000000056a0a76b n/a (zsnes)
                #9  0x0000000056a0ad3d n/a (zsnes)
                #10 0x0000000056a08334 n/a (zsnes)

Offline

#2 2018-11-01 10:36:50

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 6,362

Re: Zsnes opengl or sdl segfault after upgrading

Zsnes uses multilib(lib32)  packages . Those need to be the same version as their 64-bit counterparts.
Sometimes the multilib version is updated later then then 64-bit version.

post output of pacman -Qs nvidia and pacman -Qs mesa please.

Last edited by Lone_Wolf (2018-11-01 10:37:46)


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#3 2018-11-02 00:22:41

afader
Member
Registered: 2013-09-12
Posts: 44

Re: Zsnes opengl or sdl segfault after upgrading

lib32-nvidia-utils 410.66-1
lib32-opencl-nvidia 410.66-1
nvidia-cg-toolkit 3.1-4
nvidia-dkms 410.66-4
nvidia-settings 410.66-1
nvidia-utils 410.66-1
opencl-nvidia 410.66-1
lib32-mesa 18.2.4-1
lib32-mesa-vdpau 18.2.4-1
libva-mesa-driver 18.2.4-1
mesa 18.2.4-1
mesa-demos 8.4.0-1
mesa-vdpau 18.2.4-1

erlang-sdl 1.3.1-3
et-sdl-sound 29-13
lib32-sdl 1.2.15-7
lib32-sdl2 2.0.9-1
lib32-sdl2_image 2.0.3-1
lib32-sdl2_mixer 2.0.4-1
lib32-sdl2_ttf 2.0.14-2
lib32-sdl_image 1.2.12-4
lib32-sdl_mixer 1.2.12-2
lib32-sdl_ttf 2.0.11-4
perl-alien-sdl 1.446-5
perl-sdl 2.548-1
python2-pygame-sdl2 1:2.1.0.r349.d2ed33b-1
sdl 1.2.15-9
sdl2 2.0.9-1
sdl2_gfx 1:1.0.4-1
sdl2_image 2.0.3-1
sdl2_mixer 2.0.4-1
sdl2_net 1:2.0.1-1
sdl2_ttf 2.0.14-1
sdl_gfx 2.0.26-1
sdl_image 1.2.12-4
sdl_mixer 1.2.12-5
sdl_net 1.2.8-3
sdl_pango 0.1.2-6
sdl_sound 1.0.3-6
sdl_ttf 2.0.11-4

zsnes 1.51-20

Last edited by afader (2018-11-02 00:23:55)

Offline

#4 2018-11-02 11:25:30

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 6,362

Re: Zsnes opengl or sdl segfault after upgrading

Nothing suspicious there, but I did find a bug report where zsnes has  a problem with recent pulseaudio.

Check https://bugs.archlinux.org/task/59249

Was lib32-libpulse in the update just before the problems started ?


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#5 2018-11-02 18:16:26

afader
Member
Registered: 2013-09-12
Posts: 44

Re: Zsnes opengl or sdl segfault after upgrading

Seems like a good thought, I have downgraded all the pulse packages as follows. Doesn't seem to have fixed it though.

lib32-libpulse 11.1-1
libpulse 11.1-1
pulseaudio 11.1-1
pulseaudio-alsa 2-3
pulseaudio-bluetooth 11.1-1
pulseaudio-gconf 11.1-1

I'm wondering if a change like this in zsnes would help: https://github.com/baldurk/renderdoc/co … 9448e28112

Last edited by afader (2018-11-02 19:30:55)

Offline

#6 2018-11-07 11:47:55

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 6,362

Re: Zsnes opengl or sdl segfault after upgrading

We need more info to determine the cause.

Please run zsnes from a x-terminal and post the output.


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#7 2018-11-10 19:01:49

afader
Member
Registered: 2013-09-12
Posts: 44

Re: Zsnes opengl or sdl segfault after upgrading

All it does is segfault and tell me core dumped. However since I last posted, the trace seems to have changed. I had upgraded pulseaudio again, so maybe I'll try downgrading it again.

ZSNES v1.51, (c) 1997-2007, ZSNES Team
Be sure to check http://www.zsnes.com/ for the latest version.

ZSNES is written by the ZSNES Team (See AUTHORS.TXT)
ZSNES comes with ABSOLUTELY NO WARRANTY.  This is free software,
and you are welcome to redistribute it under certain conditions;
please read 'LICENSE.TXT' thoroughly before doing so.

Use ZSNES -? for command line definitions.

Starting Mouse detection.
ManyMouse: 1 mice detected.
[1]    25939 segmentation fault  sudo zsnes
 andrew@obsidian  ~    sudo coredumpctl gdb zsnes                                                   14:00:27  ruby 2.6.0 
           PID: 26282 (zsnes)
           UID: 0 (root)
           GID: 0 (root)
        Signal: 11 (SEGV)
     Timestamp: Sat 2018-11-10 13:59:50 EST (40s ago)
  Command Line: zsnes
    Executable: /usr/bin/zsnes
 Control Group: /user.slice/user-1000.slice/session-2.scope
          Unit: session-2.scope
         Slice: user-1000.slice
       Session: 2
     Owner UID: 1000 (andrew)
       Boot ID: c2dbb4dfaad84d678598c944226c9c90
    Machine ID: 2e13b14e07a644dd8d93b702997bc463
      Hostname: obsidian
       Storage: /var/lib/systemd/coredump/core.zsnes.0.c2dbb4dfaad84d678598c944226c9c90.26282.1541876390000000.lz4
       Message: Process 26282 (zsnes) of user 0 dumped core.
                
                Stack trace of thread 26282:
                #0  0x00000000f5c874e1 pa_smoother_new (libpulsecommon-12.2.so)
                #1  0x00000000f5cf19d4 n/a (libpulse.so.0)
                #2  0x00000000f5ef7585 pa_simple_new (libpulse-simple.so.0)
                #3  0x00000000f7ea61c5 n/a (libSDL-1.2.so.0)
                #4  0x00000000f7e78b63 SDL_AudioInit (libSDL-1.2.so.0)
                #5  0x00000000f7e777c1 SDL_InitSubSystem (libSDL-1.2.so.0)
                #6  0x00000000f7e788ef SDL_OpenAudio (libSDL-1.2.so.0)
                #7  0x00000000569ab95b n/a (zsnes)
                #8  0x00000000569af07d n/a (zsnes)
                #9  0x00000000569ac334 n/a (zsnes)

When I downgrade pulseaudio packages to 11.1 I get this different trace

 andrew@obsidian  ~    sudo coredumpctl gdb zsnes                                                   14:04:50  ruby 2.6.0 
           PID: 31263 (zsnes)
           UID: 1000 (andrew)
           GID: 142 (docker)
        Signal: 11 (SEGV)
     Timestamp: Sat 2018-11-10 14:04:44 EST (7s ago)
  Command Line: zsnes
    Executable: /usr/bin/zsnes
 Control Group: /user.slice/user-1000.slice/session-2.scope
          Unit: session-2.scope
         Slice: user-1000.slice
       Session: 2
     Owner UID: 1000 (andrew)
       Boot ID: c2dbb4dfaad84d678598c944226c9c90
    Machine ID: 2e13b14e07a644dd8d93b702997bc463
      Hostname: obsidian
       Storage: /var/lib/systemd/coredump/core.zsnes.1000.c2dbb4dfaad84d678598c944226c9c90.31263.1541876684000000.lz4
       Message: Process 31263 (zsnes) of user 1000 dumped core.
                
                Stack trace of thread 31263:
                #0  0x00000000f7720eeb __glDispatchCheckMultithreaded (libGLdispatch.so.0)
                #1  0x00000000f78d39cf glXGetProcAddressARB (libGLX.so.0)
                #2  0x00000000f7eb06db n/a (libSDL-1.2.so.0)
                #3  0x00000000f7eb0bfb n/a (libSDL-1.2.so.0)
                #4  0x00000000f7eb5e1a n/a (libSDL-1.2.so.0)
                #5  0x00000000f7eb63b2 n/a (libSDL-1.2.so.0)
                #6  0x00000000f7ea450e SDL_SetVideoMode (libSDL-1.2.so.0)
                #7  0x0000000056a164c7 n/a (zsnes)
                #8  0x0000000056a1476b n/a (zsnes)
                #9  0x0000000056a14d3d n/a (zsnes)
                #10 0x0000000056a12334 n/a (zsnes)

Last edited by afader (2018-11-10 19:05:32)

Offline

#8 2018-11-11 15:34:17

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 6,362

Re: Zsnes opengl or sdl segfault after upgrading

[1]    25939 segmentation fault  sudo zsnes

You have tried running zsnes as normal user ?


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#9 Yesterday 01:56:52

afader
Member
Registered: 2013-09-12
Posts: 44

Re: Zsnes opengl or sdl segfault after upgrading

If I run as a normal user I get this

ZSNES v1.51, (c) 1997-2007, ZSNES Team
Be sure to check http://www.zsnes.com/ for the latest version.

ZSNES is written by the ZSNES Team (See AUTHORS.TXT)
ZSNES comes with ABSOLUTELY NO WARRANTY.  This is free software,
and you are welcome to redistribute it under certain conditions;
please read 'LICENSE.TXT' thoroughly before doing so.

Use ZSNES -? for command line definitions.

Starting Mouse detection.
Unable to poll /dev/input/event18. Make sure you have read permissions to it.
Unable to poll /dev/input/event16. Make sure you have read permissions to it.
Unable to poll /dev/input/event15. Make sure you have read permissions to it.
Unable to poll /dev/input/event14. Make sure you have read permissions to it.
Unable to poll /dev/input/event13. Make sure you have read permissions to it.
Unable to poll /dev/input/event12. Make sure you have read permissions to it.
Unable to poll /dev/input/event11. Make sure you have read permissions to it.
Unable to poll /dev/input/event10. Make sure you have read permissions to it.
Unable to poll /dev/input/event9. Make sure you have read permissions to it.
Unable to poll /dev/input/event8. Make sure you have read permissions to it.
Unable to poll /dev/input/event7. Make sure you have read permissions to it.
Unable to poll /dev/input/event6. Make sure you have read permissions to it.
Unable to poll /dev/input/event5. Make sure you have read permissions to it.
Unable to poll /dev/input/event4. Make sure you have read permissions to it.
Unable to poll /dev/input/event3. Make sure you have read permissions to it.
Unable to poll /dev/input/event2. Make sure you have read permissions to it.
Unable to poll /dev/input/event1. Make sure you have read permissions to it.
Unable to poll /dev/input/event0. Make sure you have read permissions to it.
ManyMouse: 0 mice detected.
[1]    14287 segmentation fault (core dumped)  zsnes

I've also tried starting it from my window manager

Offline

Board footer

Powered by FluxBB