You are not logged in.

#1 2018-11-19 07:23:54

anark10n
Member
Registered: 2012-10-13
Posts: 152

[Solved] Steam doesn't start in online mode

Hey there,

So the problem as the title states. When starting steam, it will attempt to connect to my account, and the pop-up will hang around for a few seconds; but now it sticks around for longer, at which point steam will respond that the it could not connect to the steam network. This happens for any of the steam commands i run, steam, steam-runtime, and steam-native. It can start in offline mode, but the games in my library need to go online to update.

I ran a capture with wireshark to see if there was any traffic at all, and there does appear to be communication with steam servers.

I'm able to log in via my web browser, but i'm guessing the steam client uses a different type of protocol so maybe that's not a helpful metric.

Any ideas on what to troubleshoot to isolate the problem?

Last edited by anark10n (2018-11-22 16:50:07)

Offline

#2 2018-11-19 08:29:36

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 5,718

Re: [Solved] Steam doesn't start in online mode

Output of a terminal run? Did you ensure that the preconditions mentioned in https://wiki.archlinux.org/index.php/Steam#Installation are met?

Offline

#3 2018-11-19 09:11:14

anark10n
Member
Registered: 2012-10-13
Posts: 152

Re: [Solved] Steam doesn't start in online mode

Yes, all of the preconditions are present. It was working before today.

Terminal output for steam-runtime:

Running Steam on arch rolling 64-bit
STEAM_RUNTIME is enabled automatically
Pins up-to-date!
Installing breakpad exception handler for appid(steam)/version(1541819448)
Installing breakpad exception handler for appid(steam)/version(1541819448)
Installing breakpad exception handler for appid(steam)/version(1541819448)
[1119/105431.634070:INFO:crash_reporting.cc(216)] Crash reporting enabled for process: browser
[1119/105431.649465:WARNING:crash_reporting.cc(255)] Failed to set crash key: UserID with value: 0
[1119/105431.649512:WARNING:crash_reporting.cc(255)] Failed to set crash key: BuildID with value: 1541817908
[1119/105431.649515:WARNING:crash_reporting.cc(255)] Failed to set crash key: SteamUniverse with value: Public
[1119/105431.649518:WARNING:crash_reporting.cc(255)] Failed to set crash key: Vendor with value: Valve
[1119/105431.698168:ERROR:gpu_process_transport_factory.cc(1026)] Lost UI shared context.
Installing breakpad exception handler for appid(steam)/version(1541819448)
Installing breakpad exception handler for appid(steam)/version(1541819448)
Installing breakpad exception handler for appid(steam)/version(1541819448)
Installing breakpad exception handler for appid(steam)/version(1541819448)
Installing breakpad exception handler for appid(steam)/version(1541819448)
Installing breakpad exception handler for appid(steam)/version(1541819448)
Installing breakpad exception handler for appid(steam)/version(1541819448)
Installing breakpad exception handler for appid(steam)/version(1541819448)
Installing breakpad exception handler for appid(steam)/version(1541819448)
Installing breakpad exception handler for appid(steam)/version(1541819448)
Installing breakpad exception handler for appid(steam)/version(1541819448)
Installing breakpad exception handler for appid(steam)/version(1541819448)
CApplicationManagerPopulateThread took 35 milliseconds to initialize (will have waited on CAppInfoCacheReadFromDiskThread)
Installing breakpad exception handler for appid(steam)/version(1541819448)
Installing breakpad exception handler for appid(steam)/version(1541819448)
Installing breakpad exception handler for appid(steam)/version(1541819448)
CAppInfoCacheReadFromDiskThread took 64 milliseconds to initialize
Installing breakpad exception handler for appid(steam)/version(1541819448)
Opted-in Controller Mask for AppId 0: 0
Installing breakpad exception handler for appid(steam)/version(1541819448)

(steam:6979): Gtk-WARNING **: 10:54:44.002: gtk_disable_setlocale() must be called before gtk_init()
Installing breakpad exception handler for appid(steam)/version(1541819448)

This is the point at which the client attempts to connect to the steam servers. The pop-up appears, but no output is shown while it tries to connect.
It shows no output when it fails to connect, and just presents the options 'start in offline mode', 'retry the connection', or 'quit'.

No output when i select 'retry the connection'.

Output when i select 'start in offline mode':

Installing breakpad exception handler for appid(steam)/version(1.0)
roaming config store loaded successfully - 1634 bytes.
migrating temporary roaming config store
Failed to init SteamVR because it isn't installed
ExecCommandLine: "'/home/username/.local/share/Steam/ubuntu12_32/steam'"
System startup time: 78.60 seconds
CAPIJobRequestUserStats - No Connection & no schema
[1119/110706.549155:INFO:crash_reporting.cc(239)] Crash reporting enabled for process: renderer
[1119/110706.557986:INFO:crash_reporting.cc(239)] Crash reporting enabled for process: renderer
[1119/110706.586463:WARNING:crash_reporting.cc(255)] Failed to set crash key: UserID with value: 0
[1119/110706.586523:WARNING:crash_reporting.cc(255)] Failed to set crash key: BuildID with value: 1541817908
[1119/110706.586527:WARNING:crash_reporting.cc(255)] Failed to set crash key: SteamUniverse with value: Public
[1119/110706.586529:WARNING:crash_reporting.cc(255)] Failed to set crash key: Vendor with value: Valve
[1119/110706.586940:INFO:crash_reporting.cc(216)] Crash reporting enabled for process: gpu-process

Output after pressing quit

Exiting workitem thread
[2018-11-19 10:54:29] Startup - updater built Nov 10 2018 02:44:20
[2018-11-19 10:54:29] Opted in to client beta 'publicbeta' via beta file
You are in the 'publicbeta' client beta.
[2018-11-19 10:54:30] Verifying installation...
[2018-11-19 10:54:30] Verification complete
[2018-11-19 10:55:50] Shutdown

I noticed that i was opted into the beta client when i was posting the terminal output, so i opted out to see if that solved the issue, but still have the same experience in the standard version.

Last edited by anark10n (2018-11-19 09:11:51)

Offline

#4 2018-11-22 16:49:51

anark10n
Member
Registered: 2012-10-13
Posts: 152

Re: [Solved] Steam doesn't start in online mode

Following commands seemed to resolve going online

rm -r .local/share/Steam 
steam --reset
sudo systemctl restart wicd.service

Now, steam can go online but can't install the games in my library, but the main issue here was solved, so that's progress of a kind

Offline

#5 2018-11-22 19:18:42

headkase
Member
Registered: 2011-12-06
Posts: 1,831

Re: [Solved] Steam doesn't start in online mode

anark10n wrote:

Following commands seemed to resolve going online

rm -r .local/share/Steam 
steam --reset
sudo systemctl restart wicd.service

Now, steam can go online but can't install the games in my library, but the main issue here was solved, so that's progress of a kind

If I recall correctly, "steam --reset" deletes your game cache.  You will have to redownload your games after that.

Offline

Board footer

Powered by FluxBB