You are not logged in.

#1 2018-11-28 02:47:14

Dylanus
Member
Registered: 2018-05-21
Posts: 10

Dell installation - hard drive not showing

Hi everyone,

I'm attempting to install Arch Linux on my new Dell Inspiron 15 7000 to dual boot with Windows. Windows is already installed there. I have shrunk the Windows installation to leave 250G free on the SSD. I disabled secure boot in the boot menu and have successfully booted into the ISO for Arch. Arch does not pick up the hard drive.
Fdisk only lists /dev/sda, which, judging by the size, is clearly the USB stick. Nothing else resembling a hard drive is visible in /dev. I have never seen a problem like this before. Do I need to format the hard drive from Windows somehow? Or change something in the boot menu?

Thanks

Offline

#2 2018-11-28 03:01:48

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 5,723

Re: Dell installation - hard drive not showing

Check if your harddisk is set to RAID mode in your UEFI and switch that to AHCI, not sure if that would have any implications on booting windows though

Last edited by V1del (2018-11-28 03:02:47)

Offline

#3 2018-11-28 03:20:31

Dylanus
Member
Registered: 2018-05-21
Posts: 10

Re: Dell installation - hard drive not showing

That did fix it, thanks. It has indeed made Windows unbootable though. Looks like I'll just have to reinstall.
*Sigh* Windows takes so long to do everything...

Offline

#4 2018-11-28 03:27:45

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 5,723

Re: Dell installation - hard drive not showing

This should™ be adjustable without a complete reinstall iirc, however that's a Windows issue at that point, if you're happy with the solution for Arch please mark the thread as [SOLVED] or similar by editing the title

Offline

Board footer

Powered by FluxBB