You are not logged in.

#1 2018-11-28 07:56:07

pmatos
Member
Registered: 2017-09-03
Posts: 26

docker fails with Invalid cross-device link [SOLVED]

Hi,

I am quite surprised this is happened because I am sure I ran exactly this command line a couple of months ago on arch and had no troubles. Now running ubuntu 16.04 on docker from arch I get:

docker run -it ubuntu:16.04 /bin/bash                                                                                                     
root@fa8067909ccb:/# cd
root@fa8067909ccb:~# apt-get update
...
root@fa8067909ccb:~# apt-get install emacs-nox
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  dbus emacs24-bin-common emacs24-common emacs24-common-non-dfsg emacs24-el emacs24-nox emacsen-common libasound2 libasound2-data libcap-ng0 libdbus-1-3 libexpat1 libffi6 libglib2.0-0
  libglib2.0-data libgmp10 libgnutls30 libgpm2 libhogweed4 libicu55 libidn11 liblockfile-bin liblockfile1 libnettle6 libp11-kit0 libtasn1-6 libxml2 sgml-base shared-mime-info
  xdg-user-dirs xml-core
Suggested packages:
  dbus-user-session | dbus-x11 ncurses-term libasound2-plugins alsa-utils gnutls-bin gpm sgml-base-doc debhelper
The following NEW packages will be installed:
  dbus emacs-nox emacs24-bin-common emacs24-common emacs24-common-non-dfsg emacs24-el emacs24-nox emacsen-common libasound2 libasound2-data libcap-ng0 libdbus-1-3 libexpat1 libffi6
  libglib2.0-0 libglib2.0-data libgmp10 libgnutls30 libgpm2 libhogweed4 libicu55 libidn11 liblockfile-bin liblockfile1 libnettle6 libp11-kit0 libtasn1-6 libxml2 sgml-base
  shared-mime-info xdg-user-dirs xml-core
0 upgraded, 32 newly installed, 0 to remove and 9 not upgraded.
Need to get 47.7 MB of archives.
After this operation, 150 MB of additional disk space will be used.
Do you want to continue? [Y/n]
...
Processing triggers for libc-bin (2.23-0ubuntu10) ...
Processing triggers for systemd (229-4ubuntu21.4) ...
dpkg: error: error creating new backup file '/var/lib/dpkg/status-old': Invalid cross-device link
E: Sub-process /usr/bin/dpkg returned an error code (2)

Does anybody know what's going on? If you try these 3 commands, do you get the same?

Last edited by pmatos (2018-11-28 08:28:56)

Offline

#2 2018-11-28 08:11:03

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 5,716

Re: docker fails with Invalid cross-device link [SOLVED]

Offline

#3 2018-11-28 08:28:40

pmatos
Member
Registered: 2017-09-03
Posts: 26

Re: docker fails with Invalid cross-device link [SOLVED]

Thanks for the related. It helps.

Offline

Board footer

Powered by FluxBB