You are not logged in.

#1 2018-11-28 13:34:48

elifarley
Member
From: Rio de Janeiro
Registered: 2008-03-07
Posts: 37
Website

[Solved] Video goes blank randomly

I have a Lenovo IdeaPad Z400 Touch laptop (Intel Core i7-3520M) with an Intel 3rd gen video controller connected via HDMI to an  LG 29UB67-B Ultra Wide monitor at 2560 * 1080 that I've just bought. The laptop does have a Nvidia card as well, but I'm not using it.

The problem is that the image disappears intermittently as if I had turned off the monitor. After 5 or less seconds, it comes back again.

It happens at random intervals, like 10 minutes, 2 minutes, or even 2 seconds.

Questions:
1) What is the source of this randomness?
2) How do I fix it?

# lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)

# cat /usr/lib/modprobe.d/nvidia.conf
blacklist nouveau

# cat /etc/modprobe.d/i915.conf 
options i915 i915_enable_rc6=7 i915_enable_fbc=1 lvds_downclock=0 fastboot=1 enable_gvt=1

# grep MODULES /etc/mkinitcpio.conf
MODULES=(intel_agp i915 vfat xfs crc32c-intel lz4 lz4_compress)

# uname -a
Linux ideapad 4.18.16-arch1-1-ARCH #1 SMP PREEMPT Sat Oct 20 22:06:45 UTC 2018 x86_64 GNU/Linux

Last edited by elifarley (2018-11-28 20:14:37)

Offline

#2 2018-11-28 14:33:32

seth
Member
Registered: 2012-09-03
Posts: 8,951

Re: [Solved] Video goes blank randomly

https://wiki.archlinux.org/index.php/In … flickering

Also, more details please:
- why did you pass the other options to i915? This issue or something else?
- does this also happens at lower resolutions?
- X11, wayland or console (or all)?
- desktop session type (in case)?
- dmesg, xorg log?
- in case of X11 "xrandr -q -v"
- because "HDMI": cable. It's always the cable™…

Offline

#3 2018-11-28 20:13:14

elifarley
Member
From: Rio de Janeiro
Registered: 2008-03-07
Posts: 37
Website

Re: [Solved] Video goes blank randomly

Looks like the HDMI port on my laptop is a bit loose...

Offline

Board footer

Powered by FluxBB