You are not logged in.

#1 2018-11-29 14:50:22

djg1971
Member
Registered: 2008-09-11
Posts: 148

cupsd using 100% of CPU

We use cups-browsed at my place of work. After last pacman -Syu (this morning) both cups and cups-browsed appeared to be running, and cupsd was using 100% of the CPU on 1 or 2 cores. This happened a couple weeks ago too and I solved the problem by killing the cupsd and then disabling via systemctl disable service.cups. (Meaning I could still print via browsed network printers and cupsd was not hogging CPU cores.)

This morning I updated again and the problem reappeared, but the previous fix doesn't help. To stop the CPU use I have to disable both cups and cups-browsed, but then I can't print even though the printers.conf file is populated with valid information. Usually the cupsd process is still there somehow even after all of the above, though it no longer uses a lot of processor time.

Does anyone know how to fix this properly? I have a feeling I'm not really using systemd correctly here.

Offline

Board footer

Powered by FluxBB