You are not logged in.

#1 2018-12-04 13:10:49

GuybrushThreepwood
Member
Registered: 2018-12-04
Posts: 6

[SOLVED] Slow tty output with fresh archlinux installation

By "slow" I mean slower than the tty output speed I had when performing the installation with the live CD (actually I used a bootable USB).

I am a newbie and I don't know if I'm using the right terminology so, just in case, with "output speed" I mean well... how fast a

ls some-dir

prints the dir's contents.
Or how fast the tty displays man pages when Advancing from one page to the next.

I am used to it being instantaneous.
In fact, on the laptop where I just recently finished installing Linux to the hard drive, when I was installing it booting from the USB, the tty was as fast as I expected.
When I entered

man ls

and advanced a page, that page would display instantly.

Now with the ArchLinux installed on my hard drive, when I enter

man ls

and advance a page, the lines of the new page appear slow enough for me to see the lines moving upwards as if I was scrolling throught a text document with my mouse.

Another thing I noticed but I'm not certain of is that the blinking cursor also blinks slower when I boot from the harddrive than when I boot from the USB.

I googled this issue a lot and even used the post search from this site to look for anyone with the same problem.
But the closest ones I found, were problems with terminal emulators on Xorg.

Can anyone please help me? I swear I made a real effort looking for an answer on the wiki, google, and forums. So if I missed it, it was mere incompetence. If that's the case, please do me a favour and answer this post with a link to the answer.

Important edit: Vi page advancing is as slow as the terminal too, so I deleted the line which said vi did work fast.

Last edited by GuybrushThreepwood (2018-12-04 23:23:01)

Offline

#2 2018-12-04 13:50:30

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 20,437
Website

Re: [SOLVED] Slow tty output with fresh archlinux installation

Is this all in a real tty / console, or are you using X11/Wayland and a terminal emulator?

Have you done any configuration of less or changed your pager (e.g, set environent variables LESS, MANPAGER, and/or PAGER)?


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#3 2018-12-04 13:58:45

GuybrushThreepwood
Member
Registered: 2018-12-04
Posts: 6

Re: [SOLVED] Slow tty output with fresh archlinux installation

Thanks for the quick response.

Yes, this is all in a real tty / console.
I have only installed the base package group (contents: https://www.archlinux.org/groups/x86_64/base/) as the installation guide from the wiki instructs.
I haven't done any configuration of less or changed anything manually.
I only followed the necessary steps pointed by the installation guide on the archlinux wiki.

Last edited by GuybrushThreepwood (2018-12-04 14:01:18)

Offline

#4 2018-12-04 16:31:30

seth
Member
Registered: 2012-09-03
Posts: 8,912

Re: [SOLVED] Slow tty output with fresh archlinux installation

A fundamental difference would be that iirc the installer uses zsh instead of bash, but that doesn't explain the pager behavior.
Another thing could be the invocation of a more specific framebuffer driver by the installation initiramfs or what not. I'd start by comparing complete journals ("journalctl -b" as root) of either system.
Eg. for a dead old radeon system, I figured enforcing "radeon.fastfb=1" boosted the framebufer *A LOT* (videos turned from dia shows to perfectly playable)

Online

#5 2018-12-04 17:45:49

GuybrushThreepwood
Member
Registered: 2018-12-04
Posts: 6

Re: [SOLVED] Slow tty output with fresh archlinux installation

Thanks seth, I didn't know journalctl existed and I can see how its output may be useful for my problem.
I'll upload both outputs to pastebin in separate text files and send the links as soon as I can, which will probably be in 6 - 7 hours starting from now due to personal circumstances.
If I'm lucky enough to find out what's wrong by comparing both outputs myself I'll let you know.

Edit: Sorry, I just realised I didn't address what you pointed out about zsh, so here it goes:
That's the first thing I did to try and fix it: install zsh. I did:

 pacman -S zsh 
 Blah, blah, everything OK 
 zsh 

It switched to zsh, I tried a couple things and it behaved the same as bash in terms of output speed.
Then exploring the wiki I found out a package which configures zsh just as it is on the live CD, so I went:

 pacman -S grml-zsh-config 

And the colours suddenly matched those of the live CD mode, but not the tty output speed.

Last edited by GuybrushThreepwood (2018-12-04 18:30:06)

Offline

#6 2018-12-04 23:21:21

GuybrushThreepwood
Member
Registered: 2018-12-04
Posts: 6

Re: [SOLVED] Slow tty output with fresh archlinux installation

SOLUTION FOUND: I used the boot entry "vga = off".
(Maybe I'll find other problems with it later as I didn't research what constraints this solution imposes on my system).

As promised, here are the outputs of

 journalctl -b 

from:
LIVE CD (archiso kernel): https://pastebin.com/ypvB3gbX
HD INSTALLATION (archlinux kernel): https://pastebin.com/hCT6ZQde

The key difference between the two outputs begins at line 372 for the archlinux kernel log and on line 373 for archiso kernel log.
The archlinux log had this entries the archiso one didn't have:

Dec 04 12:43:15 archlinux kernel: vesafb: mode is 640x480x32, linelength=2560, pages=0
Dec 04 12:43:15 archlinux kernel: vesafb: scrolling: redraw
Dec 04 12:43:15 archlinux kernel: vesafb: Truecolor: size=8:8:8:8, shift=24:16:8:0
Dec 04 12:43:15 archlinux kernel: vesafb: framebuffer at 0xc0000000, mapped to 0x(____ptrval____), using 1216k, total 1216k
Dec 04 12:43:15 archlinux kernel: fbcon: Deferring console take-over
Dec 04 12:43:15 archlinux kernel: fb0: VESA VGA frame buffer device

From there I found out about vesafb (https://www.kernel.org/doc/Documentation/fb/vesafb.txt) and that its mode could be switched with the vga boot parameter (which is deprecated for grub so there's probably a better fix if you look up its equivalent for grub2).
And since I only wanted to work with good ol' text terminal, I deactivated it.

Thanks seth for pointing out the existence of such a command, it really pushed me in the right direction and made me learn new things.
Maybe I should really read one of the books on Linux recommended on the forums.
Thanks for your help seth and Trilby! :D

Offline

#7 2018-12-04 23:28:09

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 20,437
Website

Re: [SOLVED] Slow tty output with fresh archlinux installation

GuybrushThreepwood wrote:

And since I only wanted to work with good ol' text terminal, I deactivated it.

Most of what I do is in the terminal.  But I generally run an X session with a single full screened terminal emulator (st in my case) with some minimal code that barely qualifies as a WM.  This allows for a greater selection of fonts, unicode coverage, and colors for the terminal.  Or in an actually tty, I occasionally use one of the framebuffer terminals for similar reasons (currently I'm using yaft).


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#8 2018-12-05 12:23:40

Stencon281
Member
Registered: 2016-09-21
Posts: 39

Re: [SOLVED] Slow tty output with fresh archlinux installation

GuybrushThreepwood wrote:

SOLUTION FOUND: I used the boot entry "vga = off".
(Maybe I'll find other problems with it later as I didn't research what constraints this solution imposes on my system).

As promised, here are the outputs of

 journalctl -b 

from:
LIVE CD (archiso kernel): https://pastebin.com/ypvB3gbX
HD INSTALLATION (archlinux kernel): https://pastebin.com/hCT6ZQde

The key difference between the two outputs begins at line 372 for the archlinux kernel log and on line 373 for archiso kernel log.
The archlinux log had this entries the archiso one didn't have:

Dec 04 12:43:15 archlinux kernel: vesafb: mode is 640x480x32, linelength=2560, pages=0
Dec 04 12:43:15 archlinux kernel: vesafb: scrolling: redraw
Dec 04 12:43:15 archlinux kernel: vesafb: Truecolor: size=8:8:8:8, shift=24:16:8:0
Dec 04 12:43:15 archlinux kernel: vesafb: framebuffer at 0xc0000000, mapped to 0x(____ptrval____), using 1216k, total 1216k
Dec 04 12:43:15 archlinux kernel: fbcon: Deferring console take-over
Dec 04 12:43:15 archlinux kernel: fb0: VESA VGA frame buffer device

From there I found out about vesafb (https://www.kernel.org/doc/Documentation/fb/vesafb.txt) and that its mode could be switched with the vga boot parameter (which is deprecated for grub so there's probably a better fix if you look up its equivalent for grub2).
And since I only wanted to work with good ol' text terminal, I deactivated it.

Thanks seth for pointing out the existence of such a command, it really pushed me in the right direction and made me learn new things.
Maybe I should really read one of the books on Linux recommended on the forums.
Thanks for your help seth and Trilby! big_smile

by chance do you use an nvidia card?

soooo you simply added vga=off in  /etc/default/grub and this fixed your problem?

like this?

"GRUB_CMDLINE_LINUX_DEFAULT="quiet splash vga=off"

Offline

#9 2018-12-05 14:07:27

GuybrushThreepwood
Member
Registered: 2018-12-04
Posts: 6

Re: [SOLVED] Slow tty output with fresh archlinux installation

Hi Stencon281.
No, the notebook I installed ArchLinux on doesn't have a nvidia card, just a single core 1.73 gHz CPU (Intel Celeron 530 I think).
I didn't check if it has integrated graphics of some kind though, but I'm pretty sure my notebook it's just that CPU and a bunch of SiS devices. Not nvidia anywhere.

Aaaaand yes. I simply added it, then re-generated the grub.cfg file with grub-mkconfig and rebooted.
(I don't have the "splash" entry you used in the example though, just "quiet" and "vga = off").

Offline

#10 2018-12-05 14:27:51

seth
Member
Registered: 2012-09-03
Posts: 8,912

Re: [SOLVED] Slow tty output with fresh archlinux installation

"lspci"?

Online

#11 2018-12-05 17:27:02

GuybrushThreepwood
Member
Registered: 2018-12-04
Posts: 6

Re: [SOLVED] Slow tty output with fresh archlinux installation

Here you go seth:

> lspci
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 671MX
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] AGP Port (virtual PCI-to-PCI bridge)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS968 [MuTIOL Media IO] (rev 01)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 IDE Controller (rev 01)
00:03.0 USB controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.1 USB controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.3 USB controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] 191 Gigabit Ethernet Adapter (rev 02)
00:05.0 IDE interface: Silicon Integrated Systems [SiS] SATA Controller / IDE mode (rev 03)
00:0f.0 Audio device: Silicon Integrated Systems [SiS] Azalia Audio Controller
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 771/671 PCIE VGA Display Adapter (rev 10)

Offline

#12 2018-12-05 20:21:29

seth
Member
Registered: 2012-09-03
Posts: 8,912

Re: [SOLVED] Slow tty output with fresh archlinux installation

Yeah, feared as much - kinda oldish SiS VGA and SiS support has never been good.
The framebuffer console would allow for graphical output (images/videos) but if you don't need that, there's probably no better thing than the VGA console :-(

Online

Board footer

Powered by FluxBB