You are not logged in.

#1 2018-12-06 08:19:29

itsmattson
Member
Registered: 2018-11-22
Posts: 2

NAS shares mounted via fstab cause shutdown stop-job delay

Hi all,

New here. Hoping someone here can point out my potential fault with my fstab. When I shutdown, I have to wait 1m30s for a stop-job to run through. It's always the NAS mounts)

Have I made a mistake? I thought they were supposed to unmount when unused. The shares mount fine, they just don't seem to be letting go before shutdown (even if i wait a few minutes before shutdown). Any help is appreciated smile

Lines in /etc/fstab

//192.168.0.2/Videos      /mnt/nas-videos      cifs      credentials=/home/matt/.smbcredentials,noauto,x-systemd.automount,x-systemd.device-timeout=30,x-systemd.requires=network-online.target,_netdev  0 0
//192.168.0.2/Music      /mnt/nas-music      cifs      credentials=/home/matt/.smbcredentials,noauto,x-systemd.automount,x-systemd.device-timeout=30,x-systemd.requires=network-online.target,_netdev  0 0

Thanks in advance.

Offline

#2 2018-12-06 13:23:46

seth
Member
Registered: 2012-09-03
Posts: 8,900

Re: NAS shares mounted via fstab cause shutdown stop-job delay

I thought they were supposed to unmount when unused.

Nope, try "x-systemd.idle-timeout=5min"

However they should unmount before the network goes does, what raises the question how you configure the network.

Offline

#3 2018-12-08 13:51:04

itsmattson
Member
Registered: 2018-11-22
Posts: 2

Re: NAS shares mounted via fstab cause shutdown stop-job delay

Thanks for your thoughts, seth. I've added the idle timeout flag to my fstab entries.

So those flags aside, network shares I've mounted are supposed to automatically unmount when the network goes down during shutdown? Any chance you can point me in the right direction to figure out why that doesn't seem to occur?

Offline

#4 2018-12-08 14:05:15

seth
Member
Registered: 2012-09-03
Posts: 8,900

Re: NAS shares mounted via fstab cause shutdown stop-job delay

Journal of the boot and again: "the question how you configure the network"

Offline

Board footer

Powered by FluxBB