You are not logged in.

#1 2018-12-08 17:26:12

azurepancake
Member
Registered: 2009-01-19
Posts: 40

rxvt-unicode - Setting Font

I have been having some challenges getting fonts to work within rxvt-unicode.

I installed the terminus-font package with pacman from the community repo. I now try to test it out live within rxvt-unicode:

printf '\e]710;%s\007' "xft:Terminus:pixelsize=12"

However, it appears that maybe it is not finding the font? I simply end up with large, wide spaced letters. I can replace "Terminus" with a random string of characters and I get the same results, which leads me to think it's just defaulting to what I'm seeing.

I feel like I must be overlooking something obvious, even after searching through the "Fonts" and "rxvt-unicode" wiki articles.

Last edited by azurepancake (2018-12-08 17:28:09)

Offline

#2 2018-12-08 17:51:15

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 26,205
Website

Re: rxvt-unicode - Setting Font

Terminus is a bitmap font.


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#3 2018-12-08 18:33:49

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 20,436
Website

Re: rxvt-unicode - Setting Font

https://wiki.archlinux.org/index.php/Fo … tmap_Fonts

Use "xft:xos4 Terminus..." or an XLFD.

Last edited by Trilby (2018-12-08 18:34:21)


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#4 2018-12-08 19:35:24

Kirill Bugaev
Member
Registered: 2018-08-03
Posts: 87

Re: rxvt-unicode - Setting Font

Do not forget to reboot after font installing. Font database is not updated automatically after font installing.

Offline

#5 2018-12-08 19:45:12

loqs
Member
Registered: 2014-03-06
Posts: 6,371

Re: rxvt-unicode - Setting Font

azurepancake wrote:

I installed the terminus-font package with pacman from the community repo. I now try to test it out live within rxvt-unicode:

Kirill Bugaev wrote:

Do not forget to reboot after font installing. Font database is not updated automatically after font installing.

The hooks /usr/share/libalpm/hooks/fontconfig.hook and /usr/share/libalpm/hooks/xorg-mkfontdir.hook should ensure no reboot is required for fonts managed by pacman.

Offline

#6 2018-12-09 17:30:24

azurepancake
Member
Registered: 2009-01-19
Posts: 40

Re: rxvt-unicode - Setting Font

Doing what Trilby suggested did the trick. Thank you!

Offline

#7 2018-12-09 23:33:42

circleface
Member
Registered: 2012-05-26
Posts: 613

Re: rxvt-unicode - Setting Font

Please remember to mark your thread as solved by editing the first post and changing the title to include [SOLVED].

Offline

Board footer

Powered by FluxBB