You are not logged in.

#1 2018-12-08 14:17:36

moreginger
Member
Registered: 2018-12-08
Posts: 2

GDM won't start: Failed to activate service 'org.freedesktop.Accounts'

Since updating last week I can no longer start GDM.

I can switch to a terminal and login. This works briefly, before the system will lock up for a few minutes and then show a non functional GDM login screen. At this point I can switch back to the terminal and use it normally.

I've seen related commentary regarding accountservice. Indeed this has not started: http://ix.io/1vwD

I'm running everything latest including accountsservice 0.6.54+2
Downgrading accounts service to 0.6.50 from my cache doesn't help.

Hardware is Ryzen 5 2400G, running on IGP.

Any advice? Debugging this is quite a long way past my comfort zone.

Offline

#2 2018-12-08 21:19:32

cirrus
Member
From: Glasgow Scotland
Registered: 2012-08-24
Posts: 239
Website

Re: GDM won't start: Failed to activate service 'org.freedesktop.Accounts'

My advice would be to not use a DM to login & startx, use xorg-xinit
and a configured ~/.xinitrc.  IMHO DM's are often troublesome.
Should you decide to take my advice remember to disable the gdm service.
good luck

Edit: im assuming you are not using wayland my bad

echo $XDG_SESSION_TYPE

will tell, check your gdm config file for related wayland configuration.
you could also try editing /etc/gdm/custom.conf and uncomment "WaylandEnable=false"
If all else fails then provide us with the output of

journalctl -b

using a sane pastebin client

Last edited by cirrus (2018-12-08 21:39:00)


Registered Linux User #544546
   Time you enjoyed wasting was not wasted. --John Lennon.

Offline

#3 Yesterday 20:14:26

moreginger
Member
Registered: 2018-12-08
Posts: 2

Re: GDM won't start: Failed to activate service 'org.freedesktop.Accounts'

Thanks for your help cirrus.

Started up again today and this time my boot sequence prompted me to run `systemctl status polkit.service`. I was almost there, just needed one more hop from accountsservice.

Anyway, the error there mentioned libmozjs-52. Turns out I misinterpreted the instructions on archlinux.org and deleted `libmozjs-52.so.0` after upgrade :-/ Now reinstalled from cache and working fine.

Offline

Board footer

Powered by FluxBB